diff mbox series

[1/1] package/gr-osmosdr: add missing host-python-six dependency to python support

Message ID 20230223201733.222573-1-contact@martb.dev
State New
Headers show
Series [1/1] package/gr-osmosdr: add missing host-python-six dependency to python support | expand

Commit Message

Martin Böh Feb. 23, 2023, 8:17 p.m. UTC
Osmosdr failed to build docs when python support is enabled.
[ 41%] Copying osmosdr docstring templates as pybind headers ...
Traceback (most recent call last):
  File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/update_pydoc.py", line 22, in <module>
    from doxyxml import DoxyIndex, DoxyClass, DoxyFriend, DoxyFunction, DoxyFile
  File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/doxyxml/__init__.py", line 69, in <module>
    from .doxyindex import DoxyIndex, DoxyFunction, DoxyParam, DoxyClass, DoxyFile, DoxyNamespace, DoxyGroup, DoxyFriend, DoxyOther
  File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/doxyxml/doxyindex.py", line 31, in <module>
    from .generated import index
  File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/doxyxml/generated/index.py", line 13, in <module>
    from . import compound
  File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/doxyxml/generated/compound.py", line 15, in <module>
    from . import compoundsuper as supermod
  File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/doxyxml/generated/compoundsuper.py", line 15, in <module>
    import six
ModuleNotFoundError: No module named 'six'
make[2]: *** [python/bindings/CMakeFiles/osmosdr_docstrings.dir/build.make:73: python/bindings/docstring_status] Fehler 1
make[1]: *** [CMakeFiles/Makefile2:332: python/bindings/CMakeFiles/osmosdr_docstrings.dir/all] Fehler 2

Signed-off-by: Martin Böh <contact@martb.dev>
---
 package/gr-osmosdr/gr-osmosdr.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Feb. 23, 2023, 10:13 p.m. UTC | #1
Hello Martin,

On Thu, 23 Feb 2023 21:17:33 +0100
Martin Böh via buildroot <buildroot@buildroot.org> wrote:

> Osmosdr failed to build docs when python support is enabled.
> [ 41%] Copying osmosdr docstring templates as pybind headers ...
> Traceback (most recent call last):
>   File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/update_pydoc.py", line 22, in <module>
>     from doxyxml import DoxyIndex, DoxyClass, DoxyFriend, DoxyFunction, DoxyFile
>   File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/doxyxml/__init__.py", line 69, in <module>
>     from .doxyindex import DoxyIndex, DoxyFunction, DoxyParam, DoxyClass, DoxyFile, DoxyNamespace, DoxyGroup, DoxyFriend, DoxyOther
>   File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/doxyxml/doxyindex.py", line 31, in <module>
>     from .generated import index
>   File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/doxyxml/generated/index.py", line 13, in <module>
>     from . import compound
>   File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/doxyxml/generated/compound.py", line 15, in <module>
>     from . import compoundsuper as supermod
>   File "/home/martb/Schreibtisch/DiscoSAT/satos/output/build/gr-osmosdr-0.2.4/docs/doxygen/doxyxml/generated/compoundsuper.py", line 15, in <module>
>     import six
> ModuleNotFoundError: No module named 'six'
> make[2]: *** [python/bindings/CMakeFiles/osmosdr_docstrings.dir/build.make:73: python/bindings/docstring_status] Fehler 1
> make[1]: *** [CMakeFiles/Makefile2:332: python/bindings/CMakeFiles/osmosdr_docstrings.dir/all] Fehler 2
> 
> Signed-off-by: Martin Böh <contact@martb.dev>

Is there potentially a way to disable building documentation instead?
Of course, adding host-python-six in the dependencies is not a huge
deal, but we really don't care about building documentation in the
context of Buildroot.

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/gr-osmosdr/gr-osmosdr.mk b/package/gr-osmosdr/gr-osmosdr.mk
index 89907c1baa..b96a32a221 100644
--- a/package/gr-osmosdr/gr-osmosdr.mk
+++ b/package/gr-osmosdr/gr-osmosdr.mk
@@ -24,7 +24,7 @@  GR_OSMOSDR_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_GR_OSMOSDR_PYTHON),y)
 GR_OSMOSDR_CONF_OPTS += -DENABLE_PYTHON=ON
-GR_OSMOSDR_DEPENDENCIES += python3
+GR_OSMOSDR_DEPENDENCIES += python3 host-python-six
 else
 GR_OSMOSDR_CONF_OPTS += -DENABLE_PYTHON=OFF
 endif