diff mbox series

[v4,4/4] package/libgtk3: fix update-icon-cache on empty directory

Message ID 20230223125612.3156012-1-thomas.devoogdt@barco.com
State Superseded, archived
Delegated to: Thomas Petazzoni
Headers show
Series None | expand

Commit Message

Thomas Devoogdt Feb. 23, 2023, 12:56 p.m. UTC
If both, hicolor-icon-theme (selected by libgtk3-demo) and
adwaita-icon-theme is not selected, then the /usr/share/icons
folder is empty, causing find to fail.

Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>
---
v3:
 - rebased on https://patchwork.ozlabs.org/project/buildroot/list/?series=336254
 - needed to fix the webkitgtk 2.38.5 compilation
   (https://patchwork.ozlabs.org/project/buildroot/patch/20230220090923.2155635-2-thomas.devoogdt@barco.com/)
v4:
 - replace only update-icon-cache when the demos are built to a dir check
---
 package/libgtk3/libgtk3.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Feb. 25, 2023, 9:52 a.m. UTC | #1
Hello Thomas,

On Thu, 23 Feb 2023 13:56:12 +0100
Thomas Devoogdt <thomas@devoogdt.com> wrote:

> If both, hicolor-icon-theme (selected by libgtk3-demo) and
> adwaita-icon-theme is not selected, then the /usr/share/icons
> folder is empty, causing find to fail.
> 
> Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>

Thanks for this work on gtk!

Could you please always resend complete series, even if only one patch
is changed? Otherwise, it's super confusing. We see just PATCH 4/4 in
version 4, and we wonder if the other patches (1/4, 2/4, 3/4) were lost.

> @@ -146,6 +146,7 @@ endef
>  # Create icon-theme.cache for each of the icon directories/themes
>  # It's not strictly necessary but speeds up lookups
>  define LIBGTK3_UPDATE_ICON_CACHE
> +[ ! -d $(TARGET_DIR)/usr/share/icons ] || \

Indentation is not correct, this line should be indented with one tab.

>  	find $(TARGET_DIR)/usr/share/icons -maxdepth 1 -mindepth 1 -type d \
>  		-exec $(HOST_DIR)/bin/gtk-update-icon-cache {} \;
>  endef

Thanks a lot!

Thomas
diff mbox series

Patch

diff --git a/package/libgtk3/libgtk3.mk b/package/libgtk3/libgtk3.mk
index 2821c7eb52..e2dc8eabfb 100644
--- a/package/libgtk3/libgtk3.mk
+++ b/package/libgtk3/libgtk3.mk
@@ -146,6 +146,7 @@  endef
 # Create icon-theme.cache for each of the icon directories/themes
 # It's not strictly necessary but speeds up lookups
 define LIBGTK3_UPDATE_ICON_CACHE
+[ ! -d $(TARGET_DIR)/usr/share/icons ] || \
 	find $(TARGET_DIR)/usr/share/icons -maxdepth 1 -mindepth 1 -type d \
 		-exec $(HOST_DIR)/bin/gtk-update-icon-cache {} \;
 endef