diff mbox series

[next,2/2] package/linux-tools: perf: add OpenCSD support

Message ID 20230222204134.38884-2-ju.o@free.fr
State Accepted
Headers show
Series [next,1/2] package/opencsd: new package | expand

Commit Message

Julien Olivain Feb. 22, 2023, 8:41 p.m. UTC
This commit adds the Arm CoreSight trace data Decoder support to perf.
See: https://docs.kernel.org/trace/coresight/coresight-perf.html

Signed-off-by: Julien Olivain <ju.o@free.fr>
---
 package/linux-tools/linux-tool-perf.mk.in | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni July 30, 2023, 9:26 p.m. UTC | #1
On Wed, 22 Feb 2023 21:41:34 +0100
Julien Olivain <ju.o@free.fr> wrote:

> This commit adds the Arm CoreSight trace data Decoder support to perf.
> See: https://docs.kernel.org/trace/coresight/coresight-perf.html
> 
> Signed-off-by: Julien Olivain <ju.o@free.fr>
> ---
>  package/linux-tools/linux-tool-perf.mk.in | 7 +++++++
>  1 file changed, 7 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/linux-tools/linux-tool-perf.mk.in b/package/linux-tools/linux-tool-perf.mk.in
index dda63cccec..3a16705087 100644
--- a/package/linux-tools/linux-tool-perf.mk.in
+++ b/package/linux-tools/linux-tool-perf.mk.in
@@ -119,6 +119,13 @@  else
 PERF_MAKE_FLAGS += NO_LZMA=1
 endif
 
+ifeq ($(BR2_PACKAGE_OPENCSD),y)
+PERF_DEPENDENCIES += opencsd
+PERF_MAKE_FLAGS += CORESIGHT=1
+# There is no "else CORESIGHT=0" case, because "perf" Makefile uses
+# bare "ifdef CORESIGHT" constructs.
+endif
+
 # We really do not want to build the perf documentation, because it
 # has stringent requirement on the documentation generation tools,
 # like xmlto and asciidoc), which may be lagging behind on some