diff mbox series

[09/15] package/libuio: migrate to new autopoint flag

Message ID 20230221172205.2450111-9-vfazio@xes-inc.com
State Accepted
Headers show
Series [01/15] package/pkg-autotools: drop FOO_GETTEXTIZE_OPTS support | expand

Commit Message

Vincent Fazio Feb. 21, 2023, 5:21 p.m. UTC
From: Vincent Fazio <vfazio@gmail.com>

Drop patch that is no longer necessary after moving to new package flag.
Add patch to fix builds due to missing required files.

Signed-off-by: Vincent Fazio <vfazio@gmail.com>
---
 ...0001-configure-remove-po-Makefile.in.patch | 26 ----------------
 ...c-set-automake-strictness-to-foreign.patch | 31 +++++++++++++++++++
 package/libuio/libuio.mk                      |  2 +-
 3 files changed, 32 insertions(+), 27 deletions(-)
 delete mode 100644 package/libuio/0001-configure-remove-po-Makefile.in.patch
 create mode 100644 package/libuio/0001-configure.ac-set-automake-strictness-to-foreign.patch

Comments

Arnout Vandecappelle March 25, 2023, 8:37 p.m. UTC | #1
On 21/02/2023 18:21, Vincent Fazio wrote:
> From: Vincent Fazio <vfazio@gmail.com>
> 
> Drop patch that is no longer necessary after moving to new package flag.
> Add patch to fix builds due to missing required files.
> 
> Signed-off-by: Vincent Fazio <vfazio@gmail.com>
> ---
>   ...0001-configure-remove-po-Makefile.in.patch | 26 ----------------
>   ...c-set-automake-strictness-to-foreign.patch | 31 +++++++++++++++++++
>   package/libuio/libuio.mk                      |  2 +-
>   3 files changed, 32 insertions(+), 27 deletions(-)
>   delete mode 100644 package/libuio/0001-configure-remove-po-Makefile.in.patch
>   create mode 100644 package/libuio/0001-configure.ac-set-automake-strictness-to-foreign.patch
[snip]
> diff --git a/package/libuio/0001-configure.ac-set-automake-strictness-to-foreign.patch b/package/libuio/0001-configure.ac-set-automake-strictness-to-foreign.patch
> new file mode 100644
> index 0000000000..1ce91f01f3
> --- /dev/null
> +++ b/package/libuio/0001-configure.ac-set-automake-strictness-to-foreign.patch
> @@ -0,0 +1,31 @@
> +From 546e07b2405455c03b7eb0d392c331e189913bc4 Mon Sep 17 00:00:00 2001
> +From: Vincent Fazio <vfazio@xes-inc.com>
> +Date: Tue, 31 Jan 2023 19:06:29 -0600
> +Subject: [PATCH] configure.ac: set automake strictness to foreign
> +
> +libuio does not conform to the GNU's strict layout requirements. [1]
> +
> +Set the strictness to foreign to account for this.
> +
> +[1] https://www.gnu.org/software/automake/manual/html_node/Strictness.html
> +
> +Signed-off-by: Vincent Fazio <vfazio@xes-inc.com>
> +---
> + configure.ac | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/configure.ac b/configure.ac
> +index 101abd3..ef46171 100644
> +--- a/configure.ac
> ++++ b/configure.ac
> +@@ -1,6 +1,6 @@
> + dnl Every other copy of the package version number gets its value from here
> + AC_INIT(libuio, 0.2.8, https://github.com/linutronix/libuio/issues)
> +-AM_INIT_AUTOMAKE
> ++AM_INIT_AUTOMAKE([foreign])

  This looks absolutely applicable upstream, so please create a PR.

  Regards,
  Arnout

> +
> + AM_CONFIG_HEADER(config.h)
> +
> +--
> +2.25.1
> +
> diff --git a/package/libuio/libuio.mk b/package/libuio/libuio.mk
> index a0285277ab..d5019af594 100644
> --- a/package/libuio/libuio.mk
> +++ b/package/libuio/libuio.mk
> @@ -14,7 +14,7 @@ LIBUIO_LIBS = $(TARGET_NLS_LIBS)
>   LIBUIO_INSTALL_STAGING = YES
>   
>   # Fetched from github, no pre-generated configure script provided
> -LIBUIO_GETTEXTIZE = YES
> +LIBUIO_AUTOPOINT = YES
>   LIBUIO_AUTORECONF = YES
>   
>   # Avoid build issue when makeinfo is missing
Arnout Vandecappelle March 27, 2023, 9:24 a.m. UTC | #2
On 26/03/2023 00:44, Vincent Fazio wrote:
> Arnout,
> 
> 
> On Sat, Mar 25, 2023 at 3:37 PM Arnout Vandecappelle <arnout@mind.be 
> <mailto:arnout@mind.be>> wrote:
[snip]
>        This looks absolutely applicable upstream, so please create a PR.
> 
> 
> There's a couple of reasons I did not do this:
> 
> 1. The upstream repo does not look maintained and has moved URLs from what we 
> have in the mk file https://github.com/missinglinkelectronics/libuio 
> (I meant to fix that)

  Hardly a good reason not to send it to the new location :-)

> 2. It does not apply upstream since their in-tree `autogen.sh` creates the 
> missing file. See 
> https://github.com/missinglinkelectronics/libuio/blob/master/autogen.sh 
> Adding a package specific configure command to run autogen or mimic its behavior 
> seemed overkill, the "foreign" patch leveraging autotools infra seemed the 
> cleanest way to fix this

  This is a good reason though. In the future, please document such concerns in 
the commit message of the patch itself.

  I really think we should add a check-package thing to make sure that every 
patch has an Upstream: line, like we already enforce the SoB.

  Regards,
  Arnout


> 
>        Regards,
>        Arnout
> 
> 
> Thanks for looking at this series!
> 
> -Vincent
> 
>      > +
>      > + AM_CONFIG_HEADER(config.h)
>      > +
>      > +--
>      > +2.25.1
>      > +
>      > diff --git a/package/libuio/libuio.mk <http://libuio.mk>
>     b/package/libuio/libuio.mk <http://libuio.mk>
>      > index a0285277ab..d5019af594 100644
>      > --- a/package/libuio/libuio.mk <http://libuio.mk>
>      > +++ b/package/libuio/libuio.mk <http://libuio.mk>
>      > @@ -14,7 +14,7 @@ LIBUIO_LIBS = $(TARGET_NLS_LIBS)
>      >   LIBUIO_INSTALL_STAGING = YES
>      >
>      >   # Fetched from github, no pre-generated configure script provided
>      > -LIBUIO_GETTEXTIZE = YES
>      > +LIBUIO_AUTOPOINT = YES
>      >   LIBUIO_AUTORECONF = YES
>      >
>      >   # Avoid build issue when makeinfo is missing
>
diff mbox series

Patch

diff --git a/package/libuio/0001-configure-remove-po-Makefile.in.patch b/package/libuio/0001-configure-remove-po-Makefile.in.patch
deleted file mode 100644
index 067465cc31..0000000000
--- a/package/libuio/0001-configure-remove-po-Makefile.in.patch
+++ /dev/null
@@ -1,26 +0,0 @@ 
-From c5fa0b778e1c2a7d03ff6e661bdfa2faef878f68 Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@smile.fr>
-Date: Fri, 1 Jul 2016 17:56:30 +0200
-Subject: [PATCH] configure: remove po/Makefile.in
-
-The file po/Makefile.in is automatically added to AC_OUTPUT while using gettexize
-
-Signed-off-by: Romain Naour <romain.naour@smile.fr>
----
- configure.ac | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index f7fb40f..a25e463 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -55,5 +55,4 @@ dnl last but not least
- AC_OUTPUT([Makefile
- 	libuio.dox
- 	libuio-uninstalled.pc
--	libuio.pc
--	po/Makefile.in])
-+	libuio.pc])
--- 
-2.5.5
-
diff --git a/package/libuio/0001-configure.ac-set-automake-strictness-to-foreign.patch b/package/libuio/0001-configure.ac-set-automake-strictness-to-foreign.patch
new file mode 100644
index 0000000000..1ce91f01f3
--- /dev/null
+++ b/package/libuio/0001-configure.ac-set-automake-strictness-to-foreign.patch
@@ -0,0 +1,31 @@ 
+From 546e07b2405455c03b7eb0d392c331e189913bc4 Mon Sep 17 00:00:00 2001
+From: Vincent Fazio <vfazio@xes-inc.com>
+Date: Tue, 31 Jan 2023 19:06:29 -0600
+Subject: [PATCH] configure.ac: set automake strictness to foreign
+
+libuio does not conform to the GNU's strict layout requirements. [1]
+
+Set the strictness to foreign to account for this.
+
+[1] https://www.gnu.org/software/automake/manual/html_node/Strictness.html
+
+Signed-off-by: Vincent Fazio <vfazio@xes-inc.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 101abd3..ef46171 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,6 +1,6 @@
+ dnl Every other copy of the package version number gets its value from here
+ AC_INIT(libuio, 0.2.8, https://github.com/linutronix/libuio/issues)
+-AM_INIT_AUTOMAKE
++AM_INIT_AUTOMAKE([foreign])
+ 
+ AM_CONFIG_HEADER(config.h)
+ 
+-- 
+2.25.1
+
diff --git a/package/libuio/libuio.mk b/package/libuio/libuio.mk
index a0285277ab..d5019af594 100644
--- a/package/libuio/libuio.mk
+++ b/package/libuio/libuio.mk
@@ -14,7 +14,7 @@  LIBUIO_LIBS = $(TARGET_NLS_LIBS)
 LIBUIO_INSTALL_STAGING = YES
 
 # Fetched from github, no pre-generated configure script provided
-LIBUIO_GETTEXTIZE = YES
+LIBUIO_AUTOPOINT = YES
 LIBUIO_AUTORECONF = YES
 
 # Avoid build issue when makeinfo is missing