diff mbox series

[2/5] package/aubio: drop AUBIO_REMOVE_OLD_WAF hook

Message ID 20230208181933.3925279-2-peter@korsgaard.com
State Accepted
Headers show
Series [1/5] package/pkg-waf.mk: drop bundled waf/waflib when external waf is used | expand

Commit Message

Peter Korsgaard Feb. 8, 2023, 6:19 p.m. UTC
As that is now handled by the waf-package infrastructure.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/aubio/aubio.mk | 6 ------
 1 file changed, 6 deletions(-)

Comments

Romain Naour Feb. 8, 2023, 9:08 p.m. UTC | #1
Le 08/02/2023 à 19:19, Peter Korsgaard a écrit :
> As that is now handled by the waf-package infrastructure.
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Reviewed-by: Romain Naour <romain.naour@smile.fr>


> ---
>  package/aubio/aubio.mk | 6 ------
>  1 file changed, 6 deletions(-)
> 
> diff --git a/package/aubio/aubio.mk b/package/aubio/aubio.mk
> index c995fdfac7..64174a113d 100644
> --- a/package/aubio/aubio.mk
> +++ b/package/aubio/aubio.mk
> @@ -21,12 +21,6 @@ AUBIO_CONF_OPTS = \
>  # https://github.com/jackaudio/jack2/issues/898
>  AUBIO_NEEDS_EXTERNAL_WAF = YES
>  
> -# The old waf script bundled in aubio 0.4.9 need to be removed first.
> -define AUBIO_REMOVE_OLD_WAF
> -	$(RM) -fr $(@D)/waf $(@D)/waflib
> -endef
> -AUBIO_POST_EXTRACT_HOOKS = AUBIO_REMOVE_OLD_WAF

Note: the pkg-wag use a PRE_CONFIGURE_HOOKS instead of POST_EXTRACT_HOOKS.

Best regards,
Romain


> -
>  # Add --notests for each build step to avoid running unit tests on the
>  # build machine.
>  AUBIO_WAF_OPTS = --notests
Peter Korsgaard Feb. 10, 2023, 2:11 p.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > As that is now handled by the waf-package infrastructure.
 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
Peter Korsgaard Feb. 10, 2023, 2:12 p.m. UTC | #3
>>>>> "Romain" == Romain Naour <romain.naour@smile.fr> writes:

 > Le 08/02/2023 à 19:19, Peter Korsgaard a écrit :
 >> As that is now handled by the waf-package infrastructure.
 >> 
 >> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

 > Reviewed-by: Romain Naour <romain.naour@smile.fr>


 >> ---
 >> package/aubio/aubio.mk | 6 ------
 >> 1 file changed, 6 deletions(-)
 >> 
 >> diff --git a/package/aubio/aubio.mk b/package/aubio/aubio.mk
 >> index c995fdfac7..64174a113d 100644
 >> --- a/package/aubio/aubio.mk
 >> +++ b/package/aubio/aubio.mk
 >> @@ -21,12 +21,6 @@ AUBIO_CONF_OPTS = \
 >> # https://github.com/jackaudio/jack2/issues/898
 >> AUBIO_NEEDS_EXTERNAL_WAF = YES
 >> 
 >> -# The old waf script bundled in aubio 0.4.9 need to be removed first.
 >> -define AUBIO_REMOVE_OLD_WAF
 >> -	$(RM) -fr $(@D)/waf $(@D)/waflib
 >> -endef
 >> -AUBIO_POST_EXTRACT_HOOKS = AUBIO_REMOVE_OLD_WAF

 > Note: the pkg-wag use a PRE_CONFIGURE_HOOKS instead of POST_EXTRACT_HOOKS.

Correct. I don't think that has any functional change, but I did change
the waf-package logic to use a post-patch hook as suggested by Yann.
diff mbox series

Patch

diff --git a/package/aubio/aubio.mk b/package/aubio/aubio.mk
index c995fdfac7..64174a113d 100644
--- a/package/aubio/aubio.mk
+++ b/package/aubio/aubio.mk
@@ -21,12 +21,6 @@  AUBIO_CONF_OPTS = \
 # https://github.com/jackaudio/jack2/issues/898
 AUBIO_NEEDS_EXTERNAL_WAF = YES
 
-# The old waf script bundled in aubio 0.4.9 need to be removed first.
-define AUBIO_REMOVE_OLD_WAF
-	$(RM) -fr $(@D)/waf $(@D)/waflib
-endef
-AUBIO_POST_EXTRACT_HOOKS = AUBIO_REMOVE_OLD_WAF
-
 # Add --notests for each build step to avoid running unit tests on the
 # build machine.
 AUBIO_WAF_OPTS = --notests