diff mbox series

[2/5] package/libva: switch to meson

Message ID 20230130174339.36794-2-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/5] package/libva: bump version to 2.17.0 | expand

Commit Message

Bernd Kuhls Jan. 30, 2023, 5:43 p.m. UTC
The time between version 2.17.0 being tagged and the release of its
tarball version containing autoconf scripts was three weeks now.
With the switch to meson we can directly use the github-generated
tarball while not needing to run autoreconf.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/libva/libva.hash |  4 +---
 package/libva/libva.mk   | 19 +++++++++----------
 2 files changed, 10 insertions(+), 13 deletions(-)

Comments

Thomas Petazzoni Jan. 30, 2023, 9:11 p.m. UTC | #1
On Mon, 30 Jan 2023 18:43:36 +0100
Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

> -# From https://github.com/intel/libva/releases/download/2.17.0/libva-2.17.0.tar.bz2.sha1sum
> -sha1  997f7b3111bc5a4d32ec72e9d7f9fcfca41e4923  libva-2.17.0.tar.bz2
>  # Locally computed
> -sha256  f3e5eb27c305e05a9bb62703d1915a127301cc0c4f9f209025767432230c4eac  libva-2.17.0.tar.bz2
> +sha256  8940541980ef998a36cd8f6ad905e81838ea4ddf56dc479ed2bebd12711e6001  libva-2.17.0.tar.gz

Are you sure about this hash?

ERROR: libva-2.17.0.tar.gz has wrong sha256 hash:
ERROR: expected: 8940541980ef998a36cd8f6ad905e81838ea4ddf56dc479ed2bebd12711e6001
ERROR: got     : 2f3bb42b54c6c10f23ba61c00402354b7e408c6325d69cf7b353cf35e1f025c0
ERROR: Incomplete download, or man-in-the-middle (MITM) attack

Could you double check?

Thanks!

Thomas
Thomas Petazzoni Feb. 8, 2023, 8:57 a.m. UTC | #2
On Mon, 30 Jan 2023 18:43:36 +0100
Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

> The time between version 2.17.0 being tagged and the release of its
> tarball version containing autoconf scripts was three weeks now.
> With the switch to meson we can directly use the github-generated
> tarball while not needing to run autoreconf.
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/libva/libva.hash |  4 +---
>  package/libva/libva.mk   | 19 +++++++++----------
>  2 files changed, 10 insertions(+), 13 deletions(-)

Github has fixed their tarball generation logic so that the hashes are
now correct again, so I've applied!

Thomas
diff mbox series

Patch

diff --git a/package/libva/libva.hash b/package/libva/libva.hash
index 700ace0378..780c186069 100644
--- a/package/libva/libva.hash
+++ b/package/libva/libva.hash
@@ -1,5 +1,3 @@ 
-# From https://github.com/intel/libva/releases/download/2.17.0/libva-2.17.0.tar.bz2.sha1sum
-sha1  997f7b3111bc5a4d32ec72e9d7f9fcfca41e4923  libva-2.17.0.tar.bz2
 # Locally computed
-sha256  f3e5eb27c305e05a9bb62703d1915a127301cc0c4f9f209025767432230c4eac  libva-2.17.0.tar.bz2
+sha256  8940541980ef998a36cd8f6ad905e81838ea4ddf56dc479ed2bebd12711e6001  libva-2.17.0.tar.gz
 sha256  c86a782ee845b52472dae9b9d79fb915d333628ac0efe49cdce63644814931de  COPYING
diff --git a/package/libva/libva.mk b/package/libva/libva.mk
index c6b9f63b10..f50010d9fc 100644
--- a/package/libva/libva.mk
+++ b/package/libva/libva.mk
@@ -5,8 +5,7 @@ 
 ################################################################################
 
 LIBVA_VERSION = 2.17.0
-LIBVA_SOURCE = libva-$(LIBVA_VERSION).tar.bz2
-LIBVA_SITE = https://github.com/intel/libva/releases/download/$(LIBVA_VERSION)
+LIBVA_SITE = $(call github,intel,libva,$(LIBVA_VERSION))
 LIBVA_LICENSE = MIT
 LIBVA_LICENSE_FILES = COPYING
 LIBVA_INSTALL_STAGING = YES
@@ -14,25 +13,25 @@  LIBVA_DEPENDENCIES = host-pkgconf libdrm
 
 # libdrm is a hard-dependency
 LIBVA_CONF_OPTS = \
-	--enable-drm \
-	--with-drivers-path="/usr/lib/va"
+	-Ddisable_drm=false \
+	-Ddriverdir="/usr/lib/va"
 
 ifeq ($(BR2_PACKAGE_XORG7),y)
 LIBVA_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXfixes
-LIBVA_CONF_OPTS += --enable-x11
+LIBVA_CONF_OPTS += -Dwith_x11=yes
 ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
 LIBVA_DEPENDENCIES += libgl
-LIBVA_CONF_OPTS += --enable-glx
+LIBVA_CONF_OPTS += -Dwith_glx=yes
 endif
 else
-LIBVA_CONF_OPTS += --disable-glx --disable-x11
+LIBVA_CONF_OPTS += -Dwith_glx=no -Dwith_x11=no
 endif
 
 ifeq ($(BR2_PACKAGE_WAYLAND),y)
 LIBVA_DEPENDENCIES += wayland
-LIBVA_CONF_OPTS += --enable-wayland
+LIBVA_CONF_OPTS += -Dwith_wayland=yes
 else
-LIBVA_CONF_OPTS += --disable-wayland
+LIBVA_CONF_OPTS += -Dwith_wayland=no
 endif
 
-$(eval $(autotools-package))
+$(eval $(meson-package))