diff mbox series

[1/1] package/neon-2-sse: fix build without C++ toolchain

Message ID 20230130041009.3531224-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/neon-2-sse: fix build without C++ toolchain | expand

Commit Message

James Hilliard Jan. 30, 2023, 4:10 a.m. UTC
The cmake project for neon-2-sse doesn't correctly set the project
language to C which causes cmake to try and detect a C++ compiler.

Add a patch which fixes the project language setting.

Fixes:
 - http://autobuild.buildroot.net/results/0eb/0ebb8c886e0a432b6fb43ab21010f625f6797b9e
 - http://autobuild.buildroot.net/results/a5d/a5db2f286dbd69e84d518d086df857ef434b936a

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 .../neon-2-sse/0001-Fix-cmake-languages.patch | 40 +++++++++++++++++++
 1 file changed, 40 insertions(+)
 create mode 100644 package/neon-2-sse/0001-Fix-cmake-languages.patch

Comments

Yann E. MORIN Jan. 30, 2023, 7:07 a.m. UTC | #1
James, All,

On 2023-01-29 21:10 -0700, James Hilliard spake thusly:
> The cmake project for neon-2-sse doesn't correctly set the project
> language to C which causes cmake to try and detect a C++ compiler.
> 
> Add a patch which fixes the project language setting.
> 
> Fixes:
>  - http://autobuild.buildroot.net/results/0eb/0ebb8c886e0a432b6fb43ab21010f625f6797b9e
>  - http://autobuild.buildroot.net/results/a5d/a5db2f286dbd69e84d518d086df857ef434b936a
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  .../neon-2-sse/0001-Fix-cmake-languages.patch | 40 +++++++++++++++++++
>  1 file changed, 40 insertions(+)
>  create mode 100644 package/neon-2-sse/0001-Fix-cmake-languages.patch
> 
> diff --git a/package/neon-2-sse/0001-Fix-cmake-languages.patch b/package/neon-2-sse/0001-Fix-cmake-languages.patch
> new file mode 100644
> index 0000000000..e0becb1ffa
> --- /dev/null
> +++ b/package/neon-2-sse/0001-Fix-cmake-languages.patch
> @@ -0,0 +1,40 @@
> +From 186ec82e033d8c718d760d14945535a9d7e160fd Mon Sep 17 00:00:00 2001
> +From: James Hilliard <james.hilliard1@gmail.com>
> +Date: Sun, 29 Jan 2023 21:00:27 -0700
> +Subject: [PATCH] Fix cmake languages
> +
> +When no language is set cmake defaults to C and CXX, since we support
> +C by itself we should set the project language to C so that we don't
> +get a compiler error when building without a CXX toolchain.
> +
> +Fixes:
> +CMake Error at CMakeLists.txt:5 (project):
> +  No CMAKE_CXX_COMPILER could be found.
> +
> +  Tell CMake where to find the compiler by setting either the environment
> +  variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
> +  to the compiler, or to the compiler name if it is in the PATH.
> +
> +Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> +[Upstream status:
> +https://github.com/intel/ARM_NEON_2_x86_SSE/pull/62]
> +---
> + CMakeLists.txt | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/CMakeLists.txt b/CMakeLists.txt
> +index e4b8980..8f58e79 100644
> +--- a/CMakeLists.txt
> ++++ b/CMakeLists.txt
> +@@ -2,7 +2,7 @@
> + # Modification: Copyright (C) 2017 David Hirvonen
> + 
> + cmake_minimum_required(VERSION 3.0)
> +-project(NEON_2_SSE VERSION 1.0.0)
> ++project(NEON_2_SSE VERSION 1.0.0 LANGUAGES C)
> + 
> + add_library(${PROJECT_NAME} INTERFACE)
> + 
> +-- 
> +2.34.1
> +
> -- 
> 2.34.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/neon-2-sse/0001-Fix-cmake-languages.patch b/package/neon-2-sse/0001-Fix-cmake-languages.patch
new file mode 100644
index 0000000000..e0becb1ffa
--- /dev/null
+++ b/package/neon-2-sse/0001-Fix-cmake-languages.patch
@@ -0,0 +1,40 @@ 
+From 186ec82e033d8c718d760d14945535a9d7e160fd Mon Sep 17 00:00:00 2001
+From: James Hilliard <james.hilliard1@gmail.com>
+Date: Sun, 29 Jan 2023 21:00:27 -0700
+Subject: [PATCH] Fix cmake languages
+
+When no language is set cmake defaults to C and CXX, since we support
+C by itself we should set the project language to C so that we don't
+get a compiler error when building without a CXX toolchain.
+
+Fixes:
+CMake Error at CMakeLists.txt:5 (project):
+  No CMAKE_CXX_COMPILER could be found.
+
+  Tell CMake where to find the compiler by setting either the environment
+  variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
+  to the compiler, or to the compiler name if it is in the PATH.
+
+Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
+[Upstream status:
+https://github.com/intel/ARM_NEON_2_x86_SSE/pull/62]
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e4b8980..8f58e79 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,7 +2,7 @@
+ # Modification: Copyright (C) 2017 David Hirvonen
+ 
+ cmake_minimum_required(VERSION 3.0)
+-project(NEON_2_SSE VERSION 1.0.0)
++project(NEON_2_SSE VERSION 1.0.0 LANGUAGES C)
+ 
+ add_library(${PROJECT_NAME} INTERFACE)
+ 
+-- 
+2.34.1
+