diff mbox series

[v2] package/oatpp:: new package

Message ID 20230129212256.1027790-1-a.partesotti@gmail.com
State Superseded
Headers show
Series [v2] package/oatpp:: new package | expand

Commit Message

Alessandro Partesotti Jan. 29, 2023, 9:22 p.m. UTC
This package introduce oatpp in BR buildsystem.
Oatpp must be used as static library as upstreaam suggest.

Signed-off-by: Alessandro Partesotti <a.partesotti@gmail.com>
---
Changes v1 -> v2
- indentation and spaces (suggested by Yann E. MORIN)
- generic macro changes (suggested by Yann E. MORIN)

Signed-off-by: Alessandro Partesotti <a.partesotti@gmail.com>
---
 package/Config.in        |  1 +
 package/oatpp/Config.in  | 13 +++++++++++++
 package/oatpp/oatpp.hash |  2 ++
 package/oatpp/oatpp.mk   | 16 ++++++++++++++++
 4 files changed, 32 insertions(+)
 create mode 100644 package/oatpp/Config.in
 create mode 100644 package/oatpp/oatpp.hash
 create mode 100644 package/oatpp/oatpp.mk
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index 995dae2c57..c7394ae53d 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1941,6 +1941,7 @@  menu "Networking"
 	source "package/nss-mdns/Config.in"
 	source "package/nss-myhostname/Config.in"
 	source "package/nss-pam-ldapd/Config.in"
+	source "package/oatpp/Config.in"
 	source "package/omniorb/Config.in"
 	source "package/open-isns/Config.in"
 	source "package/open62541/Config.in"
diff --git a/package/oatpp/Config.in b/package/oatpp/Config.in
new file mode 100644
index 0000000000..44f0fabed8
--- /dev/null
+++ b/package/oatpp/Config.in
@@ -0,0 +1,13 @@ 
+comment "Oat++ needs a toolchain w/ C++"
+	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
+
+config BR2_PACKAGE_OATPP
+	bool "Oat++"
+	depends on BR2_INSTALL_LIBSTDCPP
+	depends on BR2_TOOLCHAIN_HAS_THREADS
+	help
+	  Oat++ is an open-source C++ web framework for highly
+	  scalable and resource-efficient web applications.
+	  It provides all the necessary components for
+	  production-grade development.
+	  See https://oatpp.io/docs/start
diff --git a/package/oatpp/oatpp.hash b/package/oatpp/oatpp.hash
new file mode 100644
index 0000000000..fadea2a05f
--- /dev/null
+++ b/package/oatpp/oatpp.hash
@@ -0,0 +1,2 @@ 
+# Hash from: https://github.com/oatpp/oatpp/archive/1.3.0/oatpp-1.3.0.tar.gz
+sha512  4fe8587efe1b4ecae14554ec8edb209e5558a3e4a4e6ff49bbfaaf06d2cc12f2cc306c5edc43b8dafc465aff53098ad4bebb9971694761b91a553730d5acb59a  oatpp-1.3.0.tar.gz
diff --git a/package/oatpp/oatpp.mk b/package/oatpp/oatpp.mk
new file mode 100644
index 0000000000..d146d05d53
--- /dev/null
+++ b/package/oatpp/oatpp.mk
@@ -0,0 +1,16 @@ 
+################################################################################
+#
+# oatpp
+#
+################################################################################
+
+OATPP_VERSION = 1.3.0
+OATPP_LICENSE = Apache-2.0
+OATPP_LICENSE_FILES = LICENSE
+OATPP_SITE = $(call github,oatpp,oatpp,$(OATPP_VERSION))
+OATPP_CMAKE_OPTS = -DBUILD_SHARED_LIBS=OFF
+OATPP_INSTALL_STAGING= YES
+# Only builds a static lib:
+OATPP_INSTALL_TARGET= NO
+
+$(eval $(cmake-package))