diff mbox series

package/kvm-unit-tests: bump to version 2023-01-05

Message ID 20230128060349.4029-1-huth@tuxfamily.org
State Accepted
Headers show
Series package/kvm-unit-tests: bump to version 2023-01-05 | expand

Commit Message

Thomas Huth Jan. 28, 2023, 6:03 a.m. UTC
A new kvm-unit-tests version has recently been tagged, so let's
update to that version now.
This new version now features a --disable-werror parameter for
the configure script, so we can drop the patch for disabling
this manually now.

Signed-off-by: Thomas Huth <huth@tuxfamily.org>
---
 ...emove-Werror-to-avoid-build-failures.patch | 30 -------------------
 package/kvm-unit-tests/kvm-unit-tests.hash    |  2 +-
 package/kvm-unit-tests/kvm-unit-tests.mk      |  3 +-
 3 files changed, 3 insertions(+), 32 deletions(-)
 delete mode 100644 package/kvm-unit-tests/0001-Makefile-remove-Werror-to-avoid-build-failures.patch

Comments

Thomas Petazzoni Jan. 28, 2023, 10:03 p.m. UTC | #1
On Sat, 28 Jan 2023 07:03:49 +0100
Thomas Huth <huth@tuxfamily.org> wrote:

> A new kvm-unit-tests version has recently been tagged, so let's
> update to that version now.
> This new version now features a --disable-werror parameter for
> the configure script, so we can drop the patch for disabling
> this manually now.
> 
> Signed-off-by: Thomas Huth <huth@tuxfamily.org>
> ---
>  ...emove-Werror-to-avoid-build-failures.patch | 30 -------------------
>  package/kvm-unit-tests/kvm-unit-tests.hash    |  2 +-
>  package/kvm-unit-tests/kvm-unit-tests.mk      |  3 +-
>  3 files changed, 3 insertions(+), 32 deletions(-)
>  delete mode 100644 package/kvm-unit-tests/0001-Makefile-remove-Werror-to-avoid-build-failures.patch

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/kvm-unit-tests/0001-Makefile-remove-Werror-to-avoid-build-failures.patch b/package/kvm-unit-tests/0001-Makefile-remove-Werror-to-avoid-build-failures.patch
deleted file mode 100644
index d07b9b6912..0000000000
--- a/package/kvm-unit-tests/0001-Makefile-remove-Werror-to-avoid-build-failures.patch
+++ /dev/null
@@ -1,30 +0,0 @@ 
-From 08e14a662b9e75daec29722e49150869952ba1b6 Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Mon, 20 Nov 2017 22:09:39 +0100
-Subject: [PATCH] Makefile: remove -Werror to avoid build failures
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-[Matthew: Refactoring of Thomas Petazzoni's original.]
-Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
-[Fabrice: updated for 2022-03-08]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- Makefile | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 7231334..d9ad42b 100644
---- a/Makefile
-+++ b/Makefile
-@@ -53,7 +53,7 @@ cc-option = $(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null \
- 
- COMMON_CFLAGS += -g $(autodepend-flags) -fno-strict-aliasing -fno-common
- COMMON_CFLAGS += -Wall -Wwrite-strings -Wempty-body -Wuninitialized
--COMMON_CFLAGS += -Wignored-qualifiers -Werror -Wno-missing-braces
-+COMMON_CFLAGS += -Wignored-qualifiers -Wno-missing-braces
-
- frame-pointer-flag=-f$(if $(KEEP_FRAME_POINTER),no-,)omit-frame-pointer
- fomit_frame_pointer := $(call cc-option, $(frame-pointer-flag), "")
-- 
-2.14.2
-
diff --git a/package/kvm-unit-tests/kvm-unit-tests.hash b/package/kvm-unit-tests/kvm-unit-tests.hash
index 42c3b4a241..3b6d02dd8e 100644
--- a/package/kvm-unit-tests/kvm-unit-tests.hash
+++ b/package/kvm-unit-tests/kvm-unit-tests.hash
@@ -1,3 +1,3 @@ 
 # Locally computed
-sha256  c2edf2b188033a5d634150ecc797c797a85e5af8e3ef4ac3e583f60b2ee7bcf3  kvm-unit-tests-v2022-03-08.tar.bz2
+sha256  9c9b093ffe3fa33145a53102de9c3e2d55cd0cdc8a20cf172b726296ffe22f4f  kvm-unit-tests-v2023-01-05.tar.bz2
 sha256  d9bbb60891710d248f01c8bdac50ef7ad39188de512610437872e83112b38a1b  COPYRIGHT
diff --git a/package/kvm-unit-tests/kvm-unit-tests.mk b/package/kvm-unit-tests/kvm-unit-tests.mk
index dd8f153710..956f07b304 100644
--- a/package/kvm-unit-tests/kvm-unit-tests.mk
+++ b/package/kvm-unit-tests/kvm-unit-tests.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-KVM_UNIT_TESTS_VERSION = 2022-03-08
+KVM_UNIT_TESTS_VERSION = 2023-01-05
 KVM_UNIT_TESTS_SOURCE = kvm-unit-tests-v$(KVM_UNIT_TESTS_VERSION).tar.bz2
 KVM_UNIT_TESTS_SITE = https://gitlab.com/kvm-unit-tests/kvm-unit-tests/-/archive/v$(KVM_UNIT_TESTS_VERSION)
 KVM_UNIT_TESTS_LICENSE = GPL-2.0, LGPL-2.0
@@ -31,6 +31,7 @@  KVM_UNIT_TESTS_ENDIAN = big
 endif
 
 KVM_UNIT_TESTS_CONF_OPTS =\
+	--disable-werror \
 	--arch="$(KVM_UNIT_TESTS_ARCH)" \
 	--processor="$(GCC_TARGET_CPU)" \
 	--endian="$(KVM_UNIT_TESTS_ENDIAN)"