diff mbox series

[v1,1/1] configs/versal_vck190_defconfig: use Xilinx github for versal-firmware

Message ID 20230127105305.25877-1-neal.frager@amd.com
State Accepted
Headers show
Series [v1,1/1] configs/versal_vck190_defconfig: use Xilinx github for versal-firmware | expand

Commit Message

Neal Frager Jan. 27, 2023, 10:53 a.m. UTC
Migrate versal-firmware package from nealfrager github to Xilinx github.
The images are identical, so this patch has zero impact on functionality.

Signed-off-by: Neal Frager <neal.frager@amd.com>
---
 configs/versal_vck190_defconfig            | 2 +-
 package/versal-firmware/Config.in          | 2 +-
 package/versal-firmware/versal-firmware.mk | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni Feb. 7, 2023, 10:43 a.m. UTC | #1
On Fri, 27 Jan 2023 10:53:05 +0000
Neal Frager via buildroot <buildroot@buildroot.org> wrote:

> Migrate versal-firmware package from nealfrager github to Xilinx github.
> The images are identical, so this patch has zero impact on functionality.
> 
> Signed-off-by: Neal Frager <neal.frager@amd.com>
> ---
>  configs/versal_vck190_defconfig            | 2 +-
>  package/versal-firmware/Config.in          | 2 +-
>  package/versal-firmware/versal-firmware.mk | 2 +-
>  3 files changed, 3 insertions(+), 3 deletions(-)

I've applied, but to be honest, it still looks a bit weird. The branch
on the repo is special for Buildroot, and its contents are completely
different than the master branch of the ubuntu-firmware repository. Why
are those firmware files specific to Ubuntu, or specific to Buildroot?
They should normally be distro/build-system agnostic.

Best regards,

Thomas
Nayab Sayed via buildroot Feb. 7, 2023, 10:48 a.m. UTC | #2
Hi Thomas,

> Migrate versal-firmware package from nealfrager github to Xilinx github.
> The images are identical, so this patch has zero impact on functionality.
> 
> Signed-off-by: Neal Frager <neal.frager@amd.com>
> ---
>  configs/versal_vck190_defconfig            | 2 +-
>  package/versal-firmware/Config.in          | 2 +-
>  package/versal-firmware/versal-firmware.mk | 2 +-
>  3 files changed, 3 insertions(+), 3 deletions(-)

> I've applied, but to be honest, it still looks a bit weird. The branch on the repo is special for Buildroot, and its contents are completely different than the master branch of the ubuntu-firmware repository. Why are those firmware files specific to Ubuntu, or specific to Buildroot?
> They should normally be distro/build-system agnostic.

Yes, I fully agree with you.  We will have a proper firmware repo agnostic to ubuntu starting with our 2023.1 release.

In the meantime, Terry O'Neal implemented this solution as a temporary one for 2022.2, so that we could get off of using my private github.

I am confident that our 2023.1 solution will clean this up.

Best regards,
Neal Frager
AMD
Thomas Petazzoni Feb. 7, 2023, 11:07 a.m. UTC | #3
Hello,

On Tue, 7 Feb 2023 10:48:53 +0000
"Frager, Neal" <neal.frager@amd.com> wrote:

> Yes, I fully agree with you.  We will have a proper firmware repo
> agnostic to ubuntu starting with our 2023.1 release.
> 
> In the meantime, Terry O'Neal implemented this solution as a
> temporary one for 2022.2, so that we could get off of using my
> private github.
> 
> I am confident that our 2023.1 solution will clean this up.

Sounds like a good plan, thanks for the details!

Best regards,

Thomas
diff mbox series

Patch

diff --git a/configs/versal_vck190_defconfig b/configs/versal_vck190_defconfig
index fcda6eb431..2808fa522b 100644
--- a/configs/versal_vck190_defconfig
+++ b/configs/versal_vck190_defconfig
@@ -32,7 +32,7 @@  BR2_TARGET_UBOOT_NEEDS_OPENSSL=y
 BR2_TARGET_UBOOT_FORMAT_REMAKE_ELF=y
 BR2_TARGET_UBOOT_FORMAT_DTB=y
 BR2_PACKAGE_VERSAL_FIRMWARE=y
-BR2_PACKAGE_VERSAL_FIRMWARE_VERSION="v2022.2"
+BR2_PACKAGE_VERSAL_FIRMWARE_VERSION="2022.2_br_1"
 BR2_PACKAGE_VERSAL_FIRMWARE_BOARD="vck190"
 BR2_PACKAGE_HOST_DOSFSTOOLS=y
 BR2_PACKAGE_HOST_GENIMAGE=y
diff --git a/package/versal-firmware/Config.in b/package/versal-firmware/Config.in
index 8d13816149..b4b63282d8 100644
--- a/package/versal-firmware/Config.in
+++ b/package/versal-firmware/Config.in
@@ -10,7 +10,7 @@  if BR2_PACKAGE_VERSAL_FIRMWARE
 
 config BR2_PACKAGE_VERSAL_FIRMWARE_VERSION
 	string "firmware version"
-	default "v2022.2"
+	default "2022.2_br_1"
 	help
 	  Release version of Versal firmware.
 
diff --git a/package/versal-firmware/versal-firmware.mk b/package/versal-firmware/versal-firmware.mk
index 3e4b9e558d..0bc5a00bc6 100644
--- a/package/versal-firmware/versal-firmware.mk
+++ b/package/versal-firmware/versal-firmware.mk
@@ -5,7 +5,7 @@ 
 ################################################################################
 
 VERSAL_FIRMWARE_VERSION = $(call qstrip,$(BR2_PACKAGE_VERSAL_FIRMWARE_VERSION))
-VERSAL_FIRMWARE_SITE = $(call github,nealfrager,buildroot-firmware,$(VERSAL_FIRMWARE_VERSION))
+VERSAL_FIRMWARE_SITE = $(call github,Xilinx,ubuntu-firmware,$(VERSAL_FIRMWARE_VERSION))
 VERSAL_FIRMWARE_LICENSE = Xilinx-Binary-Only
 VERSAL_FIRMWARE_LICENSE_FILES = LICENSE
 VERSAL_FIRMWARE_INSTALL_TARGET = NO