diff mbox series

package/util-linux: add an option to enable irqtop

Message ID 20230116080513.21407-1-yegorslists@googlemail.com
State Superseded
Headers show
Series package/util-linux: add an option to enable irqtop | expand

Commit Message

Nayab Sayed via buildroot Jan. 16, 2023, 8:05 a.m. UTC
From: Yegor Yefremov <yegorslists@googlemail.com>

irqtop is an IRQ monitoring tool.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
---
 package/util-linux/Config.in     | 7 +++++++
 package/util-linux/util-linux.mk | 1 +
 2 files changed, 8 insertions(+)

Comments

Yann E. MORIN Jan. 16, 2023, 9:24 p.m. UTC | #1
Yegor, All,

On 2023-01-16 09:05 +0100, yegorslists--- via buildroot spake thusly:
> From: Yegor Yefremov <yegorslists@googlemail.com>
> 
> irqtop is an IRQ monitoring tool.
> 
> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
> ---
>  package/util-linux/Config.in     | 7 +++++++
>  package/util-linux/util-linux.mk | 1 +
>  2 files changed, 8 insertions(+)
> 
> diff --git a/package/util-linux/Config.in b/package/util-linux/Config.in
> index 917f1bc2b4..c7e4d2d8bc 100644
> --- a/package/util-linux/Config.in
> +++ b/package/util-linux/Config.in
> @@ -161,6 +161,13 @@ config BR2_PACKAGE_UTIL_LINUX_IPCS
>  	help
>  	  Show information on IPC facilities
>  
> +config BR2_PACKAGE_UTIL_LINUX_IRQTOP
> +	bool "irqtop"
> +	depends on BR2_USE_MMU # libsmartcols
> +	select BR2_PACKAGE_UTIL_LINUX_LIBSMARTCOLS

I was about to apply this, but I am a bit conflicted... Building irqtop
defaults to 'yes' for linux systems, when --disable-irqtop is not
specified (unless I misread util-linux' configure.ac).

So, today we are providing neither --enable-irqtop nor --disable-irqtop,
which means that it is in practice always built.

But with your change, it means that now it is by default disabled.

So I wanted to add 'default y' for legacy reasons, but we have no other
option in util-linux that defaults to 'y', so it would have been a bit
odd to do so...

Or maybe I am just too tired to think straight...

Thoughts?

Regards,
Yann E. MORIN.

> +	help
> +	  Show information on IRQs
> +
>  config BR2_PACKAGE_UTIL_LINUX_KILL
>  	bool "kill"
>  	help
> diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
> index b53b94ec31..87ec3c19d7 100644
> --- a/package/util-linux/util-linux.mk
> +++ b/package/util-linux/util-linux.mk
> @@ -136,6 +136,7 @@ UTIL_LINUX_CONF_OPTS += \
>  	$(if $(BR2_PACKAGE_UTIL_LINUX_IPCMK),--enable-ipcmk,--disable-ipcmk) \
>  	$(if $(BR2_PACKAGE_UTIL_LINUX_IPCRM),--enable-ipcrm,--disable-ipcrm) \
>  	$(if $(BR2_PACKAGE_UTIL_LINUX_IPCS),--enable-ipcs,--disable-ipcs) \
> +	$(if $(BR2_PACKAGE_UTIL_LINUX_IRQTOP),--enable-irqtop,--disable-irqtop) \
>  	$(if $(BR2_PACKAGE_UTIL_LINUX_KILL),--enable-kill,--disable-kill) \
>  	$(if $(BR2_PACKAGE_UTIL_LINUX_LAST),--enable-last,--disable-last) \
>  	$(if $(BR2_PACKAGE_UTIL_LINUX_LIBBLKID),--enable-libblkid,--disable-libblkid) \
> -- 
> 2.17.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Yegor Yefremov Jan. 17, 2023, 7:57 a.m. UTC | #2
Hi Yann, All,

On Mon, Jan 16, 2023 at 10:24 PM Yann E. MORIN <yann.morin.1998@free.fr> wrote:
>
> Yegor, All,
>
> On 2023-01-16 09:05 +0100, yegorslists--- via buildroot spake thusly:
> > From: Yegor Yefremov <yegorslists@googlemail.com>
> >
> > irqtop is an IRQ monitoring tool.
> >
> > Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
> > ---
> >  package/util-linux/Config.in     | 7 +++++++
> >  package/util-linux/util-linux.mk | 1 +
> >  2 files changed, 8 insertions(+)
> >
> > diff --git a/package/util-linux/Config.in b/package/util-linux/Config.in
> > index 917f1bc2b4..c7e4d2d8bc 100644
> > --- a/package/util-linux/Config.in
> > +++ b/package/util-linux/Config.in
> > @@ -161,6 +161,13 @@ config BR2_PACKAGE_UTIL_LINUX_IPCS
> >       help
> >         Show information on IPC facilities
> >
> > +config BR2_PACKAGE_UTIL_LINUX_IRQTOP
> > +     bool "irqtop"
> > +     depends on BR2_USE_MMU # libsmartcols
> > +     select BR2_PACKAGE_UTIL_LINUX_LIBSMARTCOLS
>
> I was about to apply this, but I am a bit conflicted... Building irqtop
> defaults to 'yes' for linux systems, when --disable-irqtop is not
> specified (unless I misread util-linux' configure.ac).
>
> So, today we are providing neither --enable-irqtop nor --disable-irqtop,
> which means that it is in practice always built.
>
> But with your change, it means that now it is by default disabled.
>
> So I wanted to add 'default y' for legacy reasons, but we have no other
> option in util-linux that defaults to 'y', so it would have been a bit
> odd to do so...
>
> Or maybe I am just too tired to think straight...
>
> Thoughts?

irqtop is a rather new tool and it is not listed in the
BR2_PACKAGE_UTIL_LINUX_BINARIES help text. Perhaps, it is not that
problematic that it is not enabled by default.

I've sent v2 with the added ncurses dependency.

Regards,
Yegor

> Regards,
> Yann E. MORIN.
>
> > +     help
> > +       Show information on IRQs
> > +
> >  config BR2_PACKAGE_UTIL_LINUX_KILL
> >       bool "kill"
> >       help
> > diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
> > index b53b94ec31..87ec3c19d7 100644
> > --- a/package/util-linux/util-linux.mk
> > +++ b/package/util-linux/util-linux.mk
> > @@ -136,6 +136,7 @@ UTIL_LINUX_CONF_OPTS += \
> >       $(if $(BR2_PACKAGE_UTIL_LINUX_IPCMK),--enable-ipcmk,--disable-ipcmk) \
> >       $(if $(BR2_PACKAGE_UTIL_LINUX_IPCRM),--enable-ipcrm,--disable-ipcrm) \
> >       $(if $(BR2_PACKAGE_UTIL_LINUX_IPCS),--enable-ipcs,--disable-ipcs) \
> > +     $(if $(BR2_PACKAGE_UTIL_LINUX_IRQTOP),--enable-irqtop,--disable-irqtop) \
> >       $(if $(BR2_PACKAGE_UTIL_LINUX_KILL),--enable-kill,--disable-kill) \
> >       $(if $(BR2_PACKAGE_UTIL_LINUX_LAST),--enable-last,--disable-last) \
> >       $(if $(BR2_PACKAGE_UTIL_LINUX_LIBBLKID),--enable-libblkid,--disable-libblkid) \
> > --
> > 2.17.0
> >
> > _______________________________________________
> > buildroot mailing list
> > buildroot@buildroot.org
> > https://lists.buildroot.org/mailman/listinfo/buildroot
>
> --
> .-----------------.--------------------.------------------.--------------------.
> |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
> | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
> | +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
> | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
> '------------------------------^-------^------------------^--------------------'
Yann E. MORIN Jan. 18, 2023, 8:33 p.m. UTC | #3
Yegor, All,

On 2023-01-17 08:57 +0100, Yegor Yefremov via buildroot spake thusly:
> On Mon, Jan 16, 2023 at 10:24 PM Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> > On 2023-01-16 09:05 +0100, yegorslists--- via buildroot spake thusly:
> > > From: Yegor Yefremov <yegorslists@googlemail.com>
> > >
> > > irqtop is an IRQ monitoring tool.
> > >
> > > Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
> > > ---
> > >  package/util-linux/Config.in     | 7 +++++++
> > >  package/util-linux/util-linux.mk | 1 +
> > >  2 files changed, 8 insertions(+)
> > >
> > > diff --git a/package/util-linux/Config.in b/package/util-linux/Config.in
> > > index 917f1bc2b4..c7e4d2d8bc 100644
> > > --- a/package/util-linux/Config.in
> > > +++ b/package/util-linux/Config.in
> > > @@ -161,6 +161,13 @@ config BR2_PACKAGE_UTIL_LINUX_IPCS
> > >       help
> > >         Show information on IPC facilities
> > >
> > > +config BR2_PACKAGE_UTIL_LINUX_IRQTOP
> > > +     bool "irqtop"
> > > +     depends on BR2_USE_MMU # libsmartcols
> > > +     select BR2_PACKAGE_UTIL_LINUX_LIBSMARTCOLS
> >
> > I was about to apply this, but I am a bit conflicted... Building irqtop
> > defaults to 'yes' for linux systems, when --disable-irqtop is not
> > specified (unless I misread util-linux' configure.ac).
> >
> > So, today we are providing neither --enable-irqtop nor --disable-irqtop,
> > which means that it is in practice always built.
> >
> > But with your change, it means that now it is by default disabled.
> >
> > So I wanted to add 'default y' for legacy reasons, but we have no other
> > option in util-linux that defaults to 'y', so it would have been a bit
> > odd to do so...
[--SNIP--]
> irqtop is a rather new tool and it is not listed in the
> BR2_PACKAGE_UTIL_LINUX_BINARIES help text. Perhaps, it is not that
> problematic that it is not enabled by default.

irqtop has been in-tree since 2.36, released almost 2.5 years ago now,
and packaged in Buildroot for almost as long, so people may have come
to rely on its presence, even if undocumented.

> I've sent v2 with the added ncurses dependency.

I'll have a look, thanks.

Regards,
Yann E. MORIN.

> Regards,
> Yegor
> 
> > Regards,
> > Yann E. MORIN.
> >
> > > +     help
> > > +       Show information on IRQs
> > > +
> > >  config BR2_PACKAGE_UTIL_LINUX_KILL
> > >       bool "kill"
> > >       help
> > > diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
> > > index b53b94ec31..87ec3c19d7 100644
> > > --- a/package/util-linux/util-linux.mk
> > > +++ b/package/util-linux/util-linux.mk
> > > @@ -136,6 +136,7 @@ UTIL_LINUX_CONF_OPTS += \
> > >       $(if $(BR2_PACKAGE_UTIL_LINUX_IPCMK),--enable-ipcmk,--disable-ipcmk) \
> > >       $(if $(BR2_PACKAGE_UTIL_LINUX_IPCRM),--enable-ipcrm,--disable-ipcrm) \
> > >       $(if $(BR2_PACKAGE_UTIL_LINUX_IPCS),--enable-ipcs,--disable-ipcs) \
> > > +     $(if $(BR2_PACKAGE_UTIL_LINUX_IRQTOP),--enable-irqtop,--disable-irqtop) \
> > >       $(if $(BR2_PACKAGE_UTIL_LINUX_KILL),--enable-kill,--disable-kill) \
> > >       $(if $(BR2_PACKAGE_UTIL_LINUX_LAST),--enable-last,--disable-last) \
> > >       $(if $(BR2_PACKAGE_UTIL_LINUX_LIBBLKID),--enable-libblkid,--disable-libblkid) \
> > > --
> > > 2.17.0
> > >
> > > _______________________________________________
> > > buildroot mailing list
> > > buildroot@buildroot.org
> > > https://lists.buildroot.org/mailman/listinfo/buildroot
> >
> > --
> > .-----------------.--------------------.------------------.--------------------.
> > |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
> > | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
> > | +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
> > | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
> > '------------------------------^-------^------------------^--------------------'
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Yegor Yefremov Jan. 23, 2023, 8:44 a.m. UTC | #4
Yann, all,

On Wed, Jan 18, 2023 at 9:33 PM Yann E. MORIN <yann.morin.1998@free.fr> wrote:
>
> Yegor, All,
>
> On 2023-01-17 08:57 +0100, Yegor Yefremov via buildroot spake thusly:
> > On Mon, Jan 16, 2023 at 10:24 PM Yann E. MORIN <yann.morin.1998@free.fr> wrote:
> > > On 2023-01-16 09:05 +0100, yegorslists--- via buildroot spake thusly:
> > > > From: Yegor Yefremov <yegorslists@googlemail.com>
> > > >
> > > > irqtop is an IRQ monitoring tool.
> > > >
> > > > Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
> > > > ---
> > > >  package/util-linux/Config.in     | 7 +++++++
> > > >  package/util-linux/util-linux.mk | 1 +
> > > >  2 files changed, 8 insertions(+)
> > > >
> > > > diff --git a/package/util-linux/Config.in b/package/util-linux/Config.in
> > > > index 917f1bc2b4..c7e4d2d8bc 100644
> > > > --- a/package/util-linux/Config.in
> > > > +++ b/package/util-linux/Config.in
> > > > @@ -161,6 +161,13 @@ config BR2_PACKAGE_UTIL_LINUX_IPCS
> > > >       help
> > > >         Show information on IPC facilities
> > > >
> > > > +config BR2_PACKAGE_UTIL_LINUX_IRQTOP
> > > > +     bool "irqtop"
> > > > +     depends on BR2_USE_MMU # libsmartcols
> > > > +     select BR2_PACKAGE_UTIL_LINUX_LIBSMARTCOLS
> > >
> > > I was about to apply this, but I am a bit conflicted... Building irqtop
> > > defaults to 'yes' for linux systems, when --disable-irqtop is not
> > > specified (unless I misread util-linux' configure.ac).
> > >
> > > So, today we are providing neither --enable-irqtop nor --disable-irqtop,
> > > which means that it is in practice always built.
> > >
> > > But with your change, it means that now it is by default disabled.
> > >
> > > So I wanted to add 'default y' for legacy reasons, but we have no other
> > > option in util-linux that defaults to 'y', so it would have been a bit
> > > odd to do so...
> [--SNIP--]
> > irqtop is a rather new tool and it is not listed in the
> > BR2_PACKAGE_UTIL_LINUX_BINARIES help text. Perhaps, it is not that
> > problematic that it is not enabled by default.
>
> irqtop has been in-tree since 2.36, released almost 2.5 years ago now,
> and packaged in Buildroot for almost as long, so people may have come
> to rely on its presence, even if undocumented.

Perhaps, we should just drop my patch and I just add irqtop to the help text?

Regards,
Yegor

> > I've sent v2 with the added ncurses dependency.
>
> I'll have a look, thanks.
>
> Regards,
> Yann E. MORIN.
>
> > Regards,
> > Yegor
> >
> > > Regards,
> > > Yann E. MORIN.
> > >
> > > > +     help
> > > > +       Show information on IRQs
> > > > +
> > > >  config BR2_PACKAGE_UTIL_LINUX_KILL
> > > >       bool "kill"
> > > >       help
> > > > diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
> > > > index b53b94ec31..87ec3c19d7 100644
> > > > --- a/package/util-linux/util-linux.mk
> > > > +++ b/package/util-linux/util-linux.mk
> > > > @@ -136,6 +136,7 @@ UTIL_LINUX_CONF_OPTS += \
> > > >       $(if $(BR2_PACKAGE_UTIL_LINUX_IPCMK),--enable-ipcmk,--disable-ipcmk) \
> > > >       $(if $(BR2_PACKAGE_UTIL_LINUX_IPCRM),--enable-ipcrm,--disable-ipcrm) \
> > > >       $(if $(BR2_PACKAGE_UTIL_LINUX_IPCS),--enable-ipcs,--disable-ipcs) \
> > > > +     $(if $(BR2_PACKAGE_UTIL_LINUX_IRQTOP),--enable-irqtop,--disable-irqtop) \
> > > >       $(if $(BR2_PACKAGE_UTIL_LINUX_KILL),--enable-kill,--disable-kill) \
> > > >       $(if $(BR2_PACKAGE_UTIL_LINUX_LAST),--enable-last,--disable-last) \
> > > >       $(if $(BR2_PACKAGE_UTIL_LINUX_LIBBLKID),--enable-libblkid,--disable-libblkid) \
> > > > --
> > > > 2.17.0
> > > >
> > > > _______________________________________________
> > > > buildroot mailing list
> > > > buildroot@buildroot.org
> > > > https://lists.buildroot.org/mailman/listinfo/buildroot
> > >
> > > --
> > > .-----------------.--------------------.------------------.--------------------.
> > > |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
> > > | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
> > > | +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
> > > | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
> > > '------------------------------^-------^------------------^--------------------'
> > _______________________________________________
> > buildroot mailing list
> > buildroot@buildroot.org
> > https://lists.buildroot.org/mailman/listinfo/buildroot
>
> --
> .-----------------.--------------------.------------------.--------------------.
> |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
> | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
> | +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
> | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
> '------------------------------^-------^------------------^--------------------'
diff mbox series

Patch

diff --git a/package/util-linux/Config.in b/package/util-linux/Config.in
index 917f1bc2b4..c7e4d2d8bc 100644
--- a/package/util-linux/Config.in
+++ b/package/util-linux/Config.in
@@ -161,6 +161,13 @@  config BR2_PACKAGE_UTIL_LINUX_IPCS
 	help
 	  Show information on IPC facilities
 
+config BR2_PACKAGE_UTIL_LINUX_IRQTOP
+	bool "irqtop"
+	depends on BR2_USE_MMU # libsmartcols
+	select BR2_PACKAGE_UTIL_LINUX_LIBSMARTCOLS
+	help
+	  Show information on IRQs
+
 config BR2_PACKAGE_UTIL_LINUX_KILL
 	bool "kill"
 	help
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index b53b94ec31..87ec3c19d7 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -136,6 +136,7 @@  UTIL_LINUX_CONF_OPTS += \
 	$(if $(BR2_PACKAGE_UTIL_LINUX_IPCMK),--enable-ipcmk,--disable-ipcmk) \
 	$(if $(BR2_PACKAGE_UTIL_LINUX_IPCRM),--enable-ipcrm,--disable-ipcrm) \
 	$(if $(BR2_PACKAGE_UTIL_LINUX_IPCS),--enable-ipcs,--disable-ipcs) \
+	$(if $(BR2_PACKAGE_UTIL_LINUX_IRQTOP),--enable-irqtop,--disable-irqtop) \
 	$(if $(BR2_PACKAGE_UTIL_LINUX_KILL),--enable-kill,--disable-kill) \
 	$(if $(BR2_PACKAGE_UTIL_LINUX_LAST),--enable-last,--disable-last) \
 	$(if $(BR2_PACKAGE_UTIL_LINUX_LIBBLKID),--enable-libblkid,--disable-libblkid) \