diff mbox series

[v1] package/qt5speech: new package

Message ID 20230106210827.30007-3-ps.report@gmx.net
State Accepted
Headers show
Series [v1] package/qt5speech: new package | expand

Commit Message

Peter Seiderer Jan. 6, 2023, 9:08 p.m. UTC
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 package/qt5/Config.in                |  1 +
 package/qt5/qt5speech/Config.in      | 12 ++++++++++++
 package/qt5/qt5speech/qt5speech.hash |  7 +++++++
 package/qt5/qt5speech/qt5speech.mk   | 23 +++++++++++++++++++++++
 4 files changed, 43 insertions(+)
 create mode 100644 package/qt5/qt5speech/Config.in
 create mode 100644 package/qt5/qt5speech/qt5speech.hash
 create mode 100644 package/qt5/qt5speech/qt5speech.mk

Comments

Peter Seiderer Jan. 6, 2023, 9:27 p.m. UTC | #1
Hello *,

the patches

  - [PATCH v1] package/dotconf: new package
  - [PATCH v1] package/speechd: new package
  - [PATCH v1] package/qt5speech: new package (this one)

should have been in one patch series (1/3, 2/3, 3/3)...

Regards,
Peter


On Fri,  6 Jan 2023 22:08:27 +0100, Peter Seiderer <ps.report@gmx.net> wrote:

> Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> ---
>  package/qt5/Config.in                |  1 +
>  package/qt5/qt5speech/Config.in      | 12 ++++++++++++
>  package/qt5/qt5speech/qt5speech.hash |  7 +++++++
>  package/qt5/qt5speech/qt5speech.mk   | 23 +++++++++++++++++++++++
>  4 files changed, 43 insertions(+)
>  create mode 100644 package/qt5/qt5speech/Config.in
>  create mode 100644 package/qt5/qt5speech/qt5speech.hash
>  create mode 100644 package/qt5/qt5speech/qt5speech.mk
>
> diff --git a/package/qt5/Config.in b/package/qt5/Config.in
> index 6dc9cfa148..f1b16ff39b 100644
> --- a/package/qt5/Config.in
> +++ b/package/qt5/Config.in
> @@ -59,6 +59,7 @@ source "package/qt5/qt5scxml/Config.in"
>  source "package/qt5/qt5sensors/Config.in"
>  source "package/qt5/qt5serialbus/Config.in"
>  source "package/qt5/qt5serialport/Config.in"
> +source "package/qt5/qt5speech/Config.in"
>  source "package/qt5/qt5svg/Config.in"
>  source "package/qt5/qt5tools/Config.in"
>  source "package/qt5/qt5virtualkeyboard/Config.in"
> diff --git a/package/qt5/qt5speech/Config.in b/package/qt5/qt5speech/Config.in
> new file mode 100644
> index 0000000000..cebd06057e
> --- /dev/null
> +++ b/package/qt5/qt5speech/Config.in
> @@ -0,0 +1,12 @@
> +config BR2_PACKAGE_QT5SPEECH
> +	bool "qt5speech"
> +	help
> +	  Qt is a cross-platform application and UI framework for
> +	  developers using C++.
> +
> +	  Qt Speech enables support for accessibility features such as
> +	  text-to-speech.
> +
> +	  For output optional enable flite or speechd.
> +
> +	  https://doc.qt.io/qt-5/qtspeech-index.html
> diff --git a/package/qt5/qt5speech/qt5speech.hash b/package/qt5/qt5speech/qt5speech.hash
> new file mode 100644
> index 0000000000..595aac9f22
> --- /dev/null
> +++ b/package/qt5/qt5speech/qt5speech.hash
> @@ -0,0 +1,7 @@
> +# Locally calculated
> +sha256  6d0794ab9d5286d04fbac2db44c00ed3306e569c876f84cfd91ac0e79c834b1e  qtspeech-d32f4a479d38a11f547598004b975f4356424a16.tar.bz2
> +
> +# Hashes for license files:
> +sha256  6c3f3c31b93985f1b93bfbb35fb609d37281697d0efc220c9f91cf4b59eaabde  LICENSE.GPLv2
> +sha256  75d800e60c8d58c2e7f0338e8552ea6123a9ce7e5dd8e1cdf2095e013b737488  LICENSE.LGPLv3
> +sha256  ed8742a95cb9db653a09b050e27ccff5e67ba69c14aa2c3137f2a4e1892f6c0d  LICENSE.FDL
> diff --git a/package/qt5/qt5speech/qt5speech.mk b/package/qt5/qt5speech/qt5speech.mk
> new file mode 100644
> index 0000000000..8cf6fe19c1
> --- /dev/null
> +++ b/package/qt5/qt5speech/qt5speech.mk
> @@ -0,0 +1,23 @@
> +################################################################################
> +#
> +# qt5speech
> +#
> +################################################################################
> +
> +QT5SPEECH_VERSION = d32f4a479d38a11f547598004b975f4356424a16
> +QT5SPEECH_SITE = $(QT5_SITE)/qtspeech/-/archive/$(QT5SPEECH_VERSION)
> +QT5SPEECH_SOURCE = qtspeech-$(QT5SPEECH_VERSION).tar.bz2
> +QT5SPEECH_INSTALL_STAGING = YES
> +QT5SPEECH_LICENSE = GPL-2.0+ or LGPL-3.0, GFDL-1.3 (docs)
> +QT5SPEECH_LICENSE_FILES = LICENSE.GPLv2 LICENSE.LGPLv3 LICENSE.FDL
> +QT5SPEECH_SYNC_QT_HEADERS = YES
> +
> +ifeq ($(BR2_PACKAGE_FLITE),y)
> +QT5SPEECH_DEPENDENCIES += flite
> +endif
> +
> +ifeq ($(BR2_PACKAGE_SPEECHD),y)
> +QT5SPEECH_DEPENDENCIES += speechd
> +endif
> +
> +$(eval $(qmake-package))
Thomas Petazzoni Feb. 17, 2023, 1:48 p.m. UTC | #2
On Fri,  6 Jan 2023 22:08:27 +0100
Peter Seiderer <ps.report@gmx.net> wrote:

> Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> ---
>  package/qt5/Config.in                |  1 +
>  package/qt5/qt5speech/Config.in      | 12 ++++++++++++
>  package/qt5/qt5speech/qt5speech.hash |  7 +++++++
>  package/qt5/qt5speech/qt5speech.mk   | 23 +++++++++++++++++++++++
>  4 files changed, 43 insertions(+)
>  create mode 100644 package/qt5/qt5speech/Config.in
>  create mode 100644 package/qt5/qt5speech/qt5speech.hash
>  create mode 100644 package/qt5/qt5speech/qt5speech.mk

Applied to master after adding an entry to the DEVELOPERS file. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/qt5/Config.in b/package/qt5/Config.in
index 6dc9cfa148..f1b16ff39b 100644
--- a/package/qt5/Config.in
+++ b/package/qt5/Config.in
@@ -59,6 +59,7 @@  source "package/qt5/qt5scxml/Config.in"
 source "package/qt5/qt5sensors/Config.in"
 source "package/qt5/qt5serialbus/Config.in"
 source "package/qt5/qt5serialport/Config.in"
+source "package/qt5/qt5speech/Config.in"
 source "package/qt5/qt5svg/Config.in"
 source "package/qt5/qt5tools/Config.in"
 source "package/qt5/qt5virtualkeyboard/Config.in"
diff --git a/package/qt5/qt5speech/Config.in b/package/qt5/qt5speech/Config.in
new file mode 100644
index 0000000000..cebd06057e
--- /dev/null
+++ b/package/qt5/qt5speech/Config.in
@@ -0,0 +1,12 @@ 
+config BR2_PACKAGE_QT5SPEECH
+	bool "qt5speech"
+	help
+	  Qt is a cross-platform application and UI framework for
+	  developers using C++.
+
+	  Qt Speech enables support for accessibility features such as
+	  text-to-speech.
+
+	  For output optional enable flite or speechd.
+
+	  https://doc.qt.io/qt-5/qtspeech-index.html
diff --git a/package/qt5/qt5speech/qt5speech.hash b/package/qt5/qt5speech/qt5speech.hash
new file mode 100644
index 0000000000..595aac9f22
--- /dev/null
+++ b/package/qt5/qt5speech/qt5speech.hash
@@ -0,0 +1,7 @@ 
+# Locally calculated
+sha256  6d0794ab9d5286d04fbac2db44c00ed3306e569c876f84cfd91ac0e79c834b1e  qtspeech-d32f4a479d38a11f547598004b975f4356424a16.tar.bz2
+
+# Hashes for license files:
+sha256  6c3f3c31b93985f1b93bfbb35fb609d37281697d0efc220c9f91cf4b59eaabde  LICENSE.GPLv2
+sha256  75d800e60c8d58c2e7f0338e8552ea6123a9ce7e5dd8e1cdf2095e013b737488  LICENSE.LGPLv3
+sha256  ed8742a95cb9db653a09b050e27ccff5e67ba69c14aa2c3137f2a4e1892f6c0d  LICENSE.FDL
diff --git a/package/qt5/qt5speech/qt5speech.mk b/package/qt5/qt5speech/qt5speech.mk
new file mode 100644
index 0000000000..8cf6fe19c1
--- /dev/null
+++ b/package/qt5/qt5speech/qt5speech.mk
@@ -0,0 +1,23 @@ 
+################################################################################
+#
+# qt5speech
+#
+################################################################################
+
+QT5SPEECH_VERSION = d32f4a479d38a11f547598004b975f4356424a16
+QT5SPEECH_SITE = $(QT5_SITE)/qtspeech/-/archive/$(QT5SPEECH_VERSION)
+QT5SPEECH_SOURCE = qtspeech-$(QT5SPEECH_VERSION).tar.bz2
+QT5SPEECH_INSTALL_STAGING = YES
+QT5SPEECH_LICENSE = GPL-2.0+ or LGPL-3.0, GFDL-1.3 (docs)
+QT5SPEECH_LICENSE_FILES = LICENSE.GPLv2 LICENSE.LGPLv3 LICENSE.FDL
+QT5SPEECH_SYNC_QT_HEADERS = YES
+
+ifeq ($(BR2_PACKAGE_FLITE),y)
+QT5SPEECH_DEPENDENCIES += flite
+endif
+
+ifeq ($(BR2_PACKAGE_SPEECHD),y)
+QT5SPEECH_DEPENDENCIES += speechd
+endif
+
+$(eval $(qmake-package))