diff mbox series

[2/2] bash: bump version to 5.2.15

Message ID 20230103135617.3211318-2-martin@geanix.com
State Accepted
Headers show
Series [1/2] readline: bump version to 8.2 | expand

Commit Message

Martin Hundebøll Jan. 3, 2023, 1:56 p.m. UTC
Signed-off-by: Martin Hundebøll <martin@geanix.com>
---
 ...local_shiftstates-vs.-locale_shiftst.patch | 72 -------------------
 ...quote_pathname-vs.-udequote_pathname.patch | 40 -----------
 package/bash/bash.hash                        |  4 +-
 package/bash/bash.mk                          |  2 +-
 4 files changed, 3 insertions(+), 115 deletions(-)
 delete mode 100644 package/bash/0002-locale-fix-typo-local_shiftstates-vs.-locale_shiftst.patch
 delete mode 100644 package/bash/0003-glob-fix-dequote_pathname-vs.-udequote_pathname.patch

Comments

Peter Korsgaard Jan. 4, 2023, 10:12 p.m. UTC | #1
>>>>> "Martin" == Martin Hundebøll <martin@geanix.com> writes:

 > Signed-off-by: Martin Hundebøll <martin@geanix.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/bash/0002-locale-fix-typo-local_shiftstates-vs.-locale_shiftst.patch b/package/bash/0002-locale-fix-typo-local_shiftstates-vs.-locale_shiftst.patch
deleted file mode 100644
index 1636c18036..0000000000
--- a/package/bash/0002-locale-fix-typo-local_shiftstates-vs.-locale_shiftst.patch
+++ /dev/null
@@ -1,72 +0,0 @@ 
-From 3d6b9e18506ad9daf4ec7b7d406b38d58ec88009 Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Thu, 11 Mar 2021 20:48:36 +0100
-Subject: [PATCH] locale: fix typo local_shiftstates vs. locale_shiftstates
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes:
-
-  locale.c:94:3: error: ‘local_shiftstates’ undeclared (first use in this function); did you mean ‘locale_shiftstates’?
-     94 |   local_shiftstates = 0;
-        |   ^~~~~~~~~~~~~~~~~
-        |   locale_shiftstates
-
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- locale.c | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/locale.c b/locale.c
-index 17ccc58..d6dd95a 100644
---- a/locale.c
-+++ b/locale.c
-@@ -91,7 +91,7 @@ set_default_locale ()
- #if defined (HANDLE_MULTIBYTE)
-   locale_shiftstates = mblen ((char *)NULL, 0);
- #else
--  local_shiftstates = 0;
-+  locale_shiftstates = 0;
- #endif
- }
- 
-@@ -117,7 +117,7 @@ set_default_locale_vars ()
- #    if defined (HANDLE_MULTIBYTE)
-       locale_shiftstates = mblen ((char *)NULL, 0);
- #    else
--      local_shiftstates = 0;
-+      locale_shiftstates = 0;
- #    endif
- 
-       u32reset ();
-@@ -226,7 +226,7 @@ set_locale_var (var, value)
- #  if defined (HANDLE_MULTIBYTE)
-       locale_shiftstates = mblen ((char *)NULL, 0);
- #  else
--      local_shiftstates = 0;
-+      locale_shiftstates = 0;
- #  endif
-       u32reset ();
-       return r;
-@@ -250,7 +250,7 @@ set_locale_var (var, value)
- #if defined (HANDLE_MULTIBYTE)
- 	  locale_shiftstates = mblen ((char *)NULL, 0);
- #else
--	  local_shiftstates = 0;
-+	  locale_shiftstates = 0;
- #endif
- 	  u32reset ();
- 	}
-@@ -391,7 +391,7 @@ reset_locale_vars ()
- #  if defined (HANDLE_MULTIBYTE)
-   locale_shiftstates = mblen ((char *)NULL, 0);
- #  else
--  local_shiftstates = 0;
-+  locale_shiftstates = 0;
- #  endif
-   u32reset ();
- #endif
--- 
-2.30.1
-
diff --git a/package/bash/0003-glob-fix-dequote_pathname-vs.-udequote_pathname.patch b/package/bash/0003-glob-fix-dequote_pathname-vs.-udequote_pathname.patch
deleted file mode 100644
index a801f68236..0000000000
--- a/package/bash/0003-glob-fix-dequote_pathname-vs.-udequote_pathname.patch
+++ /dev/null
@@ -1,40 +0,0 @@ 
-From a60ab1e5e88863acf9b0e9bcaa7919bbf093da05 Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Thu, 11 Mar 2021 20:55:52 +0100
-Subject: [PATCH] glob: fix dequote_pathname vs. udequote_pathname
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes:
-
-  glob.c:123:28: error: static declaration of ‘udequote_pathname’ follows non-static declaration
-    123 | #  define dequote_pathname udequote_pathname
-        |                            ^~~~~~~~~~~~~~~~~
-  glob.c:125:13: note: in expansion of macro ‘dequote_pathname’
-    125 | static void dequote_pathname PARAMS((char *));
-        |             ^~~~~~~~~~~~~~~~
-  glob.c:118:6: note: previous declaration of ‘udequote_pathname’ was here
-    118 | void udequote_pathname PARAMS((char *));
-        |      ^~~~~~~~~~~~~~~~~
-
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- lib/glob/glob.c | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/lib/glob/glob.c b/lib/glob/glob.c
-index eb6277f..c903b15 100644
---- a/lib/glob/glob.c
-+++ b/lib/glob/glob.c
-@@ -117,6 +117,5 @@ static int mbskipname PARAMS((char *, char *, int));
- #else
- #  define dequote_pathname udequote_pathname
- #endif
--static void dequote_pathname PARAMS((char *));
- static int glob_testdir PARAMS((char *, int));
- static char **glob_dir_to_array PARAMS((char *, char **, int));
- 
--- 
-2.30.1
-
diff --git a/package/bash/bash.hash b/package/bash/bash.hash
index 4660e9d38a..e0a1ebac91 100644
--- a/package/bash/bash.hash
+++ b/package/bash/bash.hash
@@ -1,4 +1,4 @@ 
 # Locally calculated after checking pgp signature from
-# https://ftp.gnu.org/gnu/bash/bash-5.1.16.tar.gz.sig
-sha256  5bac17218d3911834520dad13cd1f85ab944e1c09ae1aba55906be1f8192f558  bash-5.1.16.tar.gz
+# https://ftp.gnu.org/gnu/bash/bash-5.2.15.tar.gz.sig
+sha256  13720965b5f4fc3a0d4b61dd37e7565c741da9a5be24edc2ae00182fc1b3588c  bash-5.2.15.tar.gz
 sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  COPYING
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index 3aca22898e..ec5e2d722f 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-BASH_VERSION = 5.1.16
+BASH_VERSION = 5.2.15
 BASH_SITE = $(BR2_GNU_MIRROR)/bash
 BASH_DEPENDENCIES = ncurses readline host-bison
 BASH_LICENSE = GPL-3.0+