diff mbox series

package/qemu: pixman only used for system emulation

Message ID 20230101143242.187845-1-yann.morin.1998@free.fr
State Accepted
Headers show
Series package/qemu: pixman only used for system emulation | expand

Commit Message

Yann E. MORIN Jan. 1, 2023, 2:32 p.m. UTC
When we initially introduced the target qemu in 98e1a6b9619c
(package/qemu: build for the target (i386 or x86_64 only)), we
unconditionally enabled all the system and user emulation without
distinction, so pixman was made a mandatory dependency.

However, soon afterwards, in 68ec49acc7be (package/qemu: add basic
target selection), we added an option to enable/disable the system
emulation, but the dependency on pixman was not moved to that new
option.

Fix that now, and only depend on pixman when system emulation is
enabled.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
---
 package/qemu/Config.in | 2 +-
 package/qemu/qemu.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Jan. 6, 2023, 3:11 p.m. UTC | #1
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > When we initially introduced the target qemu in 98e1a6b9619c
 > (package/qemu: build for the target (i386 or x86_64 only)), we
 > unconditionally enabled all the system and user emulation without
 > distinction, so pixman was made a mandatory dependency.

 > However, soon afterwards, in 68ec49acc7be (package/qemu: add basic
 > target selection), we added an option to enable/disable the system
 > emulation, but the dependency on pixman was not moved to that new
 > option.

 > Fix that now, and only depend on pixman when system emulation is
 > enabled.

 > Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/qemu/Config.in b/package/qemu/Config.in
index f1631059c7..a446c0cf68 100644
--- a/package/qemu/Config.in
+++ b/package/qemu/Config.in
@@ -25,7 +25,6 @@  menuconfig BR2_PACKAGE_QEMU
 	depends on BR2_USE_WCHAR # gettext
 	depends on BR2_USE_MMU # fork()
 	select BR2_PACKAGE_LIBGLIB2
-	select BR2_PACKAGE_PIXMAN
 	select BR2_PACKAGE_ZLIB
 	select BR2_PACKAGE_QEMU_TOOLS if !BR2_PACKAGE_QEMU_SYSTEM && !BR2_PACKAGE_QEMU_LINUX_USER
 	help
@@ -53,6 +52,7 @@  comment "Emulators selection"
 config BR2_PACKAGE_QEMU_SYSTEM
 	bool "Enable systems emulation"
 	depends on !BR2_STATIC_LIBS # dtc
+	select BR2_PACKAGE_PIXMAN
 	help
 	  Say 'y' to build system emulators/virtualisers.
 
diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index b38dde4308..d514a2285c 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -27,7 +27,6 @@  QEMU_DEPENDENCIES = \
 	host-pkgconf \
 	host-python3 \
 	libglib2 \
-	pixman \
 	zlib
 
 # Need the LIBS variable because librt and libm are
@@ -45,6 +44,7 @@  QEMU_VARS = LIBTOOL=$(HOST_DIR)/bin/libtool
 # checks if the specified sub-set is valid.
 
 ifeq ($(BR2_PACKAGE_QEMU_SYSTEM),y)
+QEMU_DEPENDENCIES += pixman
 QEMU_OPTS += --enable-system
 QEMU_TARGET_LIST_$(BR2_PACKAGE_QEMU_TARGET_AARCH64) += aarch64-softmmu
 QEMU_TARGET_LIST_$(BR2_PACKAGE_QEMU_TARGET_ALPHA) += alpha-softmmu