diff mbox series

package/qemu: add option to install blobs

Message ID 20230101143232.187601-1-yann.morin.1998@free.fr
State Accepted
Headers show
Series package/qemu: add option to install blobs | expand

Commit Message

Yann E. MORIN Jan. 1, 2023, 2:32 p.m. UTC
Binary blobs are BIOS of some sorts for the various machines emulated
by QEMU. There is no option to individually install blobs; it's an
all-or-nothing option.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
 package/qemu/Config.in | 11 +++++++++++
 package/qemu/qemu.mk   |  6 ++++++
 2 files changed, 17 insertions(+)

Comments

Thomas Petazzoni Feb. 22, 2023, 9:03 p.m. UTC | #1
On Sun,  1 Jan 2023 15:32:32 +0100
"Yann E. MORIN" <yann.morin.1998@free.fr> wrote:

> Binary blobs are BIOS of some sorts for the various machines emulated
> by QEMU. There is no option to individually install blobs; it's an
> all-or-nothing option.
> 
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> ---
>  package/qemu/Config.in | 11 +++++++++++
>  package/qemu/qemu.mk   |  6 ++++++
>  2 files changed, 17 insertions(+)

Applied to next, thanks. Should we install them unconditionally in the
host variant?

Thomas
diff mbox series

Patch

diff --git a/package/qemu/Config.in b/package/qemu/Config.in
index 2bbc6a14c0..f1631059c7 100644
--- a/package/qemu/Config.in
+++ b/package/qemu/Config.in
@@ -58,6 +58,17 @@  config BR2_PACKAGE_QEMU_SYSTEM
 
 if BR2_PACKAGE_QEMU_SYSTEM
 
+config BR2_PACKAGE_QEMU_BLOBS
+	bool "Install binary blobs"
+	default y
+	help
+	  Say 'y' here (the default) to install binary blobs (such as
+	  BIOS or firmwares for the different machines simulated by
+	  QEMU). Say 'n' to not install those blobs.
+
+	  Note: Some machines may be unbootable without those blobs.
+	  If unsure, say 'y'.
+
 config BR2_PACKAGE_QEMU_SLIRP
 	bool "Enable user mode networking (SLIRP)"
 	select BR2_PACKAGE_SLIRP
diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index 5c7a8d504c..b38dde4308 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -246,6 +246,12 @@  ifeq ($(BR2_STATIC_LIBS),y)
 QEMU_OPTS += --static
 endif
 
+ifeq ($(BR2_PACKAGE_QEMU_BLOBS),y)
+QEMU_OPTS += --enable-install-blobs
+else
+QEMU_OPTS += --disable-install-blobs
+endif
+
 # Override CPP, as it expects to be able to call it like it'd
 # call the compiler.
 define QEMU_CONFIGURE_CMDS