diff mbox series

[v5,1/3] package/rtl8723ds-bt: new package

Message ID 20221214221506.43849-1-angelo@amarulasolutions.com
State Superseded
Delegated to: Peter Korsgaard
Headers show
Series [v5,1/3] package/rtl8723ds-bt: new package | expand

Commit Message

Angelo Compagnucci Dec. 14, 2022, 10:15 p.m. UTC
This package install the required firmware for enabling the
Bluetooth device embedded in the RTL8723DS chip.
The driver is included in Linux main tree and can be enabled
with the BT_HCIUART_RTL symbol.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
---
v3:
* Simplified package (Thomas, Yann)
* Package now only installs firmware (Thomas, Yann)

 package/Config.in                      |  1 +
 package/rtl8723ds-bt/Config.in         |  6 ++++++
 package/rtl8723ds-bt/rtl8723ds-bt.hash |  2 ++
 package/rtl8723ds-bt/rtl8723ds-bt.mk   | 17 +++++++++++++++++
 4 files changed, 26 insertions(+)
 create mode 100644 package/rtl8723ds-bt/Config.in
 create mode 100644 package/rtl8723ds-bt/rtl8723ds-bt.hash
 create mode 100644 package/rtl8723ds-bt/rtl8723ds-bt.mk

Comments

Indrek Kruusa Dec. 15, 2022, 9:52 p.m. UTC | #1
Kontakt Angelo Compagnucci (<angelo@amarulasolutions.com>) kirjutas
kuupƤeval N, 15. detsember 2022 kell 00:15:

> This package install the required firmware for enabling the
> Bluetooth device embedded in the RTL8723DS chip.
> The driver is included in Linux main tree and can be enabled
> with the BT_HCIUART_RTL symbol.
>
> Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
>

I did the clean build + boot testing with Lichee RV dock
(sipeed_lichee_rv_dock_defconfig) which is using this package. From the log:

Starting mdev... OK
[    7.044734] Bluetooth: HCI UART driver ver 2.3
[    7.050998] Bluetooth: HCI UART protocol Three-wire (H5) registered
[    7.805105] Bluetooth: hci0: RTL: examining hci_ver=08 hci_rev=000d
lmp_ver=08 lmp_subver=8723
[    7.817938] Bluetooth: hci0: RTL: rom_version status=0 version=2
[    7.824105] Bluetooth: hci0: RTL: loading rtl_bt/rtl8723ds_fw.bin
[    8.073287] 8723ds: loading out-of-tree module taints kernel.
[    8.085577] Bluetooth: hci0: RTL: loading rtl_bt/rtl8723ds_config.bin
[    8.117338] Bluetooth: hci0: RTL: cfg_sz 47, total sz 30775
[    8.637554] Bluetooth: hci0: RTL: fw version 0xaa6c133b
Initializing random number generator: OK
Saving random seed: OK
Starting system message bus: done

If that counts as a test from patch perspective then:

Tested-by: Indrek Kruusa <indrek.kruusa@gmail.com>


> ---
> v3:
> * Simplified package (Thomas, Yann)
> * Package now only installs firmware (Thomas, Yann)
>
>  package/Config.in                      |  1 +
>  package/rtl8723ds-bt/Config.in         |  6 ++++++
>  package/rtl8723ds-bt/rtl8723ds-bt.hash |  2 ++
>  package/rtl8723ds-bt/rtl8723ds-bt.mk   | 17 +++++++++++++++++
>  4 files changed, 26 insertions(+)
>  create mode 100644 package/rtl8723ds-bt/Config.in
>  create mode 100644 package/rtl8723ds-bt/rtl8723ds-bt.hash
>  create mode 100644 package/rtl8723ds-bt/rtl8723ds-bt.mk
>
> diff --git a/package/Config.in b/package/Config.in
> index 914c3584e9..999feae08a 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -585,6 +585,7 @@ endmenu
>         source "package/rtl8192eu/Config.in"
>         source "package/rtl8723bu/Config.in"
>         source "package/rtl8723ds/Config.in"
> +       source "package/rtl8723ds-bt/Config.in"
>         source "package/rtl8812au-aircrack-ng/Config.in"
>         source "package/rtl8821au/Config.in"
>         source "package/sane-backends/Config.in"
> diff --git a/package/rtl8723ds-bt/Config.in
> b/package/rtl8723ds-bt/Config.in
> new file mode 100644
> index 0000000000..0a604310c0
> --- /dev/null
> +++ b/package/rtl8723ds-bt/Config.in
> @@ -0,0 +1,6 @@
> +config BR2_PACKAGE_RTL8723DS_BT
> +       bool "rtl8723ds-bt"
> +       help
> +         rtl8723ds UART attached Bluetooth module firmware.
> +
> +         https://github.com/wsyco/RTL8723DS_BT_Linux
> diff --git a/package/rtl8723ds-bt/rtl8723ds-bt.hash
> b/package/rtl8723ds-bt/rtl8723ds-bt.hash
> new file mode 100644
> index 0000000000..1ec4e350f9
> --- /dev/null
> +++ b/package/rtl8723ds-bt/rtl8723ds-bt.hash
> @@ -0,0 +1,2 @@
> +# Locally computed
> +sha256  9e70a981946abeeb6437d9a27d8437cea15aa4df72f8d56ded0ae28af484d2f4
> rtl8723ds-bt-14cedf3a9fec1aa8c500fa52f3e3acc433cbcf08.tar.gz
> diff --git a/package/rtl8723ds-bt/rtl8723ds-bt.mk b/package/rtl8723ds-bt/
> rtl8723ds-bt.mk
> new file mode 100644
> index 0000000000..efd0a5bae9
> --- /dev/null
> +++ b/package/rtl8723ds-bt/rtl8723ds-bt.mk
> @@ -0,0 +1,17 @@
>
> +################################################################################
> +#
> +# rtl8723ds-bt
> +#
>
> +################################################################################
> +
> +RTL8723DS_BT_VERSION = 14cedf3a9fec1aa8c500fa52f3e3acc433cbcf08
> +RTL8723DS_BT_SITE = $(call
> github,wsyco,RTL8723DS_BT_Linux,$(RTL8723DS_BT_VERSION))
> +RTL8723DS_BT_LICENSE = PROPRIETARY
> +
> +define RTL8723DS_BT_INSTALL_TARGET_CMDS
> +       mkdir -p $(TARGET_DIR)/lib/firmware/rtl_bt/
> +       cp $(@D)/8723D/rtl8723d_fw
> $(TARGET_DIR)/lib/firmware/rtl_bt/rtl8723ds_fw.bin
> +       cp $(@D)/8723D/rtl8723d_config
> $(TARGET_DIR)/lib/firmware/rtl_bt/rtl8723ds_config.bin
> +endef
> +
> +$(eval $(generic-package))
> --
> 2.34.1
>
>
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index 914c3584e9..999feae08a 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -585,6 +585,7 @@  endmenu
 	source "package/rtl8192eu/Config.in"
 	source "package/rtl8723bu/Config.in"
 	source "package/rtl8723ds/Config.in"
+	source "package/rtl8723ds-bt/Config.in"
 	source "package/rtl8812au-aircrack-ng/Config.in"
 	source "package/rtl8821au/Config.in"
 	source "package/sane-backends/Config.in"
diff --git a/package/rtl8723ds-bt/Config.in b/package/rtl8723ds-bt/Config.in
new file mode 100644
index 0000000000..0a604310c0
--- /dev/null
+++ b/package/rtl8723ds-bt/Config.in
@@ -0,0 +1,6 @@ 
+config BR2_PACKAGE_RTL8723DS_BT
+	bool "rtl8723ds-bt"
+	help
+	  rtl8723ds UART attached Bluetooth module firmware.
+
+	  https://github.com/wsyco/RTL8723DS_BT_Linux
diff --git a/package/rtl8723ds-bt/rtl8723ds-bt.hash b/package/rtl8723ds-bt/rtl8723ds-bt.hash
new file mode 100644
index 0000000000..1ec4e350f9
--- /dev/null
+++ b/package/rtl8723ds-bt/rtl8723ds-bt.hash
@@ -0,0 +1,2 @@ 
+# Locally computed
+sha256  9e70a981946abeeb6437d9a27d8437cea15aa4df72f8d56ded0ae28af484d2f4  rtl8723ds-bt-14cedf3a9fec1aa8c500fa52f3e3acc433cbcf08.tar.gz
diff --git a/package/rtl8723ds-bt/rtl8723ds-bt.mk b/package/rtl8723ds-bt/rtl8723ds-bt.mk
new file mode 100644
index 0000000000..efd0a5bae9
--- /dev/null
+++ b/package/rtl8723ds-bt/rtl8723ds-bt.mk
@@ -0,0 +1,17 @@ 
+################################################################################
+#
+# rtl8723ds-bt
+#
+################################################################################
+
+RTL8723DS_BT_VERSION = 14cedf3a9fec1aa8c500fa52f3e3acc433cbcf08
+RTL8723DS_BT_SITE = $(call github,wsyco,RTL8723DS_BT_Linux,$(RTL8723DS_BT_VERSION))
+RTL8723DS_BT_LICENSE = PROPRIETARY
+
+define RTL8723DS_BT_INSTALL_TARGET_CMDS
+	mkdir -p $(TARGET_DIR)/lib/firmware/rtl_bt/
+	cp $(@D)/8723D/rtl8723d_fw $(TARGET_DIR)/lib/firmware/rtl_bt/rtl8723ds_fw.bin
+	cp $(@D)/8723D/rtl8723d_config $(TARGET_DIR)/lib/firmware/rtl_bt/rtl8723ds_config.bin
+endef
+
+$(eval $(generic-package))