diff mbox series

[v2,3/8] package/ruy: new package

Message ID 20221128175851.1913859-3-james.hilliard1@gmail.com
State Superseded, archived
Headers show
Series [v2,1/8] package/flatbuffers: build position independent code | expand

Commit Message

James Hilliard Nov. 28, 2022, 5:58 p.m. UTC
From: Stefan Hager <stefan.hager@ginzinger.com>

This package is required by tensorflow-lite.

Signed-off-by: Stefan Hager <stefan.hager@ginzinger.com>
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/Config.in     |  1 +
 package/ruy/Config.in | 11 +++++++++++
 package/ruy/ruy.hash  |  4 ++++
 package/ruy/ruy.mk    | 18 ++++++++++++++++++
 4 files changed, 34 insertions(+)
 create mode 100644 package/ruy/Config.in
 create mode 100644 package/ruy/ruy.hash
 create mode 100644 package/ruy/ruy.mk

Comments

Hager Stefan Dec. 16, 2022, 5:05 p.m. UTC | #1
Tested-by: Stefan Hager <Stefan.Hager@ginzinger.com>
Acked-by: Stefan Hager <Stefan.Hager@ginzinger.com>


From: James Hilliard <james.hilliard1@gmail.com>
Sent: Monday, November 28, 2022 18:58
To: buildroot@buildroot.org <buildroot@buildroot.org>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>; Fabrice Fontaine <fontaine.fabrice@gmail.com>; Samuel Martin <s.martin49@gmail.com>; Hager Stefan <Stefan.Hager@ginzinger.com>; James Hilliard <james.hilliard1@gmail.com>
Subject: [PATCH v2 3/8] package/ruy: new package 
 
From: Stefan Hager <stefan.hager@ginzinger.com>

This package is required by tensorflow-lite.

Signed-off-by: Stefan Hager <stefan.hager@ginzinger.com>
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/Config.in     |  1 +
 package/ruy/Config.in | 11 +++++++++++
 package/ruy/ruy.hash  |  4 ++++
 package/ruy/ruy.mk    | 18 ++++++++++++++++++
 4 files changed, 34 insertions(+)
 create mode 100644 package/ruy/Config.in
 create mode 100644 package/ruy/ruy.hash
 create mode 100644 package/ruy/ruy.mk

diff --git a/package/Config.in b/package/Config.in
index e09fa0b3bd..45e66caa8c 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -2095,6 +2095,7 @@ endif
         source "package/qhull/Config.in"
         source "package/qlibc/Config.in"
         source "package/riemann-c-client/Config.in"
+       source "package/ruy/Config.in"
         source "package/shapelib/Config.in"
         source "package/skalibs/Config.in"
         source "package/sphinxbase/Config.in"
diff --git a/package/ruy/Config.in b/package/ruy/Config.in
new file mode 100644
index 0000000000..ce7ab5d585
--- /dev/null
+++ b/package/ruy/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_RUY
+       bool "ruy"
+       depends on BR2_INSTALL_LIBSTDCPP
+       select BR2_PACKAGE_CPUINFO
+       help
+         Ruy is a matrix multiplication library. Its focus is to cover
+         the matrix multiplication needs of neural network inference
+         engines. Its initial user has been TensorFlow Lite, where it
+         is used by default on the ARM CPU architecture.
+
+         https://github.com/google/ruy
diff --git a/package/ruy/ruy.hash b/package/ruy/ruy.hash
new file mode 100644
index 0000000000..98266b5881
--- /dev/null
+++ b/package/ruy/ruy.hash
@@ -0,0 +1,4 @@
+# Locally calculated
+sha256  4da8572946007603378c5d0280f48c5b77f4d38763209f5306b57c7513d9a82e  ruy-3168a5c8f4c447fd8cea94078121ee2e2cd87df0.tar.gz
+# License files, locally calculated
+sha256  cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30  LICENSE
diff --git a/package/ruy/ruy.mk b/package/ruy/ruy.mk
new file mode 100644
index 0000000000..ceeea8cd58
--- /dev/null
+++ b/package/ruy/ruy.mk
@@ -0,0 +1,18 @@
+################################################################################
+#
+# ruy
+#
+################################################################################
+
+RUY_VERSION = 3168a5c8f4c447fd8cea94078121ee2e2cd87df0
+RUY_SITE = $(call github,google,ruy,$(RUY_VERSION))
+RUY_LICENSE = Apache-2.0
+RUY_LICENSE_FILES = LICENSE
+RUY_INSTALL_STAGING = YES
+RUY_DEPENDENCIES = cpuinfo
+RUY_CONF_OPTS = \
+       -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
+       -DRUY_FIND_CPUINFO=ON \
+       -DRUY_MINIMAL_BUILD=ON
+
+$(eval $(cmake-package))
Gilles Talis Jan. 10, 2023, 12:31 p.m. UTC | #2
Hi James Stefan,

Le lun. 28 nov. 2022 à 18:59, James Hilliard
<james.hilliard1@gmail.com> a écrit :
>
> From: Stefan Hager <stefan.hager@ginzinger.com>
>
> This package is required by tensorflow-lite.
>
> Signed-off-by: Stefan Hager <stefan.hager@ginzinger.com>
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  package/Config.in     |  1 +
If you want to be maintainers for this package, do not forget to
update the DEVELOPERS file.

>  package/ruy/Config.in | 11 +++++++++++
>  package/ruy/ruy.hash  |  4 ++++
>  package/ruy/ruy.mk    | 18 ++++++++++++++++++
>  4 files changed, 34 insertions(+)
>  create mode 100644 package/ruy/Config.in
>  create mode 100644 package/ruy/ruy.hash
>  create mode 100644 package/ruy/ruy.mk
>
> diff --git a/package/Config.in b/package/Config.in
> index e09fa0b3bd..45e66caa8c 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -2095,6 +2095,7 @@ endif
>         source "package/qhull/Config.in"
>         source "package/qlibc/Config.in"
>         source "package/riemann-c-client/Config.in"
> +       source "package/ruy/Config.in"
>         source "package/shapelib/Config.in"
>         source "package/skalibs/Config.in"
>         source "package/sphinxbase/Config.in"
> diff --git a/package/ruy/Config.in b/package/ruy/Config.in
> new file mode 100644
> index 0000000000..ce7ab5d585
> --- /dev/null
> +++ b/package/ruy/Config.in
> @@ -0,0 +1,11 @@
> +config BR2_PACKAGE_RUY
> +       bool "ruy"
> +       depends on BR2_INSTALL_LIBSTDCPP
The CMakeLists.txt mentions a dependency on C++14. Can you set the
minimum GCC version required? (either 4.9 or 5)

> +       select BR2_PACKAGE_CPUINFO
> +       help
> +         Ruy is a matrix multiplication library. Its focus is to cover
> +         the matrix multiplication needs of neural network inference
> +         engines. Its initial user has been TensorFlow Lite, where it
> +         is used by default on the ARM CPU architecture.
> +
> +         https://github.com/google/ruy
Please mention the dependencies (C++ and C++ version)


> diff --git a/package/ruy/ruy.hash b/package/ruy/ruy.hash
> new file mode 100644
> index 0000000000..98266b5881
> --- /dev/null
> +++ b/package/ruy/ruy.hash
> @@ -0,0 +1,4 @@
> +# Locally calculated
> +sha256  4da8572946007603378c5d0280f48c5b77f4d38763209f5306b57c7513d9a82e  ruy-3168a5c8f4c447fd8cea94078121ee2e2cd87df0.tar.gz
> +# License files, locally calculated
> +sha256  cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30  LICENSE
> diff --git a/package/ruy/ruy.mk b/package/ruy/ruy.mk
> new file mode 100644
> index 0000000000..ceeea8cd58
> --- /dev/null
> +++ b/package/ruy/ruy.mk
> @@ -0,0 +1,18 @@
> +################################################################################
> +#
> +# ruy
> +#
> +################################################################################
> +
> +RUY_VERSION = 3168a5c8f4c447fd8cea94078121ee2e2cd87df0
> +RUY_SITE = $(call github,google,ruy,$(RUY_VERSION))
> +RUY_LICENSE = Apache-2.0
> +RUY_LICENSE_FILES = LICENSE
> +RUY_INSTALL_STAGING = YES
> +RUY_DEPENDENCIES = cpuinfo
> +RUY_CONF_OPTS = \
> +       -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
> +       -DRUY_FIND_CPUINFO=ON \
> +       -DRUY_MINIMAL_BUILD=ON
> +
> +$(eval $(cmake-package))
> --
> 2.34.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index e09fa0b3bd..45e66caa8c 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -2095,6 +2095,7 @@  endif
 	source "package/qhull/Config.in"
 	source "package/qlibc/Config.in"
 	source "package/riemann-c-client/Config.in"
+	source "package/ruy/Config.in"
 	source "package/shapelib/Config.in"
 	source "package/skalibs/Config.in"
 	source "package/sphinxbase/Config.in"
diff --git a/package/ruy/Config.in b/package/ruy/Config.in
new file mode 100644
index 0000000000..ce7ab5d585
--- /dev/null
+++ b/package/ruy/Config.in
@@ -0,0 +1,11 @@ 
+config BR2_PACKAGE_RUY
+	bool "ruy"
+	depends on BR2_INSTALL_LIBSTDCPP
+	select BR2_PACKAGE_CPUINFO
+	help
+	  Ruy is a matrix multiplication library. Its focus is to cover
+	  the matrix multiplication needs of neural network inference
+	  engines. Its initial user has been TensorFlow Lite, where it
+	  is used by default on the ARM CPU architecture.
+
+	  https://github.com/google/ruy
diff --git a/package/ruy/ruy.hash b/package/ruy/ruy.hash
new file mode 100644
index 0000000000..98266b5881
--- /dev/null
+++ b/package/ruy/ruy.hash
@@ -0,0 +1,4 @@ 
+# Locally calculated
+sha256  4da8572946007603378c5d0280f48c5b77f4d38763209f5306b57c7513d9a82e  ruy-3168a5c8f4c447fd8cea94078121ee2e2cd87df0.tar.gz
+# License files, locally calculated
+sha256  cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30  LICENSE
diff --git a/package/ruy/ruy.mk b/package/ruy/ruy.mk
new file mode 100644
index 0000000000..ceeea8cd58
--- /dev/null
+++ b/package/ruy/ruy.mk
@@ -0,0 +1,18 @@ 
+################################################################################
+#
+# ruy
+#
+################################################################################
+
+RUY_VERSION = 3168a5c8f4c447fd8cea94078121ee2e2cd87df0
+RUY_SITE = $(call github,google,ruy,$(RUY_VERSION))
+RUY_LICENSE = Apache-2.0
+RUY_LICENSE_FILES = LICENSE
+RUY_INSTALL_STAGING = YES
+RUY_DEPENDENCIES = cpuinfo
+RUY_CONF_OPTS = \
+	-DCMAKE_POSITION_INDEPENDENT_CODE=ON \
+	-DRUY_FIND_CPUINFO=ON \
+	-DRUY_MINIMAL_BUILD=ON
+
+$(eval $(cmake-package))