diff mbox series

[next,07/25] package/live555: fix build config with locale

Message ID 20221127130739.1862398-8-ricardo.martincoski@gmail.com
State Accepted
Headers show
Series check-symbols v2 | expand

Commit Message

Ricardo Martincoski Nov. 27, 2022, 1:07 p.m. UTC
Using current conditional code, added in 2014:

ifndef ($(BR2_ENABLE_LOCALE),y)
LIVE555_CFLAGS += -DLOCALE_NOT_USED
endif

the define LOCALE_NOT_USED is always passed on CFLAGS, because there is
no symbol with following names defined:
 "(y,y)" -> not defined when BR2_ENABLE_LOCALE=y
 "(,y)" -> not defined when BR2_ENABLE_LOCALE is not set

So fix the typo, switching ifndef to ifneq.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
---
test-pkg config 1:
BR2_PACKAGE_LIVE555=y
https://gitlab.com/RicardoMartincoski/buildroot/-/pipelines/705379816
44 builds, 1 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed

test-pkg config 2:
BR2_PACKAGE_LIVE555=y
BR2_PACKAGE_OPENSSL=y
https://gitlab.com/RicardoMartincoski/buildroot/-/pipelines/705388345
44 builds, 1 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed

test-pkg config 3:
BR2_PACKAGE_LIVE555=y
BR2_PACKAGE_OPENSSL=y
BR2_STATIC_LIBS=y
https://gitlab.com/RicardoMartincoski/buildroot/-/pipelines/705391470
44 builds, 22 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed

test-pkg config 4:
BR2_PACKAGE_LIVE555=y
BR2_STATIC_LIBS=y
https://gitlab.com/RicardoMartincoski/buildroot/-/pipelines/705392278
44 builds, 22 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed
---
 package/live555/live555.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Feb. 6, 2023, 11:06 a.m. UTC | #1
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > Using current conditional code, added in 2014:
 > ifndef ($(BR2_ENABLE_LOCALE),y)
 > LIVE555_CFLAGS += -DLOCALE_NOT_USED
 > endif

 > the define LOCALE_NOT_USED is always passed on CFLAGS, because there is
 > no symbol with following names defined:
 >  "(y,y)" -> not defined when BR2_ENABLE_LOCALE=y
 >  "(,y)" -> not defined when BR2_ENABLE_LOCALE is not set

 > So fix the typo, switching ifndef to ifneq.

 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed, thanks.
Peter Korsgaard Feb. 22, 2023, 4:38 p.m. UTC | #2
>>>>> "Ricardo" == Ricardo Martincoski <ricardo.martincoski@gmail.com> writes:

 > Using current conditional code, added in 2014:
 > ifndef ($(BR2_ENABLE_LOCALE),y)
 > LIVE555_CFLAGS += -DLOCALE_NOT_USED
 > endif

 > the define LOCALE_NOT_USED is always passed on CFLAGS, because there is
 > no symbol with following names defined:
 >  "(y,y)" -> not defined when BR2_ENABLE_LOCALE=y
 >  "(,y)" -> not defined when BR2_ENABLE_LOCALE is not set

 > So fix the typo, switching ifndef to ifneq.

 > Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>

Committed to 2022.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/live555/live555.mk b/package/live555/live555.mk
index effd4517cf..56ed705783 100644
--- a/package/live555/live555.mk
+++ b/package/live555/live555.mk
@@ -39,7 +39,7 @@  else
 LIVE555_CFLAGS += -DNO_OPENSSL
 endif
 
-ifndef ($(BR2_ENABLE_LOCALE),y)
+ifneq ($(BR2_ENABLE_LOCALE),y)
 LIVE555_CFLAGS += -DLOCALE_NOT_USED
 endif