diff mbox series

[2/2] utils/genrandconfig: disallow configs with BR2_XTENSA_CUSTOM=y

Message ID 20221111215759.358116-2-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series [1/2] arch/arch.mk.xtensa: relax check on overlay file to apply only to internal toolchains | expand

Commit Message

Thomas Petazzoni Nov. 11, 2022, 9:57 p.m. UTC
When BR2_XTENSA_CUSTOM=y is used with the internal toolchain, an
overlay file is mandatory, which genrandconfig can't provide. So we
simply disallow such configurations.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 utils/genrandconfig | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Yann E. MORIN Nov. 13, 2022, 9:40 p.m. UTC | #1
Thomas, All,

On 2022-11-11 22:57 +0100, Thomas Petazzoni spake thusly:
> When BR2_XTENSA_CUSTOM=y is used with the internal toolchain, an
> overlay file is mandatory, which genrandconfig can't provide. So we
> simply disallow such configurations.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  utils/genrandconfig | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/utils/genrandconfig b/utils/genrandconfig
> index f19a405685..9c6c2b359c 100755
> --- a/utils/genrandconfig
> +++ b/utils/genrandconfig
> @@ -304,6 +304,11 @@ def fixup_config(sysinfo, configfile):
>      # No C library for internal toolchain
>      if 'BR2_TOOLCHAIN_BUILDROOT_NONE=y' in configlines:
>          return False
> +    # Xtensa custom cores require an overlay file with internal
> +    # toolchains
> +    if 'BR2_XTENSA_CUSTOM=y' in configlines and \
> +       'BR2_TOOLCHAIN_BUILDROOT=y' in configlines:
> +        return False
>  
>      if 'BR2_PACKAGE_AUFS_UTIL=y\n' in configlines and \
>         'BR2_PACKAGE_AUFS_UTIL_VERSION=""\n' in configlines:
> -- 
> 2.38.1
>
Peter Korsgaard Nov. 15, 2022, 1:22 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni via buildroot <buildroot@buildroot.org> writes:

 > When BR2_XTENSA_CUSTOM=y is used with the internal toolchain, an
 > overlay file is mandatory, which genrandconfig can't provide. So we
 > simply disallow such configurations.

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Committed to 2022.08.x, thanks.
diff mbox series

Patch

diff --git a/utils/genrandconfig b/utils/genrandconfig
index f19a405685..9c6c2b359c 100755
--- a/utils/genrandconfig
+++ b/utils/genrandconfig
@@ -304,6 +304,11 @@  def fixup_config(sysinfo, configfile):
     # No C library for internal toolchain
     if 'BR2_TOOLCHAIN_BUILDROOT_NONE=y' in configlines:
         return False
+    # Xtensa custom cores require an overlay file with internal
+    # toolchains
+    if 'BR2_XTENSA_CUSTOM=y' in configlines and \
+       'BR2_TOOLCHAIN_BUILDROOT=y' in configlines:
+        return False
 
     if 'BR2_PACKAGE_AUFS_UTIL=y\n' in configlines and \
        'BR2_PACKAGE_AUFS_UTIL_VERSION=""\n' in configlines: