diff mbox series

From: Michael Nosthoff <buildroot@heine.tech>

Message ID 20221110101621.181532-1-buildroot@heine.tech
State Superseded
Headers show
Series From: Michael Nosthoff <buildroot@heine.tech> | expand

Commit Message

Michael Nosthoff Nov. 10, 2022, 10:16 a.m. UTC
when using BR2_PER_PACKAGE_DIRECTORIES and configuring swupdate to
use uboot the build fails because libubootenv is not a dependency.

Fixes:
bootloader/uboot.c:23:10: fatal error: libuboot.h: No such file or directory
   23 | #include <libuboot.h>

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
---

v2:
 - exchange "buildroot" with "uboot" in the description

observed on buildroot 2022.08.1 so I guess older version might also need the fix.
CC: Peter Korsgaard <peter@korsgaard.com>
---
 package/swupdate/swupdate.mk | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/package/swupdate/swupdate.mk b/package/swupdate/swupdate.mk
index bfc161d490..ed0c1e56a8 100644
--- a/package/swupdate/swupdate.mk
+++ b/package/swupdate/swupdate.mk
@@ -81,6 +81,10 @@  else
 SWUPDATE_MAKE_ENV += HAVE_LIBGPIOD=n
 endif
 
+ifeq ($(BR2_PACKAGE_LIBUBOOTENV),y)
+SWUPDATE_DEPENDENCIES += libubootenv
+endif
+
 ifeq ($(BR2_PACKAGE_LIBURIPARSER),y)
 SWUPDATE_DEPENDENCIES += liburiparser
 SWUPDATE_MAKE_ENV += HAVE_URIPARSER=y