diff mbox series

[1/1] package/swupdate: specify SWU_VER during build

Message ID 20221104151242.2735240-1-vfazio@xes-inc.com
State Accepted
Headers show
Series [1/1] package/swupdate: specify SWU_VER during build | expand

Commit Message

Vincent Fazio Nov. 4, 2022, 3:12 p.m. UTC
The swupdate build process uses SWU_VER as part of the build commandline
for compiling objects to define the value for use in globals.h (see also
Makefile.flags).

This value is also used to communicate capabilities to lua handlers
(see upstream 0f38ff186e76c55c8d00ccb53739a29bcca91445).

When swupdate gets built, SWU_VER defaults to using `git describe` to
determine the version. This, unfortunately, picks up the version of the
Buildroot checkout and not the actual version of swupdate.

Now, specify SWU_VER as part of the make options to override the
calculated value so the proper version is reported.

Signed-off-by: Vincent Fazio <vfazio@xes-inc.com>
---
 package/swupdate/swupdate.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Nov. 5, 2022, 8:03 p.m. UTC | #1
On Fri,  4 Nov 2022 10:12:42 -0500
Vincent Fazio <vfazio@xes-inc.com> wrote:

> The swupdate build process uses SWU_VER as part of the build commandline
> for compiling objects to define the value for use in globals.h (see also
> Makefile.flags).
> 
> This value is also used to communicate capabilities to lua handlers
> (see upstream 0f38ff186e76c55c8d00ccb53739a29bcca91445).
> 
> When swupdate gets built, SWU_VER defaults to using `git describe` to
> determine the version. This, unfortunately, picks up the version of the
> Buildroot checkout and not the actual version of swupdate.
> 
> Now, specify SWU_VER as part of the make options to override the
> calculated value so the proper version is reported.
> 
> Signed-off-by: Vincent Fazio <vfazio@xes-inc.com>
> ---
>  package/swupdate/swupdate.mk | 1 +
>  1 file changed, 1 insertion(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Nov. 14, 2022, 3:40 p.m. UTC | #2
>>>>> "Vincent" == Vincent Fazio <vfazio@xes-inc.com> writes:

 > The swupdate build process uses SWU_VER as part of the build commandline
 > for compiling objects to define the value for use in globals.h (see also
 > Makefile.flags).

 > This value is also used to communicate capabilities to lua handlers
 > (see upstream 0f38ff186e76c55c8d00ccb53739a29bcca91445).

 > When swupdate gets built, SWU_VER defaults to using `git describe` to
 > determine the version. This, unfortunately, picks up the version of the
 > Buildroot checkout and not the actual version of swupdate.

 > Now, specify SWU_VER as part of the make options to override the
 > calculated value so the proper version is reported.

 > Signed-off-by: Vincent Fazio <vfazio@xes-inc.com>

Committed to 2022.08.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/swupdate/swupdate.mk b/package/swupdate/swupdate.mk
index b2f50d2b71..2f618b2e79 100644
--- a/package/swupdate/swupdate.mk
+++ b/package/swupdate/swupdate.mk
@@ -209,6 +209,7 @@  SWUPDATE_KCONFIG_FILE = $(call qstrip,$(BR2_PACKAGE_SWUPDATE_CONFIG))
 SWUPDATE_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
 
 SWUPDATE_MAKE_OPTS = \
+	SWU_VER="$(SWUPDATE_VERSION) (Buildroot $(BR2_VERSION_FULL))"
 	CROSS_COMPILE="$(TARGET_CROSS)" \
 	CONFIG_EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
 	CONFIG_EXTRA_LDFLAGS="$(TARGET_LDFLAGS)"