diff mbox series

[3/3] support/testing/tests/package/test_gdb.py: drop version-specific tests

Message ID 20221101181320.368702-3-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series [1/3] support/testing/tests/package/test_python_flask*: increase time after server startup | expand

Commit Message

Thomas Petazzoni Nov. 1, 2022, 6:13 p.m. UTC
Back when support/testing/tests/package/test_gdb was introduced, there
was a significant difference in how gdb < 10 and gdb >= 10 were
handled in gdb.mk, which explained why we were testing both gdb 9.x
and gdb 11.x.

However, support for gdb 9.x has now been dropped, and we only support
gdb >= 10.x, so testing gdb 9.x and 11.x separately no longer make
much sense. In addition:

 - other GDB tests in the same file already test the default version,
 which is now 11.x, meaning we in fact have duplicated tests between
 the ones testing the default version and the ones testing 11.x
 specifically

 - GDB 9.x has been removed, which means all the tests testing GDB 9.x
 are failing, with a Config.in.legacy build error.

Fixes:

  https://gitlab.com/buildroot.org/buildroot/-/jobs/3249828456 (TestGdbHostOnly9x)
  https://gitlab.com/buildroot.org/buildroot/-/jobs/3249828454 (TestGdbHostGdbserver9x)
  https://gitlab.com/buildroot.org/buildroot/-/jobs/3249828451 (TestGdbHostGdbTarget9x)

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 support/testing/tests/package/test_gdb.py | 108 ----------------------
 1 file changed, 108 deletions(-)
diff mbox series

Patch

diff --git a/support/testing/tests/package/test_gdb.py b/support/testing/tests/package/test_gdb.py
index a7b0870644..4712162349 100644
--- a/support/testing/tests/package/test_gdb.py
+++ b/support/testing/tests/package/test_gdb.py
@@ -91,114 +91,6 @@  class TestGdbFullTarget(BaseGdb):
         self.verify_gdb()
 
 
-class TestGdbHostOnly9x(BaseGdb):
-    config = \
-        infra.basetest.MINIMAL_CONFIG + \
-        """
-        BR2_arm=y
-        BR2_TOOLCHAIN_EXTERNAL=y
-        BR2_TOOLCHAIN_EXTERNAL_BOOTLIN=y
-        BR2_PACKAGE_HOST_GDB=y
-        BR2_GDB_VERSION_9_2=y
-        """
-
-    def test_run(self):
-        self.verify_host_gdb()
-
-
-class TestGdbHostGdbserver9x(BaseGdb):
-    config = \
-        """
-        BR2_arm=y
-        BR2_TOOLCHAIN_EXTERNAL=y
-        BR2_TOOLCHAIN_EXTERNAL_BOOTLIN=y
-        BR2_PACKAGE_HOST_GDB=y
-        BR2_GDB_VERSION_9_2=y
-        BR2_PACKAGE_GDB=y
-        BR2_TARGET_ROOTFS_CPIO=y
-        # BR2_TARGET_ROOTFS_TAR is not set
-        """
-
-    def test_run(self):
-        self.verify_host_gdb()
-        self.boot()
-        self.verify_gdbserver()
-
-
-class TestGdbHostGdbTarget9x(BaseGdb):
-    config = \
-        """
-        BR2_arm=y
-        BR2_TOOLCHAIN_EXTERNAL=y
-        BR2_TOOLCHAIN_EXTERNAL_BOOTLIN=y
-        BR2_PACKAGE_HOST_GDB=y
-        BR2_GDB_VERSION_9_2=y
-        BR2_PACKAGE_GDB=y
-        BR2_PACKAGE_GDB_DEBUGGER=y
-        BR2_TARGET_ROOTFS_CPIO=y
-        # BR2_TARGET_ROOTFS_TAR is not set
-        """
-
-    def test_run(self):
-        self.verify_host_gdb()
-        self.boot()
-        self.verify_gdb()
-
-
-class TestGdbHostOnly11x(BaseGdb):
-    config = \
-        infra.basetest.MINIMAL_CONFIG + \
-        """
-        BR2_arm=y
-        BR2_TOOLCHAIN_EXTERNAL=y
-        BR2_TOOLCHAIN_EXTERNAL_BOOTLIN=y
-        BR2_PACKAGE_HOST_GDB=y
-        BR2_GDB_VERSION_11=y
-        """
-
-    def test_run(self):
-        self.verify_host_gdb()
-
-
-class TestGdbHostGdbserver11x(BaseGdb):
-    config = \
-        """
-        BR2_arm=y
-        BR2_TOOLCHAIN_EXTERNAL=y
-        BR2_TOOLCHAIN_EXTERNAL_BOOTLIN=y
-        BR2_PACKAGE_HOST_GDB=y
-        BR2_GDB_VERSION_11=y
-        BR2_PACKAGE_GDB=y
-        BR2_TARGET_ROOTFS_CPIO=y
-        # BR2_TARGET_ROOTFS_TAR is not set
-        """
-
-    def test_run(self):
-        self.verify_host_gdb()
-        self.boot()
-        self.verify_gdbserver()
-
-
-class TestGdbHostGdbTarget11x(BaseGdb):
-    config = \
-        """
-        BR2_arm=y
-        BR2_TOOLCHAIN_EXTERNAL=y
-        BR2_TOOLCHAIN_EXTERNAL_BOOTLIN=y
-        BR2_PACKAGE_HOST_GDB=y
-        BR2_GDB_VERSION_11=y
-        BR2_PACKAGE_GDB=y
-        BR2_PACKAGE_GDB_DEBUGGER=y
-        BR2_TARGET_ROOTFS_CPIO=y
-        # BR2_TARGET_ROOTFS_TAR is not set
-        """
-
-    def test_run(self):
-        self.verify_host_gdb()
-        self.boot()
-        self.verify_gdb()
-
-
 class TestGdbArc(BaseGdb):
     config = \
         """