diff mbox series

[1/2] package/libglib2: bump to version 2.74.0

Message ID 20221007133912.2869000-1-james.hilliard1@gmail.com
State Superseded
Headers show
Series [1/2] package/libglib2: bump to version 2.74.0 | expand

Commit Message

James Hilliard Oct. 7, 2022, 1:39 p.m. UTC
Drop patch which is now upstream.

Replace pcre with pcre2 dependency.

Drop no longer supported fam option.

COPYING hash changed due to formatting changes.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 .../0002-remove-cpp-requirement.patch         | 87 -------------------
 package/libglib2/libglib2.hash                |  6 +-
 package/libglib2/libglib2.mk                  |  9 +-
 3 files changed, 7 insertions(+), 95 deletions(-)
 delete mode 100644 package/libglib2/0002-remove-cpp-requirement.patch

Comments

Yann E. MORIN May 13, 2023, 11:53 a.m. UTC | #1
James, All,
On 2022-10-07 07:39 -0600, James Hilliard spake thusly:
> Drop patch which is now upstream.
> 
> Replace pcre with pcre2 dependency.
> 
> Drop no longer supported fam option.
> 
> COPYING hash changed due to formatting changes.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
[--SNIP--]
> diff --git a/package/libglib2/libglib2.mk b/package/libglib2/libglib2.mk
> index 2970d5a7a9..a0dea81c3f 100644
> --- a/package/libglib2/libglib2.mk
> +++ b/package/libglib2/libglib2.mk
> @@ -4,8 +4,8 @@
>  #
>  ################################################################################
>  
> -LIBGLIB2_VERSION_MAJOR = 2.72
> -LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).3
> +LIBGLIB2_VERSION_MAJOR = 2.74
> +LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).0

We now have 2.76.1 (with a patch pending for 2.76.2), so I've marked
this bump as superseded, thansk!

Regards,
Yann E. MORIN.

>  LIBGLIB2_SOURCE = glib-$(LIBGLIB2_VERSION).tar.xz
>  LIBGLIB2_SITE = http://ftp.gnome.org/pub/gnome/sources/glib/$(LIBGLIB2_VERSION_MAJOR)
>  LIBGLIB2_LICENSE = LGPL-2.1+
> @@ -24,7 +24,6 @@ endif
>  
>  HOST_LIBGLIB2_CONF_OPTS = \
>  	-Ddtrace=false \
> -	-Dfam=false \
>  	-Dglib_debug=disabled \
>  	-Dlibelf=disabled \
>  	-Dselinux=disabled \
> @@ -35,12 +34,12 @@ HOST_LIBGLIB2_CONF_OPTS = \
>  
>  LIBGLIB2_DEPENDENCIES = \
>  	host-pkgconf host-libglib2 \
> -	libffi pcre zlib $(TARGET_NLS_DEPENDENCIES)
> +	libffi pcre2 zlib $(TARGET_NLS_DEPENDENCIES)
>  
>  HOST_LIBGLIB2_DEPENDENCIES = \
>  	host-gettext \
>  	host-libffi \
> -	host-pcre \
> +	host-pcre2 \
>  	host-pkgconf \
>  	host-util-linux \
>  	host-zlib
> -- 
> 2.34.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/libglib2/0002-remove-cpp-requirement.patch b/package/libglib2/0002-remove-cpp-requirement.patch
deleted file mode 100644
index 84511dea32..0000000000
--- a/package/libglib2/0002-remove-cpp-requirement.patch
+++ /dev/null
@@ -1,87 +0,0 @@ 
-From dd65a8cfdeafeb18b72d8d1eb676c7ca43ae505f Mon Sep 17 00:00:00 2001
-From: Adam Duskett <Aduskett@gmail.com>
-Date: Mon, 16 Sep 2019 10:12:38 -0700
-Subject: [PATCH] remove cpp requirement
-
-The c++ test is necessary to ensure libglib doesn't accidentally use C++
-reserved keywords in public headers. Because this is just a test, it isn't
-necessary to have a C++ compiler to build libglib2.
-
-Signed-off-by: Adam Duskett <Aduskett@gmail.com>
-Upstream status: Denied (Buildroot specific)
-https://gitlab.gnome.org/GNOME/glib/issues/1748
----
- glib/glibconfig.h.in |  1 -
- meson.build          | 19 +------------------
- 2 files changed, 1 insertion(+), 19 deletions(-)
-
-diff --git a/glib/glibconfig.h.in b/glib/glibconfig.h.in
-index e66748d95..2173d8be6 100644
---- a/glib/glibconfig.h.in
-+++ b/glib/glibconfig.h.in
-@@ -119,7 +119,6 @@ typedef unsigned @glib_intptr_type_define@ guintptr;
- @glib_vacopy@
- 
- @g_have_iso_c_varargs@
--@g_have_iso_cxx_varargs@
- 
- /* gcc-2.95.x supports both gnu style and ISO varargs, but if -ansi
-  * is passed ISO vararg support is turned off, and there is no work
-diff --git a/meson.build b/meson.build
-index 48fdfe864..5df242e39 100644
---- a/meson.build
-+++ b/meson.build
-@@ -1,4 +1,4 @@
--project('glib', 'c', 'cpp',
-+project('glib', 'c',
-   version : '2.72.3',
-   # NOTE: We keep this pinned at 0.52 because that's what Debian Stable ships
-   meson_version : '>= 0.52.0',
-@@ -10,7 +10,6 @@ project('glib', 'c', 'cpp',
- )
- 
- cc = meson.get_compiler('c')
--cxx = meson.get_compiler('cpp')
- 
- cc_can_run = not meson.is_cross_build() or meson.has_exe_wrapper()
- 
-@@ -495,7 +494,6 @@ else
- endif
- 
- add_project_arguments(cc.get_supported_arguments(warning_c_args), language: 'c')
--add_project_arguments(cxx.get_supported_arguments(warning_cxx_args), language: 'cpp')
- 
- # FIXME: We cannot build some of the GResource tests with -z nodelete, which
- # means we cannot use that flag in add_project_link_arguments(), and must add
-@@ -1734,20 +1732,6 @@ if g_have_iso_c_varargs
- #endif''')
- endif
- 
--g_have_iso_cxx_varargs = cxx.compiles('''
--  void some_func (void) {
--    int a(int p1, int p2, int p3);
--    #define call_a(...) a(1,__VA_ARGS__)
--    call_a(2,3);
--  }''', name : 'ISO C99 varargs macros in C++')
--
--if g_have_iso_cxx_varargs
--  glibconfig_conf.set('g_have_iso_cxx_varargs', '''
--#ifdef __cplusplus
--# define G_HAVE_ISO_VARARGS 1
--#endif''')
--endif
--
- g_have_gnuc_varargs = cc.compiles('''
-   void some_func (void) {
-     int a(int p1, int p2, int p3);
-@@ -2381,7 +2365,6 @@ subdir('gobject')
- subdir('gthread')
- subdir('gmodule')
- subdir('gio')
--subdir('fuzzing')
- if build_tests
-   subdir('tests')
- endif
--- 
-2.34.1
-
diff --git a/package/libglib2/libglib2.hash b/package/libglib2/libglib2.hash
index 0395ff234a..ccda94f7c1 100644
--- a/package/libglib2/libglib2.hash
+++ b/package/libglib2/libglib2.hash
@@ -1,4 +1,4 @@ 
-# https://download.gnome.org/sources/glib/2.72/glib-2.72.3.sha256sum
-sha256  4a39a2f624b8512d500d5840173eda7fa85f51c109052eae806acece85d345f0  glib-2.72.3.tar.xz
+# https://download.gnome.org/sources/glib/2.74/glib-2.74.0.sha256sum
+sha256  3652c7f072d7b031a6b5edd623f77ebc5dcd2ae698598abcc89ff39ca75add30  glib-2.74.0.tar.xz
 # License files, locally calculated
-sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING
+sha256  fa6f36630bb1e0c571d34b2bbdf188d08495c9dbf58f28cac112f303fc1f58fb  COPYING
diff --git a/package/libglib2/libglib2.mk b/package/libglib2/libglib2.mk
index 2970d5a7a9..a0dea81c3f 100644
--- a/package/libglib2/libglib2.mk
+++ b/package/libglib2/libglib2.mk
@@ -4,8 +4,8 @@ 
 #
 ################################################################################
 
-LIBGLIB2_VERSION_MAJOR = 2.72
-LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).3
+LIBGLIB2_VERSION_MAJOR = 2.74
+LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).0
 LIBGLIB2_SOURCE = glib-$(LIBGLIB2_VERSION).tar.xz
 LIBGLIB2_SITE = http://ftp.gnome.org/pub/gnome/sources/glib/$(LIBGLIB2_VERSION_MAJOR)
 LIBGLIB2_LICENSE = LGPL-2.1+
@@ -24,7 +24,6 @@  endif
 
 HOST_LIBGLIB2_CONF_OPTS = \
 	-Ddtrace=false \
-	-Dfam=false \
 	-Dglib_debug=disabled \
 	-Dlibelf=disabled \
 	-Dselinux=disabled \
@@ -35,12 +34,12 @@  HOST_LIBGLIB2_CONF_OPTS = \
 
 LIBGLIB2_DEPENDENCIES = \
 	host-pkgconf host-libglib2 \
-	libffi pcre zlib $(TARGET_NLS_DEPENDENCIES)
+	libffi pcre2 zlib $(TARGET_NLS_DEPENDENCIES)
 
 HOST_LIBGLIB2_DEPENDENCIES = \
 	host-gettext \
 	host-libffi \
-	host-pcre \
+	host-pcre2 \
 	host-pkgconf \
 	host-util-linux \
 	host-zlib