diff mbox series

[v2] package/chartjs: fix installation

Message ID 20220926095203.r5u22akkpbj66rpg@zenon.in.qult.net
State Accepted
Headers show
Series [v2] package/chartjs: fix installation | expand

Commit Message

Ignacy Gawędzki Sept. 26, 2022, 9:52 a.m. UTC
Version 3.9.1 does not distribute a CSS file nor a bundle.  Install
only the minified Javascript source.

http://autobuild.buildroot.net/?reason=chartjs-3.9.1

Signed-off-by: Ignacy Gawędzki <ignacy.gawedzki@green-communications.fr>
---
Changes v1 -> v2:
  - add link to autobuild failure
---
 package/chartjs/chartjs.mk | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

Comments

Thomas Petazzoni Sept. 26, 2022, 12:01 p.m. UTC | #1
On Mon, 26 Sep 2022 11:52:03 +0200
Ignacy Gawędzki <ignacy.gawedzki@green-communications.fr> wrote:

> Version 3.9.1 does not distribute a CSS file nor a bundle.  Install
> only the minified Javascript source.
> 
> http://autobuild.buildroot.net/?reason=chartjs-3.9.1

We want to have a link to one specific build issue. Indeed, imagine
other chartjs-3.9.1 build issues pop up once this issue has been fixed.
Then this link would no longer make sense, as we wouldn't know which
specific build issue it was fixing.

So I have replaced this link with a link to one specific occurrence of
the build issue, and applied. Thanks a lot!

Thomas
diff mbox series

Patch

diff --git a/package/chartjs/chartjs.mk b/package/chartjs/chartjs.mk
index 585b4be285..5ed4b3d9c3 100644
--- a/package/chartjs/chartjs.mk
+++ b/package/chartjs/chartjs.mk
@@ -13,12 +13,8 @@  CHARTJS_CPE_ID_VENDOR = chartjs
 CHARTJS_CPE_ID_PRODUCT = chart.js
 
 define CHARTJS_INSTALL_TARGET_CMDS
-	$(INSTALL) -m 0644 -D $(@D)/dist/Chart.min.css \
-		$(TARGET_DIR)/var/www/chartjs/css/Chart.css
-	$(INSTALL) -m 0644 -D $(@D)/dist/Chart.min.js \
+	$(INSTALL) -m 0644 -D $(@D)/dist/chart.min.js \
 		$(TARGET_DIR)/var/www/chartjs/js/Chart.js
-	$(INSTALL) -m 0644 -D $(@D)/dist/Chart.bundle.min.js \
-		$(TARGET_DIR)/var/www/chartjs/js/Chart.bundle.js
 endef
 
 $(eval $(generic-package))