diff mbox series

package/collectd: work around gcc bug 68485

Message ID 20220924230826.283565-1-giulio.benetti@benettiengineering.com
State Accepted
Headers show
Series package/collectd: work around gcc bug 68485 | expand

Commit Message

Giulio Benetti Sept. 24, 2022, 11:08 p.m. UTC
collectd is impacted by the microblaze-specific gcc bug #68485 [0].

As for all other impacted packages, force no optimisation when using a
toolchain riddled with that bug.

Fixes:
   http://autobuild.buildroot.net/results/6a8/6a87bbe17e6f606a97097800dc484a7b17bffa7d/

[0] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 package/collectd/collectd.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Thomas Petazzoni Sept. 26, 2022, 12:09 p.m. UTC | #1
On Sun, 25 Sep 2022 01:08:26 +0200
Giulio Benetti <giulio.benetti@benettiengineering.com> wrote:

> collectd is impacted by the microblaze-specific gcc bug #68485 [0].
> 
> As for all other impacted packages, force no optimisation when using a
> toolchain riddled with that bug.
> 
> Fixes:
>    http://autobuild.buildroot.net/results/6a8/6a87bbe17e6f606a97097800dc484a7b17bffa7d/
> 
> [0] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
> ---
>  package/collectd/collectd.mk | 8 ++++++++
>  1 file changed, 8 insertions(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Oct. 12, 2022, 3:44 p.m. UTC | #2
>>>>> "Giulio" == Giulio Benetti <giulio.benetti@benettiengineering.com> writes:

 > collectd is impacted by the microblaze-specific gcc bug #68485 [0].
 > As for all other impacted packages, force no optimisation when using a
 > toolchain riddled with that bug.

 > Fixes:
 >    http://autobuild.buildroot.net/results/6a8/6a87bbe17e6f606a97097800dc484a7b17bffa7d/

 > [0] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485

 > Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>

Committed to 2022.02.x and 2022.08.x, thanks.
diff mbox series

Patch

diff --git a/package/collectd/collectd.mk b/package/collectd/collectd.mk
index 5751757040..5510c265e8 100644
--- a/package/collectd/collectd.mk
+++ b/package/collectd/collectd.mk
@@ -27,6 +27,14 @@  COLLECTD_PLUGINS_DISABLE = \
 
 COLLECTD_CONF_ENV += LIBS="-lm"
 
+COLLECTD_CFLAGS = $(TARGET_CFLAGS)
+
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)
+COLLECTD_CFLAGS += -O0
+endif
+
+COLLECTD_CONF_ENV += CFLAGS="$(COLLECTD_CFLAGS)"
+
 #
 # NOTE: There's also a third availible setting "intswap", which might
 # be needed on some old ARM hardware (see [2]), but is not being