diff mbox series

[v2,1/2] boot/optee-os: remove host-python-pillow build dependency

Message ID 20220906102322.899679-1-kory.maincent@bootlin.com
State Accepted
Headers show
Series [v2,1/2] boot/optee-os: remove host-python-pillow build dependency | expand

Commit Message

Kory Maincent Sept. 6, 2022, 10:23 a.m. UTC
From: Kory Maincent <kory.maincent@bootlin.com>

host-python-pillow dependency was needed to build the STMicroelecronics
version during its rc versions but is is not needed anymore in the release.
It is then useless to keep this dependency.

Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
---
 boot/optee-os/Config.in   | 7 -------
 boot/optee-os/optee-os.mk | 4 ----
 2 files changed, 11 deletions(-)

Comments

Yann E. MORIN Sept. 6, 2022, 11:47 a.m. UTC | #1
Köry, All,

On 2022-09-06 12:23 +0200, Köry Maincent via buildroot spake thusly:
> From: Kory Maincent <kory.maincent@bootlin.com>
> 
> host-python-pillow dependency was needed to build the STMicroelecronics
> version during its rc versions but is is not needed anymore in the release.
> It is then useless to keep this dependency.
> 
> Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>

You forgot to add an entry in Config.in.legacy. But since that option
was never part of a release, we indeed do not want to add a legacy
entry.

Applied to master (yes, master on purpose), thanks.

Regards,
Yann E. MORIN.

> ---
>  boot/optee-os/Config.in   | 7 -------
>  boot/optee-os/optee-os.mk | 4 ----
>  2 files changed, 11 deletions(-)
> 
> diff --git a/boot/optee-os/Config.in b/boot/optee-os/Config.in
> index db7a93c10c..5244700bc2 100644
> --- a/boot/optee-os/Config.in
> +++ b/boot/optee-os/Config.in
> @@ -91,13 +91,6 @@ config BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_CRYPTOGRAPHY
>  	  python-cryptography. Select this option if optee-os needs
>  	  python-cryptography to be built.
>  
> -config BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_PILLOW
> -	bool "OP-TEE OS needs host-python-pillow"
> -	help
> -	  Some specific OP-TEE OS versions may use python-pillow to
> -	  build the Trusted User Interface feature.  Select this
> -	  option if optee-os need python-pillow to be built.
> -
>  config BR2_TARGET_OPTEE_OS_CORE
>  	bool "Build core"
>  	default y
> diff --git a/boot/optee-os/optee-os.mk b/boot/optee-os/optee-os.mk
> index 136c4b2401..38b0d367ef 100644
> --- a/boot/optee-os/optee-os.mk
> +++ b/boot/optee-os/optee-os.mk
> @@ -36,10 +36,6 @@ else
>  OPTEE_OS_DEPENDENCIES += host-python-pycryptodomex
>  endif
>  
> -ifeq ($(BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_PILLOW),y)
> -OPTEE_OS_DEPENDENCIES += host-python-pillow
> -endif
> -
>  ifeq ($(BR2_TARGET_OPTEE_OS_NEEDS_DTC),y)
>  OPTEE_OS_DEPENDENCIES += host-dtc
>  endif
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/boot/optee-os/Config.in b/boot/optee-os/Config.in
index db7a93c10c..5244700bc2 100644
--- a/boot/optee-os/Config.in
+++ b/boot/optee-os/Config.in
@@ -91,13 +91,6 @@  config BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_CRYPTOGRAPHY
 	  python-cryptography. Select this option if optee-os needs
 	  python-cryptography to be built.
 
-config BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_PILLOW
-	bool "OP-TEE OS needs host-python-pillow"
-	help
-	  Some specific OP-TEE OS versions may use python-pillow to
-	  build the Trusted User Interface feature.  Select this
-	  option if optee-os need python-pillow to be built.
-
 config BR2_TARGET_OPTEE_OS_CORE
 	bool "Build core"
 	default y
diff --git a/boot/optee-os/optee-os.mk b/boot/optee-os/optee-os.mk
index 136c4b2401..38b0d367ef 100644
--- a/boot/optee-os/optee-os.mk
+++ b/boot/optee-os/optee-os.mk
@@ -36,10 +36,6 @@  else
 OPTEE_OS_DEPENDENCIES += host-python-pycryptodomex
 endif
 
-ifeq ($(BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_PILLOW),y)
-OPTEE_OS_DEPENDENCIES += host-python-pillow
-endif
-
 ifeq ($(BR2_TARGET_OPTEE_OS_NEEDS_DTC),y)
 OPTEE_OS_DEPENDENCIES += host-dtc
 endif