diff mbox series

package/python-pillow: remove host-python-pillow support

Message ID 20220906081425.854318-1-kory.maincent@bootlin.com
State Changes Requested
Headers show
Series package/python-pillow: remove host-python-pillow support | expand

Commit Message

Kory Maincent Sept. 6, 2022, 8:14 a.m. UTC
From: Kory Maincent <kory.maincent@bootlin.com>

host-python-pillow was needed to build optee-os from STMicroelecronics
during its rc versions but is is not needed anymore in the release.
It is then useless to keep this support.

Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
---
 package/python-pillow/python-pillow.mk | 14 --------------
 1 file changed, 14 deletions(-)

Comments

Yann E. MORIN Sept. 6, 2022, 8:24 a.m. UTC | #1
Köry, All,

On 2022-09-06 10:14 +0200, Köry Maincent spake thusly:
> From: Kory Maincent <kory.maincent@bootlin.com>
> 
> host-python-pillow was needed to build optee-os from STMicroelecronics
> during its rc versions but is is not needed anymore in the release.
> It is then useless to keep this support.

Err, did you forget to remove it from optee-os?

Regards,
Yann E. MORIN.

> Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
> ---
>  package/python-pillow/python-pillow.mk | 14 --------------
>  1 file changed, 14 deletions(-)
> 
> diff --git a/package/python-pillow/python-pillow.mk b/package/python-pillow/python-pillow.mk
> index 7cff54e9ea..31725a3e46 100644
> --- a/package/python-pillow/python-pillow.mk
> +++ b/package/python-pillow/python-pillow.mk
> @@ -71,18 +71,4 @@ else
>  PYTHON_PILLOW_BUILD_OPTS += --disable-webp --disable-webpmux
>  endif
>  
> -HOST_PYTHON_PILLOW_DEPENDENCIES = host-pkgconf
> -HOST_PYTHON_PILLOW_BUILD_OPTS = \
> -	build_ext \
> -	--disable-freetype \
> -	--disable-jpeg \
> -	--disable-lcms \
> -	--disable-xcb \
> -	--disable-jpeg2000 \
> -	--disable-tiff \
> -	--disable-webp \
> -	--disable-webpmux
> -HOST_PYTHON_PILLOW_INSTALL_OPTS = $(HOST_PYTHON_PILLOW_BUILD_OPTS)
> -
>  $(eval $(python-package))
> -$(eval $(host-python-package))
> -- 
> 2.25.1
>
Kory Maincent Sept. 6, 2022, 8:39 a.m. UTC | #2
On Tue, 6 Sep 2022 10:24:38 +0200
"Yann E. MORIN" <yann.morin.1998@free.fr> wrote:

> Köry, All,
> 
> On 2022-09-06 10:14 +0200, Köry Maincent spake thusly:
> > From: Kory Maincent <kory.maincent@bootlin.com>
> > 
> > host-python-pillow was needed to build optee-os from STMicroelecronics
> > during its rc versions but is is not needed anymore in the release.
> > It is then useless to keep this support.  
> 
> Err, did you forget to remove it from optee-os?

Doh, That's true I did it to quickly. I will fix that with new patches.
Sorry for it.

Regards,
diff mbox series

Patch

diff --git a/package/python-pillow/python-pillow.mk b/package/python-pillow/python-pillow.mk
index 7cff54e9ea..31725a3e46 100644
--- a/package/python-pillow/python-pillow.mk
+++ b/package/python-pillow/python-pillow.mk
@@ -71,18 +71,4 @@  else
 PYTHON_PILLOW_BUILD_OPTS += --disable-webp --disable-webpmux
 endif
 
-HOST_PYTHON_PILLOW_DEPENDENCIES = host-pkgconf
-HOST_PYTHON_PILLOW_BUILD_OPTS = \
-	build_ext \
-	--disable-freetype \
-	--disable-jpeg \
-	--disable-lcms \
-	--disable-xcb \
-	--disable-jpeg2000 \
-	--disable-tiff \
-	--disable-webp \
-	--disable-webpmux
-HOST_PYTHON_PILLOW_INSTALL_OPTS = $(HOST_PYTHON_PILLOW_BUILD_OPTS)
-
 $(eval $(python-package))
-$(eval $(host-python-package))