diff mbox series

[1/1] package/libiio: bump to version v0.24

Message ID 20220829103049.17780-1-paul@crapouillou.net
State Accepted
Headers show
Series [1/1] package/libiio: bump to version v0.24 | expand

Commit Message

Paul Cercueil Aug. 29, 2022, 10:30 a.m. UTC
The changelog is available here:
https://github.com/analogdevicesinc/libiio/releases/tag/v0.24

Remove the 0001 patch as it is included in the v0.24 version.

Signed-off-by: Paul Cercueil <paul@crapouillou.net>
---
 ...rs-setters-cannot-be-marked-readonly.patch | 32 -------------------
 package/libiio/libiio.hash                    |  2 +-
 package/libiio/libiio.mk                      |  2 +-
 3 files changed, 2 insertions(+), 34 deletions(-)
 delete mode 100644 package/libiio/0001-C-public-fields-with-getters-setters-cannot-be-marked-readonly.patch

Comments

Thomas Petazzoni Aug. 29, 2022, 8:08 p.m. UTC | #1
On Mon, 29 Aug 2022 11:30:49 +0100
Paul Cercueil <paul@crapouillou.net> wrote:

> The changelog is available here:
> https://github.com/analogdevicesinc/libiio/releases/tag/v0.24
> 
> Remove the 0001 patch as it is included in the v0.24 version.
> 
> Signed-off-by: Paul Cercueil <paul@crapouillou.net>
> ---
>  ...rs-setters-cannot-be-marked-readonly.patch | 32 -------------------
>  package/libiio/libiio.hash                    |  2 +-
>  package/libiio/libiio.mk                      |  2 +-
>  3 files changed, 2 insertions(+), 34 deletions(-)
>  delete mode 100644 package/libiio/0001-C-public-fields-with-getters-setters-cannot-be-marked-readonly.patch

Applied to next, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/libiio/0001-C-public-fields-with-getters-setters-cannot-be-marked-readonly.patch b/package/libiio/0001-C-public-fields-with-getters-setters-cannot-be-marked-readonly.patch
deleted file mode 100644
index a665d48363..0000000000
--- a/package/libiio/0001-C-public-fields-with-getters-setters-cannot-be-marked-readonly.patch
+++ /dev/null
@@ -1,32 +0,0 @@ 
-From 85bf9cd32138539252ed01c355cf766612cf47c9 Mon Sep 17 00:00:00 2001
-From: Paul Cercueil <paul@crapouillou.net>
-Date: Thu, 2 Sep 2021 11:04:21 +0100
-Subject: [PATCH] C#: public fields with getters/setters cannot be marked
- readonly
-
-MSVC would fail with the following error:
-error CS0106: The modifier 'readonly' is not valid for this item
-
-Reported-by: Raluca Chis <raluca.chis@analog.com>
-Signed-off-by: Paul Cercueil <paul@crapouillou.net>
-
-[Retrieved from:
-https://github.com/analogdevicesinc/libiio/commit/85bf9cd32138539252ed01c355cf766612cf47c9]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- bindings/csharp/Device.cs | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/bindings/csharp/Device.cs b/bindings/csharp/Device.cs
-index 96214243f..6c8c8f4f3 100644
---- a/bindings/csharp/Device.cs
-+++ b/bindings/csharp/Device.cs
-@@ -208,7 +208,7 @@ public override void write(string str)
-         public readonly string name;
- 
-         /// <summary>The label of this device.</summary>
--        public readonly string label { get; private set; }
-+        public string label { get; private set; }
- 
-         /// <summary>A <c>list</c> of all the attributes that this device has.</summary>
-         public readonly List<Attr> attrs;
diff --git a/package/libiio/libiio.hash b/package/libiio/libiio.hash
index c523b5d685..f497756eac 100644
--- a/package/libiio/libiio.hash
+++ b/package/libiio/libiio.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  df1577740ea93dca732e7d7c04786600cb083117901dee793f3d38980754af00  libiio-0.23.tar.gz
+sha256  a2b5d848531ea64fd9f95327dfd5a588bd227d9577281ec375e822702c6a52d5  libiio-0.24.tar.gz
 sha256  102900208eef27b766380135906d431dba87edaa7ec6aa72e6ebd3dd67f3a97b  COPYING.txt
diff --git a/package/libiio/libiio.mk b/package/libiio/libiio.mk
index cfae34b2b7..9e2cf454b5 100644
--- a/package/libiio/libiio.mk
+++ b/package/libiio/libiio.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-LIBIIO_VERSION = 0.23
+LIBIIO_VERSION = 0.24
 LIBIIO_SITE = $(call github,analogdevicesinc,libiio,v$(LIBIIO_VERSION))
 LIBIIO_INSTALL_STAGING = YES
 LIBIIO_LICENSE = LGPL-2.1+