diff mbox series

[v1,5/7] package/python-scipy: add host-package

Message ID 20220816143943.16142-5-guillaume.bressaix@gmail.com
State Changes Requested
Headers show
Series [v1,1/7] package/python-joblib: new package | expand

Commit Message

Guillaume Bres Aug. 16, 2022, 2:39 p.m. UTC
host-python-scipy is a build time dependency of python-scikitlearn

Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>
---
 package/python-scipy/python-scipy.mk | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
diff mbox series

Patch

diff --git a/package/python-scipy/python-scipy.mk b/package/python-scipy/python-scipy.mk
index a8c23c6c88..d41cf2fd70 100644
--- a/package/python-scipy/python-scipy.mk
+++ b/package/python-scipy/python-scipy.mk
@@ -31,6 +31,12 @@  PYTHON_SCIPY_DEPENDENCIES += \
 	lapack \
 	python-numpy \
 	python-pybind
+HOST_PYTHON_SCIPY_DEPENDENCIES += \
+	host-python-numpy \
+	host-python-pybind \
+	host-python-pythran \
+	host-lapack \
+	zlib
 PYTHON_SCIPY_INSTALL_STAGING = YES
 
 PYTHON_SCIPY_SETUP_TYPE = setuptools
@@ -55,4 +61,12 @@  define PYTHON_SCIPY_CONFIGURE_CMDS
 	echo "include_dirs = $(STAGING_DIR)/usr/include" >> $(@D)/site.cfg
 endef
 
+define HOST_PYTHON_SCIPY_CONFIGURE_CMDS
+	-rm -f $(@D)/site.cfg
+	echo "[DEFAULT]" >> $(@D)/site.cfg
+	echo "library_dirs = $(HOST_DIR)/usr/lib" >> $(@D)/site.cfg
+	echo "include_dirs = $(HOST_DIR)/usr/include" >> $(@D)/site.cfg
+endef
+
 $(eval $(python-package))
+$(eval $(host-python-package))