diff mbox series

[v2,1/1] package/jack2: add host-pkgconf dependency

Message ID 20220813113114.986655-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v2,1/1] package/jack2: add host-pkgconf dependency | expand

Commit Message

Fabrice Fontaine Aug. 13, 2022, 11:31 a.m. UTC
Fix the following build failure raised since commit
69284b6700e5f45e25a583e87b86ed1eb95038fd:

Checking for program 'pkg-config'        : not found
The above check failed, but the checkee is required for --alsa.

Indeed, before this commit, host-pkgconf was pulled by libsndfile
dependency

Fixes:
 - http://autobuild.buildroot.org/results/cbdc251980f5571f75281202ebffc04ddecbf28d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2 (after review of Thomas Petazzoni):
 - Update commit log

 package/jack2/jack2.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Aug. 14, 2022, 10:10 a.m. UTC | #1
On Sat, 13 Aug 2022 13:31:14 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fix the following build failure raised since commit
> 69284b6700e5f45e25a583e87b86ed1eb95038fd:
> 
> Checking for program 'pkg-config'        : not found
> The above check failed, but the checkee is required for --alsa.
> 
> Indeed, before this commit, host-pkgconf was pulled by libsndfile
> dependency
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/cbdc251980f5571f75281202ebffc04ddecbf28d
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
> Changes v1 -> v2 (after review of Thomas Petazzoni):
>  - Update commit log

Applied to master, thanks for having researched the root cause!

Thomas
Peter Korsgaard Sept. 15, 2022, 8:33 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure raised since commit
 > 69284b6700e5f45e25a583e87b86ed1eb95038fd:

 > Checking for program 'pkg-config'        : not found
 > The above check failed, but the checkee is required for --alsa.

 > Indeed, before this commit, host-pkgconf was pulled by libsndfile
 > dependency

 > Fixes:
 >  - http://autobuild.buildroot.org/results/cbdc251980f5571f75281202ebffc04ddecbf28d

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 > ---
 > Changes v1 -> v2 (after review of Thomas Petazzoni):
 >  - Update commit log

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/jack2/jack2.mk b/package/jack2/jack2.mk
index 9e56dcdfd8..9d6a3b6479 100644
--- a/package/jack2/jack2.mk
+++ b/package/jack2/jack2.mk
@@ -9,7 +9,7 @@  JACK2_SITE = $(call github,jackaudio,jack2,v$(JACK2_VERSION))
 JACK2_LICENSE = GPL-2.0+ (jack server), LGPL-2.1+ (jack library)
 JACK2_LICENSE_FILES = COPYING
 JACK2_CPE_ID_VENDOR = jackaudio
-JACK2_DEPENDENCIES = alsa-lib
+JACK2_DEPENDENCIES = host-pkgconf alsa-lib
 JACK2_INSTALL_STAGING = YES
 
 JACK2_CONF_OPTS = --alsa --example-tools=no