diff mbox series

[v3,2/2] package/libgit2: bump to 1.5.0

Message ID 20220812145652.24342-2-nicolas.cavallari@green-communications.fr
State Accepted
Headers show
Series [v3,1/2] package/libgit2: link with -latomic if needed | expand

Commit Message

Nicolas Cavallari Aug. 12, 2022, 2:56 p.m. UTC
It includes an option to build a command line program that can be used
to replace git in simple cases.

The upcoming sha256 repository support made them steal the sha256 code
from RFC6234, hence the license change.

Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>

---
v2 -> v3: link executable with -latomic
Tested with test-pkg on top of af972178b

v1 -> v2: fix scissor lines

v1:
Tested with test-pkg with various options on top of 417eb476fd.

It works, except for bootlin-armv7m-uclibc which always fails with
"MMU support available in C library, please enable BR2_USE_MMU"
when configuring the toolchain.
---
 package/libgit2/Config.in    | 10 ++++++++++
 package/libgit2/libgit2.hash |  4 ++--
 package/libgit2/libgit2.mk   | 16 ++++++++++++++--
 3 files changed, 26 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni Aug. 14, 2022, 10:07 a.m. UTC | #1
On Fri, 12 Aug 2022 16:56:52 +0200
Nicolas Cavallari <nicolas.cavallari@green-communications.fr> wrote:

> It includes an option to build a command line program that can be used
> to replace git in simple cases.
> 
> The upcoming sha256 repository support made them steal the sha256 code
> from RFC6234, hence the license change.
> 
> Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
> 
> ---
> v2 -> v3: link executable with -latomic
> Tested with test-pkg on top of af972178b

Applied to next, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/libgit2/Config.in b/package/libgit2/Config.in
index a6a9728ff0..5d28f054f2 100644
--- a/package/libgit2/Config.in
+++ b/package/libgit2/Config.in
@@ -12,3 +12,13 @@  config BR2_PACKAGE_LIBGIT2
 
 comment "libgit2 needs a toolchain w/ dynamic library"
 	depends on BR2_STATIC_LIBS
+
+if BR2_PACKAGE_LIBGIT2
+
+config BR2_PACKAGE_LIBGIT2_CLI
+	bool "enable command line interface (git2_cli)"
+	help
+	  Enable a command-line interface for libgit2.
+	  It aims to be git-compatible.
+
+endif
diff --git a/package/libgit2/libgit2.hash b/package/libgit2/libgit2.hash
index 3b5837f789..fb760fd4cc 100644
--- a/package/libgit2/libgit2.hash
+++ b/package/libgit2/libgit2.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  f48b961e463a9e4e7e7e58b21a0fb5a9b2a1d24d9ba4d15870a0c9b8ad965163  libgit2-1.4.3.tar.gz
-sha256  0092f24acc306ee3287dc05b5e85cb9e0e48cd3f11c60c4625b1a673a5912616  COPYING
+sha256  8de872a0f201b33d9522b817c92e14edb4efad18dae95cf156cf240b2efff93e  libgit2-1.5.0.tar.gz
+sha256  0fc09da43d666b5b0cf5695defc3100d5cf387936b260ebab37e396d7e0dbc83  COPYING
diff --git a/package/libgit2/libgit2.mk b/package/libgit2/libgit2.mk
index 9b5e2b897d..9409011eb4 100644
--- a/package/libgit2/libgit2.mk
+++ b/package/libgit2/libgit2.mk
@@ -4,9 +4,14 @@ 
 #
 ################################################################################
 
-LIBGIT2_VERSION = 1.4.3
+LIBGIT2_VERSION = 1.5.0
 LIBGIT2_SITE = $(call github,libgit2,libgit2,v$(LIBGIT2_VERSION))
-LIBGIT2_LICENSE = GPL-2.0 with linking exception, MIT (sha1), wildmatch license (wildmatch), CC0-1.0 (xoroshiro256)
+LIBGIT2_LICENSE = \
+	GPL-2.0 with linking exception, \
+	MIT (sha1), \
+	BSD-3-Clause (sha256), \
+	wildmatch license (wildmatch), \
+	CC0-1.0 (xoroshiro256)
 LIBGIT2_LICENSE_FILES = COPYING
 LIBGIT2_CPE_ID_VENDOR = libgit2_project
 LIBGIT2_INSTALL_STAGING = YES
@@ -44,8 +49,15 @@  else
 LIBGIT2_CONF_OPTS += -DUSE_HTTPS=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_LIBGIT2_CLI),y)
+LIBGIT2_CONF_OPTS += -DBUILD_CLI=ON
+else
+LIBGIT2_CONF_OPTS += -DBUILD_CLI=OFF
+endif
+
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 LIBGIT2_CONF_OPTS += \
+	-DCMAKE_EXE_LINKER_FLAGS=-latomic \
 	-DCMAKE_SHARED_LINKER_FLAGS=-latomic
 endif