diff mbox series

package/linux-tools/linux-tool-perf.mk.in: Fix disabling of documentation

Message ID 20220809203505.3620840-1-mmayer@broadcom.com
State Accepted
Headers show
Series package/linux-tools/linux-tool-perf.mk.in: Fix disabling of documentation | expand

Commit Message

Markus Mayer Aug. 9, 2022, 8:35 p.m. UTC
We are trying to not build the perf documentation. However, the hook
being used to do so was named incorrectly. As a result, the build steps
to disable the documentation were never executed.

Rename the hook from
    LINUX_POST_PATCH_HOOKS
to
    LINUX_TOOLS_POST_PATCH_HOOKS
to fix the issue.

Fixes: 20b144666909 ("linux/tools: make it a real, separate package")
Signed-off-by: Markus Mayer <mmayer@broadcom.com>
---
 package/linux-tools/linux-tool-perf.mk.in | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Florian Fainelli Aug. 15, 2022, 4:29 p.m. UTC | #1
On 8/9/22 13:35, Markus Mayer via buildroot wrote:
> We are trying to not build the perf documentation. However, the hook
> being used to do so was named incorrectly. As a result, the build steps
> to disable the documentation were never executed.
> 
> Rename the hook from
>      LINUX_POST_PATCH_HOOKS
> to
>      LINUX_TOOLS_POST_PATCH_HOOKS
> to fix the issue.
> 
> Fixes: 20b144666909 ("linux/tools: make it a real, separate package")
> Signed-off-by: Markus Mayer <mmayer@broadcom.com>

Tested-by: Florian Fainelli <f.fainelli@gmail.com>
Reviewed-by: Florian Fainelli <f.fainelli@gmail.com>
Yann E. MORIN Aug. 15, 2022, 7:56 p.m. UTC | #2
Markus, All,

On 2022-08-09 13:35 -0700, Markus Mayer via buildroot spake thusly:
> We are trying to not build the perf documentation. However, the hook
> being used to do so was named incorrectly. As a result, the build steps
> to disable the documentation were never executed.
> 
> Rename the hook from
>     LINUX_POST_PATCH_HOOKS
> to
>     LINUX_TOOLS_POST_PATCH_HOOKS
> to fix the issue.
> 
> Fixes: 20b144666909 ("linux/tools: make it a real, separate package")

Woo.. almost six years before my crap gets noticed! ;-)

> Signed-off-by: Markus Mayer <mmayer@broadcom.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/linux-tools/linux-tool-perf.mk.in | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/linux-tools/linux-tool-perf.mk.in b/package/linux-tools/linux-tool-perf.mk.in
> index d82d45973cd7..3ec4dc6fee38 100644
> --- a/package/linux-tools/linux-tool-perf.mk.in
> +++ b/package/linux-tools/linux-tool-perf.mk.in
> @@ -126,7 +126,7 @@ define PERF_DISABLE_DOCUMENTATION
>  		printf "%%:\n\t@:\n" >$(LINUX_DIR)/tools/perf/Documentation/GNUmakefile; \
>  	fi
>  endef
> -LINUX_POST_PATCH_HOOKS += PERF_DISABLE_DOCUMENTATION
> +LINUX_TOOLS_POST_PATCH_HOOKS += PERF_DISABLE_DOCUMENTATION
>  
>  # O must be redefined here to overwrite the one used by Buildroot for
>  # out of tree build. We build perf in $(LINUX_DIR)/tools/perf/ and not just
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Markus Mayer Aug. 16, 2022, 5:40 p.m. UTC | #3
Hi Yann,

> Woo.. almost six years before my crap gets noticed! ;-)
>
> > Signed-off-by: Markus Mayer <mmayer@broadcom.com>
>
> Applied to master, thanks.

Thanks for applying this. We have to thank Ubuntu 22.04 for flushing
out this error.

In the past, /usr/bin/asciidoc used to be a regular Python script that
would import "regular" Python packages (i.e. nothing special). The
actual parser was contained in the script. With Ubuntu 22.04,
/usr/bin/asciidoc became a shell script like so:

$ cat /usr/bin/asciidoc
#!/bin/sh
python3 -m asciidoc "$@"

This means that the actual parser now lives as a Python module in
/usr/lib/python3/dist-packages/asciidoc. And therein lies the issue.
We are using BR2_FORCE_HOST_BUILD=y, so it builds its own Python
interpreter. And while .../output/arm64/host/bin/python3 is perfectly
capable of running /usr/bin/asciidoc when it is a standalone script,
it can't run asciidoc as a module, because
/usr/lib/python3/dist-packages is not in the custom Python
interpreter's search path.

And, thus, our build started failing when conducted on Ubuntu 22.04
(while being perfectly fine on Ubuntu 20.04 and older). Subsequently,
a slightly confusing search for the root cause commenced, since none
of these findings were expected.

I am mentioning here what happened, in case somebody else comes across
a similar issue.

Regards,
-Markus
Peter Korsgaard Sept. 16, 2022, 9:55 p.m. UTC | #4
>>>>> "Markus" == Markus Mayer via buildroot <buildroot@buildroot.org> writes:

 > We are trying to not build the perf documentation. However, the hook
 > being used to do so was named incorrectly. As a result, the build steps
 > to disable the documentation were never executed.

 > Rename the hook from
 >     LINUX_POST_PATCH_HOOKS
 > to
 >     LINUX_TOOLS_POST_PATCH_HOOKS
 > to fix the issue.

 > Fixes: 20b144666909 ("linux/tools: make it a real, separate package")
 > Signed-off-by: Markus Mayer <mmayer@broadcom.com>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/linux-tools/linux-tool-perf.mk.in b/package/linux-tools/linux-tool-perf.mk.in
index d82d45973cd7..3ec4dc6fee38 100644
--- a/package/linux-tools/linux-tool-perf.mk.in
+++ b/package/linux-tools/linux-tool-perf.mk.in
@@ -126,7 +126,7 @@  define PERF_DISABLE_DOCUMENTATION
 		printf "%%:\n\t@:\n" >$(LINUX_DIR)/tools/perf/Documentation/GNUmakefile; \
 	fi
 endef
-LINUX_POST_PATCH_HOOKS += PERF_DISABLE_DOCUMENTATION
+LINUX_TOOLS_POST_PATCH_HOOKS += PERF_DISABLE_DOCUMENTATION
 
 # O must be redefined here to overwrite the one used by Buildroot for
 # out of tree build. We build perf in $(LINUX_DIR)/tools/perf/ and not just