diff mbox series

[1/1] package/gauche: fix build

Message ID 20220809190926.2535336-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/gauche: fix build | expand

Commit Message

Fabrice Fontaine Aug. 9, 2022, 7:09 p.m. UTC
Fix the following build failure raised since bump to version 9.12.0 in
commit f2eb56459ed3d8f5fdb026a31fe85e8df7d3b42d and
https://github.com/shirok/Gauche/commit/9601603db7aea7bb6e075b4f7f09210a919a35b5
which deleted the internal libatomic_ops:

configure: error: libatomic_ops is required.  You can either install it on
                  your system, or fetch and unpack a recent version into the
                  source directory and link or rename it to libatomic_ops.

Fixes:
 - http://autobuild.buildroot.org/results/4c7a1b690d1b12e39b6b24f8cc8a144f79c73711

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gauche/gauche.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Aug. 15, 2022, 8:21 p.m. UTC | #1
On Tue,  9 Aug 2022 21:09:26 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fix the following build failure raised since bump to version 9.12.0 in
> commit f2eb56459ed3d8f5fdb026a31fe85e8df7d3b42d and
> https://github.com/shirok/Gauche/commit/9601603db7aea7bb6e075b4f7f09210a919a35b5
> which deleted the internal libatomic_ops:
> 
> configure: error: libatomic_ops is required.  You can either install it on
>                   your system, or fetch and unpack a recent version into the
>                   source directory and link or rename it to libatomic_ops.
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/4c7a1b690d1b12e39b6b24f8cc8a144f79c73711
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/gauche/gauche.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks. When --with-libatomic-ops=none, gauche will
use the atomic builtins of the compiler, which on some architectures
requires linking with libatomic. But it seems like the intersection of
architectures supported by gauche and the architectures that neeed
libatomic is empty, so it seems to be OK as-is. The autobuilders will
tell us :-)

Thomas
diff mbox series

Patch

diff --git a/package/gauche/gauche.mk b/package/gauche/gauche.mk
index 7c43bd4573..b635c488fe 100644
--- a/package/gauche/gauche.mk
+++ b/package/gauche/gauche.mk
@@ -12,7 +12,7 @@  GAUCHE_LICENSE_FILES = COPYING
 GAUCHE_DEPENDENCIES = host-gauche
 
 HOST_GAUCHE_CONF_OPTS = --without-zlib
-GAUCHE_CONF_OPTS = --without-libatomic-ops
+GAUCHE_CONF_OPTS = --with-libatomic-ops=none
 
 # Enable embedded axTLS
 GAUCHE_TLS_LIBS = axtls