diff mbox series

[01/13] package/libuv: add host-build

Message ID 20220809075704.86472-2-ardeleanalex@gmail.com
State Changes Requested
Headers show
Series package/nodejs: rework cross-building | expand

Commit Message

Alexandru Ardelean Aug. 9, 2022, 7:56 a.m. UTC
Useful for nodejs cross-building to build some of the host-tools of nodejs.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
---
 package/libuv/libuv.mk | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/package/libuv/libuv.mk b/package/libuv/libuv.mk
index ed51fc92f9..033390e318 100644
--- a/package/libuv/libuv.mk
+++ b/package/libuv/libuv.mk
@@ -27,4 +27,7 @@  define LIBUV_FIXUP_AUTOGEN
 endef
 LIBUV_POST_PATCH_HOOKS += LIBUV_FIXUP_AUTOGEN
 
+HOST_LIBUV_POST_PATCH_HOOKS += LIBUV_FIXUP_AUTOGEN
+
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))