diff mbox series

[2/3] support/scripts/pkg-stats: adjust column widths

Message ID 20220728232357.270130-2-sen@phobosdpl.com
State Changes Requested
Headers show
Series [1/3] support/scripts/pkg-stats: make cells with many CVEs collapsible | expand

Commit Message

Sen Hastings July 28, 2022, 11:23 p.m. UTC
This adjusts the column widths, mostly for asthetics/legibility.

It is primarily for chrome based browsers, which like to
linebreak on explicit hyphens, meaning every CVE takes multiple lines.

see: https://github.com/w3c/csswg-drafts/issues/3434

Signed-off-by: Sen Hastings <sen@phobosdpl.com>
---
 support/scripts/pkg-stats | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Aug. 1, 2022, 5:04 p.m. UTC | #1
On Thu, 28 Jul 2022 18:23:56 -0500
Sen Hastings <sen@phobosdpl.com> wrote:

> This adjusts the column widths, mostly for asthetics/legibility.
> 
> It is primarily for chrome based browsers, which like to
> linebreak on explicit hyphens, meaning every CVE takes multiple lines.
> 
> see: https://github.com/w3c/csswg-drafts/issues/3434
> 
> Signed-off-by: Sen Hastings <sen@phobosdpl.com>

This doesn't behave extremely well here as it prevents wrapping of the
package .mk file path in the first column, making this first column
larger than it was. I guess wrapping on "/" would be ideally for this
first column.

Here the table continues to exceed the width of my large browser window
(with or without this patch), which is not very nice :-/

Thomas
Arnout Vandecappelle Aug. 1, 2022, 6:11 p.m. UTC | #2
Hi Sen,

On 01/08/2022 19:04, Thomas Petazzoni via buildroot wrote:
> On Thu, 28 Jul 2022 18:23:56 -0500
> Sen Hastings <sen@phobosdpl.com> wrote:
> 
>> This adjusts the column widths, mostly for asthetics/legibility.
>>
>> It is primarily for chrome based browsers, which like to
>> linebreak on explicit hyphens, meaning every CVE takes multiple lines.
>>
>> see: https://github.com/w3c/csswg-drafts/issues/3434
>>
>> Signed-off-by: Sen Hastings <sen@phobosdpl.com>
> 
> This doesn't behave extremely well here as it prevents wrapping of the
> package .mk file path in the first column, making this first column
> larger than it was. I guess wrapping on "/" would be ideally for this
> first column.
> 
> Here the table continues to exceed the width of my large browser window
> (with or without this patch), which is not very nice :-/

  Since pkg-stats takes a pretty long time to run, it would be nice if you could 
publish the output of pkg-stats (with no .config) somewhere so we can look at it 
directly and notice these things easier.

  Regards,
  Arnout
Sen Hastings Aug. 2, 2022, 8:30 p.m. UTC | #3
On 8/1/22 13:11, Arnout Vandecappelle wrote:
>  Hi Sen,
> 
> On 01/08/2022 19:04, Thomas Petazzoni via buildroot wrote:
>> On Thu, 28 Jul 2022 18:23:56 -0500
>> Sen Hastings <sen@phobosdpl.com> wrote:
>>
>>> This adjusts the column widths, mostly for asthetics/legibility.
>>>
>>> It is primarily for chrome based browsers, which like to
>>> linebreak on explicit hyphens, meaning every CVE takes multiple lines.
>>>
>>> see: https://github.com/w3c/csswg-drafts/issues/3434
>>>
>>> Signed-off-by: Sen Hastings <sen@phobosdpl.com>
>>
>> This doesn't behave extremely well here as it prevents wrapping of the
>> package .mk file path in the first column, making this first column
>> larger than it was. I guess wrapping on "/" would be ideally for this
>> first column.
>>
>> Here the table continues to exceed the width of my large browser window
>> (with or without this patch), which is not very nice :-/
> 
>  Since pkg-stats takes a pretty long time to run, it would be nice if
> you could publish the output of pkg-stats (with no .config) somewhere so
> we can look at it directly and notice these things easier.>
Yeah, these weird edge cases only crop up when you build all the
packages... which requires building all the packages.
My usual dev cycle is to pull master.html, edit the js in situ and then
move it back into the pkg-stats script. I usually only run pkg-stats
against a fairly simple defconfig like pc_x86_64_efi or my own personal
project. I guess I should do a full build of master weekly, and perhaps
a nightly run of pkg-stats, then host the html somewhere. And perhaps I
should look into parsing the json output into html...

Sincerely,
Sen H.

>  Regards,
>  Arnout
>
Thomas Petazzoni Aug. 2, 2022, 10:04 p.m. UTC | #4
On Tue, 2 Aug 2022 15:30:06 -0500
Sen Hastings <sen@phobosdpl.com> wrote:

> >  Since pkg-stats takes a pretty long time to run, it would be nice if
> > you could publish the output of pkg-stats (with no .config) somewhere so
> > we can look at it directly and notice these things easier.>  
> Yeah, these weird edge cases only crop up when you build all the
> packages... which requires building all the packages.

No, you don't. Just run it manually:

./support/scripts/pkg-stats --html foo.html --nvd-path ~/path/to/somewhere/

This will use pkg-stats without the -c option, and therefore pkg-stats
will handle all packages rather than just the ones selected in your
configuration.

Thomas
diff mbox series

Patch

diff --git a/support/scripts/pkg-stats b/support/scripts/pkg-stats
index 8ce4e3f260..4b396d3217 100755
--- a/support/scripts/pkg-stats
+++ b/support/scripts/pkg-stats
@@ -853,7 +853,7 @@  function expandField(fieldId){
 #package-grid, #results-grid {
   display: grid;
   grid-gap: 2px;
-  grid-template-columns: 1fr repeat(12, min-content);
+  grid-template-columns: max-content repeat(5, min-content) 20ch repeat(3, max-content) repeat(2, 20ch) auto;
 }
 #results-grid {
   grid-template-columns: 3fr 1fr;