diff mbox series

[1/2] package/eudev: remove HOST_EUDEV_SYSCONFDIR

Message ID 20220728193726.1465662-1-arnout@mind.be
State Accepted
Headers show
Series [1/2] package/eudev: remove HOST_EUDEV_SYSCONFDIR | expand

Commit Message

Arnout Vandecappelle July 28, 2022, 7:37 p.m. UTC
The HOST_EUDEV_SYSCONFDIR is a leftover from before eudev, when udev was
still built from systemd sources. Now that we have a separate file for
eudev and systemd, there's no need any more to have a condition there.
In addition, its usage in systemd.mk has been removed.

Remove the HOST_EUDEV_SYSCONFDIR variable and instead use /etc directly
in eudev.mk.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/eudev/eudev.mk | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni July 28, 2022, 9:05 p.m. UTC | #1
On Thu, 28 Jul 2022 21:37:25 +0200
"Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be> wrote:

> The HOST_EUDEV_SYSCONFDIR is a leftover from before eudev, when udev was
> still built from systemd sources. Now that we have a separate file for
> eudev and systemd, there's no need any more to have a condition there.
> In addition, its usage in systemd.mk has been removed.
> 
> Remove the HOST_EUDEV_SYSCONFDIR variable and instead use /etc directly
> in eudev.mk.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> ---
>  package/eudev/eudev.mk | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)

Both applied, thanks!

Thomas
diff mbox series

Patch

diff --git a/package/eudev/eudev.mk b/package/eudev/eudev.mk
index 705370689d..f050563feb 100644
--- a/package/eudev/eudev.mk
+++ b/package/eudev/eudev.mk
@@ -57,13 +57,12 @@  endef
 
 HOST_EUDEV_DEPENDENCIES = host-gperf host-pkgconf
 
-HOST_EUDEV_SYSCONFDIR = $(if $(BR2_PACKAGE_SYSTEMD),/usr/lib,/etc)
 HOST_EUDEV_CONF_OPTS = \
 	--prefix=/usr \
 	--sbindir=/sbin \
 	--libexecdir=/lib \
 	--with-rootlibdir=/lib \
-	--sysconfdir=$(HOST_EUDEV_SYSCONFDIR) \
+	--sysconfdir=/etc \
 	--disable-blkid \
 	--disable-introspection \
 	--disable-kmod \
@@ -86,7 +85,7 @@  HOST_EUDEV_TARGET_FINALIZE_HOOKS += HOST_EUDEV_BUILD_HWDB
 # of tharget/, not the real one, so the files are still available on
 # re-builds (foo-rebuild, etc...)
 define HOST_EUDEV_RM_HWDB_SRC
-	rm -rf $(TARGET_DIR)/$(HOST_EUDEV_SYSCONFDIR)/udev/hwdb.d/
+	rm -rf $(TARGET_DIR)/etc/udev/hwdb.d/
 endef
 HOST_EUDEV_ROOTFS_PRE_CMD_HOOKS += HOST_EUDEV_RM_HWDB_SRC