diff mbox series

[1/1] package/opensc: disable cmocka

Message ID 20220726202645.347259-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/opensc: disable cmocka | expand

Commit Message

Fabrice Fontaine July 26, 2022, 8:26 p.m. UTC
Disable cmocka (enabled by default) to avoid the following uclibc build
failure raised since the addition of the package in commit
8aaa7ecbce1d10cbcd880c3da5e429988f96176a:

In file included from p11test_common.h:30,
                 from p11test_helpers.h:25,
                 from p11test.c:24:
/home/giuliobenetti/autobuild/run/instance-0/output-1/host/powerpc-buildroot-linux-uclibc/sysroot/usr/include/cmocka.h:2334:47: error: unknown type name 'va_list'
 2334 | void vprint_message(const char* const format, va_list args) CMOCKA_PRINTF_ATTRIBUTE(1, 0);
      |                                               ^~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/19d1171a76cd4789472b16aa24b44f58cd7e0a1e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/opensc/opensc.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni July 26, 2022, 9:47 p.m. UTC | #1
On Tue, 26 Jul 2022 22:26:45 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Disable cmocka (enabled by default) to avoid the following uclibc build
> failure raised since the addition of the package in commit
> 8aaa7ecbce1d10cbcd880c3da5e429988f96176a:
> 
> In file included from p11test_common.h:30,
>                  from p11test_helpers.h:25,
>                  from p11test.c:24:
> /home/giuliobenetti/autobuild/run/instance-0/output-1/host/powerpc-buildroot-linux-uclibc/sysroot/usr/include/cmocka.h:2334:47: error: unknown type name 'va_list'
>  2334 | void vprint_message(const char* const format, va_list args) CMOCKA_PRINTF_ATTRIBUTE(1, 0);
>       |                                               ^~~~~~~
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/19d1171a76cd4789472b16aa24b44f58cd7e0a1e
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/opensc/opensc.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/opensc/opensc.mk b/package/opensc/opensc.mk
index e1ad5d61b0..f9e2f5083e 100644
--- a/package/opensc/opensc.mk
+++ b/package/opensc/opensc.mk
@@ -11,6 +11,6 @@  OPENSC_LICENSE_FILES = COPYING
 OPENSC_CPE_ID_VENDOR = opensc_project
 OPENSC_DEPENDENCIES = openssl pcsc-lite
 OPENSC_INSTALL_STAGING = YES
-OPENSC_CONF_OPTS = --disable-strict
+OPENSC_CONF_OPTS = --disable-cmocka --disable-strict
 
 $(eval $(autotools-package))