diff mbox series

[v2,1/1] package/libopenssl: fix BR2_OPTIMIZE_FAST build

Message ID 20220707054948.479212-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v2,1/1] package/libopenssl: fix BR2_OPTIMIZE_FAST build | expand

Commit Message

Fabrice Fontaine July 7, 2022, 5:49 a.m. UTC
Drop unneeded SED hacks (including build_tests) to fix the following
build failure with BR2_OPTIMIZE_FAST:

In file included from crypto/async/arch/../async_local.h:30,
                 from crypto/async/arch/async_null.c:11:
crypto/async/arch/../arch/async_posix.h:32:5: error: unknown type name 'ucontext_t'
   32 |     ucontext_t fibre;
      |     ^~~~~~~~~~

While at it, also "drop parentheses as all it does is spawn a useless
sub-shell" as noticed by Yann E. Morin

Fixes:
 - http://autobuild.buildroot.org/results/3ce202f11a821940ff55eafa1dc7cea54b8c0da2

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2 (after review of Yann E. Morin):
 - Drop SED hacks and useless parentheses

 package/libopenssl/libopenssl.mk | 15 +++++----------
 1 file changed, 5 insertions(+), 10 deletions(-)

Comments

Thomas Petazzoni July 20, 2022, 11:51 a.m. UTC | #1
On Thu,  7 Jul 2022 07:49:48 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Drop unneeded SED hacks (including build_tests) to fix the following
> build failure with BR2_OPTIMIZE_FAST:
> 
> In file included from crypto/async/arch/../async_local.h:30,
>                  from crypto/async/arch/async_null.c:11:
> crypto/async/arch/../arch/async_posix.h:32:5: error: unknown type name 'ucontext_t'
>    32 |     ucontext_t fibre;
>       |     ^~~~~~~~~~
> 
> While at it, also "drop parentheses as all it does is spawn a useless
> sub-shell" as noticed by Yann E. Morin
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/3ce202f11a821940ff55eafa1dc7cea54b8c0da2
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
> Changes v1 -> v2 (after review of Yann E. Morin):
>  - Drop SED hacks and useless parentheses

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 11, 2022, 11:42 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Drop unneeded SED hacks (including build_tests) to fix the following
 > build failure with BR2_OPTIMIZE_FAST:

 > In file included from crypto/async/arch/../async_local.h:30,
 >                  from crypto/async/arch/async_null.c:11:
 > crypto/async/arch/../arch/async_posix.h:32:5: error: unknown type name 'ucontext_t'
 >    32 |     ucontext_t fibre;
 >       |     ^~~~~~~~~~

 > While at it, also "drop parentheses as all it does is spawn a useless
 > sub-shell" as noticed by Yann E. Morin

 > Fixes:
 >  - http://autobuild.buildroot.org/results/3ce202f11a821940ff55eafa1dc7cea54b8c0da2

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 > ---
 > Changes v1 -> v2 (after review of Yann E. Morin):
 >  - Drop SED hacks and useless parentheses

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libopenssl/libopenssl.mk b/package/libopenssl/libopenssl.mk
index 601da3f8f1..f19a63da41 100644
--- a/package/libopenssl/libopenssl.mk
+++ b/package/libopenssl/libopenssl.mk
@@ -52,7 +52,7 @@  LIBOPENSSL_CFLAGS += -DOPENSSL_NO_ASYNC
 endif
 
 define HOST_LIBOPENSSL_CONFIGURE_CMDS
-	(cd $(@D); \
+	cd $(@D); \
 		$(HOST_CONFIGURE_OPTS) \
 		./config \
 		--prefix=$(HOST_DIR) \
@@ -61,15 +61,14 @@  define HOST_LIBOPENSSL_CONFIGURE_CMDS
 		no-fuzz-libfuzzer \
 		no-fuzz-afl \
 		shared \
-		zlib-dynamic \
-	)
-	$(SED) "s#-O[0-9sg]#$(HOST_CFLAGS)#" $(@D)/Makefile
+		zlib-dynamic
 endef
 
 define LIBOPENSSL_CONFIGURE_CMDS
-	(cd $(@D); \
+	cd $(@D); \
 		$(TARGET_CONFIGURE_ARGS) \
 		$(TARGET_CONFIGURE_OPTS) \
+		 CFLAGS="$(LIBOPENSSL_CFLAGS)" \
 		./Configure \
 			$(LIBOPENSSL_TARGET_ARCH) \
 			--prefix=/usr \
@@ -108,11 +107,7 @@  define LIBOPENSSL_CONFIGURE_CMDS
 			$(if $(BR2_PACKAGE_LIBOPENSSL_DYNAMIC_ENGINE),,no-dynamic-engine ) \
 			$(if $(BR2_PACKAGE_LIBOPENSSL_ENABLE_COMP),,no-comp) \
 			$(if $(BR2_STATIC_LIBS),zlib,zlib-dynamic) \
-			$(if $(BR2_STATIC_LIBS),no-dso) \
-	)
-	$(SED) "s#-march=[-a-z0-9] ##" -e "s#-mcpu=[-a-z0-9] ##g" $(@D)/Makefile
-	$(SED) "s#-O[0-9sg]#$(LIBOPENSSL_CFLAGS)#" $(@D)/Makefile
-	$(SED) "s# build_tests##" $(@D)/Makefile
+			$(if $(BR2_STATIC_LIBS),no-dso)
 endef
 
 # libdl is not available in a static build, and this is not implied by no-dso