diff mbox series

[2/3] package/bind: disable cmocka

Message ID 20220619210102.1021263-2-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/3] package/bind: drop unrecognized options | expand

Commit Message

Fabrice Fontaine June 19, 2022, 9:01 p.m. UTC
Disable cmocka (wich is enabled by default)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/bind/bind.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Raphael Pavlidis June 28, 2022, 6:10 p.m. UTC | #1
Maybe we could make this dependency dynamically, if the 
BR2_PACKAGE_CMOCKA is enabled.

For Example:

ifeq ($(BR2_PACKAGE_CMOCKA),y)
BIND_CONF_OPTS += --with-cmocka
BIND_DEPENDENCIES += cmocka
else
BIND_CONF_OPTS += --without-cmocka
endif
Thomas Petazzoni July 20, 2022, 9:37 p.m. UTC | #2
Hello Raphael,

On Tue, 28 Jun 2022 20:10:07 +0200
Raphael Pavlidis via buildroot <buildroot@buildroot.org> wrote:

> Maybe we could make this dependency dynamically, if the 
> BR2_PACKAGE_CMOCKA is enabled.
> 
> For Example:
> 
> ifeq ($(BR2_PACKAGE_CMOCKA),y)
> BIND_CONF_OPTS += --with-cmocka
> BIND_DEPENDENCIES += cmocka
> else
> BIND_CONF_OPTS += --without-cmocka
> endif

Correct, but we don't "require" this. Indeed, if nobody has ever had
the need for cmocka support in bind, it's fine for the moment to have
an unconditional --without-cmocka. This can be improved later by
someone needing this cmocka support.

Essentially all what I'm saying is that we don't require supporting all
possible optional dependencies/features: it's fine to have some of them
not supported in Buildroot, until someone really needs them.

Best regards,

Thomas
Peter Korsgaard Aug. 11, 2022, 5:33 p.m. UTC | #3
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Disable cmocka (wich is enabled by default)
 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/bind/bind.mk b/package/bind/bind.mk
index 0ce78d08cb..c84abe91a0 100644
--- a/package/bind/bind.mk
+++ b/package/bind/bind.mk
@@ -31,6 +31,7 @@  BIND_CONF_ENV = \
 	BUILD_CFLAGS="$(TARGET_CFLAGS)" \
 	LIBS=`$(PKG_CONFIG_HOST_BINARY) --libs openssl`
 BIND_CONF_OPTS = \
+	--without-cmocka \
 	--without-lmdb \
 	--with-json-c=no \
 	--enable-epoll \