diff mbox series

[v4,1/1] package/wolftpm: Add config options for TPM 2.0 extra capabilities

Message ID 20220615075028.41612-1-dimi@tpm.dev
State Superseded
Headers show
Series [v4,1/1] package/wolftpm: Add config options for TPM 2.0 extra capabilities | expand

Commit Message

Dimi Tomov June 15, 2022, 7:50 a.m. UTC
From: Dimitar Tomov <dimi@tpm.dev>

Some TPM 2.0 chips offer extra capabilities. This patch adds additional
configuration options to the wolftpm package, so such capabilities can
be available to the user. For example, the STMicroelectronics ST33 and
Nuvoton NPCT750 both offer secure GPIO. Due to chip differences, wolfTPM
requires explicit configuration options to enable the extra capabilities.

Signed-off-by: Dimitar Tomov <dimi@tpm.dev>
---
Changes v3 -> v4:
- Fix commit message. For some reason the update was not included in patch v3.
Changes v2 -> v3:
- Better commit message
Changes v1 -> v2:
- Remove a not needed package description change
---
 package/wolftpm/Config.in  | 12 ++++++++++++
 package/wolftpm/wolftpm.mk | 12 ++++++++++++
 2 files changed, 24 insertions(+)

Comments

Dimi Tomov June 15, 2022, 7:52 a.m. UTC | #1
Hi Thomas,

This patch adds new package options that enable extra TPM 2.0 
capabilities.

ps: Please excuse the extra versions, it seems I am still sleepy this 
morning.

Thanks,
Dimi
--
Founder of TPM.dev

On 2022-06-15 10:50 AM, Dimi Tomov wrote:
> From: Dimitar Tomov <dimi@tpm.dev>
> 
> Some TPM 2.0 chips offer extra capabilities. This patch adds additional
> configuration options to the wolftpm package, so such capabilities can
> be available to the user. For example, the STMicroelectronics ST33 and
> Nuvoton NPCT750 both offer secure GPIO. Due to chip differences, 
> wolfTPM
> requires explicit configuration options to enable the extra 
> capabilities.
> 
> Signed-off-by: Dimitar Tomov <dimi@tpm.dev>
> ---
> Changes v3 -> v4:
> - Fix commit message. For some reason the update was not included in 
> patch v3.
> Changes v2 -> v3:
> - Better commit message
> Changes v1 -> v2:
> - Remove a not needed package description change
> ---
>  package/wolftpm/Config.in  | 12 ++++++++++++
>  package/wolftpm/wolftpm.mk | 12 ++++++++++++
>  2 files changed, 24 insertions(+)
> 
> diff --git a/package/wolftpm/Config.in b/package/wolftpm/Config.in
> index 0b964c3d7e..3027b7e33d 100644
> --- a/package/wolftpm/Config.in
> +++ b/package/wolftpm/Config.in
> @@ -23,6 +23,18 @@ config BR2_PACKAGE_WOLFTPM_WOLFCRYPT
>  	  encryption. Disabling this option is not recommended as it
>  	  could create a security breach in most environments.
> 
> +config BR2_PACKAGE_WOLFTPM_ST33
> +	bool "st33"
> +	default n
> +	help
> +	  Enable support of TPM 2.0 extra functionality offered by the
> STMicroelectronics ST33 chip.
> +
> +config BR2_PACKAGE_WOLFTPM_NUVOTON
> +	bool "npct750"
> +	default n
> +	help
> +	  Enable support of TPM 2.0 extra functionality offered by the
> Nuvoton NPCT750 chip.
> +
>  comment "wolfCrypt hooks need a toolchain w/ threads, dynamic library"
>  	depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
> 
> diff --git a/package/wolftpm/wolftpm.mk b/package/wolftpm/wolftpm.mk
> index a4a9edce85..d0423cd06b 100644
> --- a/package/wolftpm/wolftpm.mk
> +++ b/package/wolftpm/wolftpm.mk
> @@ -35,4 +35,16 @@ else
>  WOLFTPM_CONF_OPTS += --disable-wolfcrypt
>  endif
> 
> +ifeq ($(BR2_PACKAGE_WOLFTPM_ST33),y)
> +WOLFTPM_CONF_OPTS += --enable-st33
> +else
> +WOLFTPM_CONF_OPTS += --disable-st33
> +endif
> +
> +ifeq ($(BR2_PACKAGE_WOLFTPM_NPCT750),y)
> +WOLFTPM_CONF_OPTS += --enable-nuvoton
> +else
> +WOLFTPM_CONF_OPTS += --disable-nuvoton
> +endif
> +
>  $(eval $(autotools-package))
Fabrice Fontaine June 15, 2022, 8:34 a.m. UTC | #2
Hi Dimi,

Le mer. 15 juin 2022 à 09:53, Dimi Tomov <dimi@tpm.dev> a écrit :
>
> Hi Thomas,
>
> This patch adds new package options that enable extra TPM 2.0
> capabilities.
>
> ps: Please excuse the extra versions, it seems I am still sleepy this
> morning.
>
> Thanks,
> Dimi
> --
> Founder of TPM.dev
>
> On 2022-06-15 10:50 AM, Dimi Tomov wrote:
> > From: Dimitar Tomov <dimi@tpm.dev>
> >
> > Some TPM 2.0 chips offer extra capabilities. This patch adds additional
> > configuration options to the wolftpm package, so such capabilities can
> > be available to the user. For example, the STMicroelectronics ST33 and
> > Nuvoton NPCT750 both offer secure GPIO. Due to chip differences,
> > wolfTPM
> > requires explicit configuration options to enable the extra
> > capabilities.
> >
> > Signed-off-by: Dimitar Tomov <dimi@tpm.dev>
> > ---
> > Changes v3 -> v4:
> > - Fix commit message. For some reason the update was not included in
> > patch v3.
> > Changes v2 -> v3:
> > - Better commit message
> > Changes v1 -> v2:
> > - Remove a not needed package description change

You should set previous iterations as superseded in patchwork:
https://patchwork.ozlabs.org/project/buildroot/list/

> > ---
> >  package/wolftpm/Config.in  | 12 ++++++++++++
> >  package/wolftpm/wolftpm.mk | 12 ++++++++++++
> >  2 files changed, 24 insertions(+)
> >
> > diff --git a/package/wolftpm/Config.in b/package/wolftpm/Config.in
> > index 0b964c3d7e..3027b7e33d 100644
> > --- a/package/wolftpm/Config.in
> > +++ b/package/wolftpm/Config.in
> > @@ -23,6 +23,18 @@ config BR2_PACKAGE_WOLFTPM_WOLFCRYPT
> >         encryption. Disabling this option is not recommended as it
> >         could create a security breach in most environments.
> >
> > +config BR2_PACKAGE_WOLFTPM_ST33
> > +     bool "st33"
> > +     default n
> > +     help
> > +       Enable support of TPM 2.0 extra functionality offered by the
> > STMicroelectronics ST33 chip.

This line is too long (it should be wrapped to 72 characters).
make check-package will warn you about it

> > +
> > +config BR2_PACKAGE_WOLFTPM_NUVOTON
> > +     bool "npct750"
> > +     default n
> > +     help
> > +       Enable support of TPM 2.0 extra functionality offered by the
> > Nuvoton NPCT750 chip.

This line is also too long.

> > +
> >  comment "wolfCrypt hooks need a toolchain w/ threads, dynamic library"
> >       depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
> >
> > diff --git a/package/wolftpm/wolftpm.mk b/package/wolftpm/wolftpm.mk
> > index a4a9edce85..d0423cd06b 100644
> > --- a/package/wolftpm/wolftpm.mk
> > +++ b/package/wolftpm/wolftpm.mk
> > @@ -35,4 +35,16 @@ else
> >  WOLFTPM_CONF_OPTS += --disable-wolfcrypt
> >  endif
> >
> > +ifeq ($(BR2_PACKAGE_WOLFTPM_ST33),y)
> > +WOLFTPM_CONF_OPTS += --enable-st33
> > +else
> > +WOLFTPM_CONF_OPTS += --disable-st33
> > +endif
> > +
> > +ifeq ($(BR2_PACKAGE_WOLFTPM_NPCT750),y)
> > +WOLFTPM_CONF_OPTS += --enable-nuvoton
> > +else
> > +WOLFTPM_CONF_OPTS += --disable-nuvoton
> > +endif
> > +
> >  $(eval $(autotools-package))

Best Regards,

Fabrice
Dimi Tomov June 15, 2022, 10:56 a.m. UTC | #3
Hi Fabrice,

Thank you for this input.

What do you mean by superseded? I am using --in-reply-to. How are you 
typically sending follow-up patch versions?

I thought we are using 80 chars per line limit, I will update the patch 
with 72 chars per line limit.

Regards,

Dimi

On 2022-06-15 11:34 AM, Fabrice Fontaine wrote:
> Hi Dimi,
> 
> Le mer. 15 juin 2022 à 09:53, Dimi Tomov <dimi@tpm.dev> a écrit :
>> 
>> Hi Thomas,
>> 
>> This patch adds new package options that enable extra TPM 2.0
>> capabilities.
>> 
>> ps: Please excuse the extra versions, it seems I am still sleepy this
>> morning.
>> 
>> Thanks,
>> Dimi
>> --
>> Founder of TPM.dev
>> 
>> On 2022-06-15 10:50 AM, Dimi Tomov wrote:
>> > From: Dimitar Tomov <dimi@tpm.dev>
>> >
>> > Some TPM 2.0 chips offer extra capabilities. This patch adds additional
>> > configuration options to the wolftpm package, so such capabilities can
>> > be available to the user. For example, the STMicroelectronics ST33 and
>> > Nuvoton NPCT750 both offer secure GPIO. Due to chip differences,
>> > wolfTPM
>> > requires explicit configuration options to enable the extra
>> > capabilities.
>> >
>> > Signed-off-by: Dimitar Tomov <dimi@tpm.dev>
>> > ---
>> > Changes v3 -> v4:
>> > - Fix commit message. For some reason the update was not included in
>> > patch v3.
>> > Changes v2 -> v3:
>> > - Better commit message
>> > Changes v1 -> v2:
>> > - Remove a not needed package description change
> 
> You should set previous iterations as superseded in patchwork:
> https://patchwork.ozlabs.org/project/buildroot/list/
> 
>> > ---
>> >  package/wolftpm/Config.in  | 12 ++++++++++++
>> >  package/wolftpm/wolftpm.mk | 12 ++++++++++++
>> >  2 files changed, 24 insertions(+)
>> >
>> > diff --git a/package/wolftpm/Config.in b/package/wolftpm/Config.in
>> > index 0b964c3d7e..3027b7e33d 100644
>> > --- a/package/wolftpm/Config.in
>> > +++ b/package/wolftpm/Config.in
>> > @@ -23,6 +23,18 @@ config BR2_PACKAGE_WOLFTPM_WOLFCRYPT
>> >         encryption. Disabling this option is not recommended as it
>> >         could create a security breach in most environments.
>> >
>> > +config BR2_PACKAGE_WOLFTPM_ST33
>> > +     bool "st33"
>> > +     default n
>> > +     help
>> > +       Enable support of TPM 2.0 extra functionality offered by the
>> > STMicroelectronics ST33 chip.
> 
> This line is too long (it should be wrapped to 72 characters).
> make check-package will warn you about it
> 
>> > +
>> > +config BR2_PACKAGE_WOLFTPM_NUVOTON
>> > +     bool "npct750"
>> > +     default n
>> > +     help
>> > +       Enable support of TPM 2.0 extra functionality offered by the
>> > Nuvoton NPCT750 chip.
> 
> This line is also too long.
> 
>> > +
>> >  comment "wolfCrypt hooks need a toolchain w/ threads, dynamic library"
>> >       depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
>> >
>> > diff --git a/package/wolftpm/wolftpm.mk b/package/wolftpm/wolftpm.mk
>> > index a4a9edce85..d0423cd06b 100644
>> > --- a/package/wolftpm/wolftpm.mk
>> > +++ b/package/wolftpm/wolftpm.mk
>> > @@ -35,4 +35,16 @@ else
>> >  WOLFTPM_CONF_OPTS += --disable-wolfcrypt
>> >  endif
>> >
>> > +ifeq ($(BR2_PACKAGE_WOLFTPM_ST33),y)
>> > +WOLFTPM_CONF_OPTS += --enable-st33
>> > +else
>> > +WOLFTPM_CONF_OPTS += --disable-st33
>> > +endif
>> > +
>> > +ifeq ($(BR2_PACKAGE_WOLFTPM_NPCT750),y)
>> > +WOLFTPM_CONF_OPTS += --enable-nuvoton
>> > +else
>> > +WOLFTPM_CONF_OPTS += --disable-nuvoton
>> > +endif
>> > +
>> >  $(eval $(autotools-package))
> 
> Best Regards,
> 
> Fabrice
Fabrice Fontaine June 15, 2022, 11:51 a.m. UTC | #4
Le mer. 15 juin 2022 à 12:57, Dimi Tomov <dimi@tpm.dev> a écrit :
>
> Hi Fabrice,
>
> Thank you for this input.
>
> What do you mean by superseded? I am using --in-reply-to. How are you
> typically sending follow-up patch versions?

I'm not using --in-reply-to.
I'm manually changing the status in
https://patchwork.ozlabs.org/project/buildroot.

I assume that there is an issue with the ID that you provide to
--in-reply-to as buildroot manual specifies that "You can also add the
--in-reply-to <message-id> option when submitting a patch to the
mailing list. The id of the mail to reply to can be found under the
"Message Id" tag on patchwork. The advantage of in-reply-to is that
patchwork will automatically mark the previous version of the patch as
superseded."
but previous iterations of your patch are still set as New in patchwork:
https://patchwork.ozlabs.org/project/buildroot/patch/20220615073053.40347-1-dimi@tpm.dev/

>
> I thought we are using 80 chars per line limit, I will update the patch
> with 72 chars per line limit.

help text must be lower than 72 chars in Config.in.


>
> Regards,
>
> Dimi
>
> On 2022-06-15 11:34 AM, Fabrice Fontaine wrote:
> > Hi Dimi,
> >
> > Le mer. 15 juin 2022 à 09:53, Dimi Tomov <dimi@tpm.dev> a écrit :
> >>
> >> Hi Thomas,
> >>
> >> This patch adds new package options that enable extra TPM 2.0
> >> capabilities.
> >>
> >> ps: Please excuse the extra versions, it seems I am still sleepy this
> >> morning.
> >>
> >> Thanks,
> >> Dimi
> >> --
> >> Founder of TPM.dev
> >>
> >> On 2022-06-15 10:50 AM, Dimi Tomov wrote:
> >> > From: Dimitar Tomov <dimi@tpm.dev>
> >> >
> >> > Some TPM 2.0 chips offer extra capabilities. This patch adds additional
> >> > configuration options to the wolftpm package, so such capabilities can
> >> > be available to the user. For example, the STMicroelectronics ST33 and
> >> > Nuvoton NPCT750 both offer secure GPIO. Due to chip differences,
> >> > wolfTPM
> >> > requires explicit configuration options to enable the extra
> >> > capabilities.
> >> >
> >> > Signed-off-by: Dimitar Tomov <dimi@tpm.dev>
> >> > ---
> >> > Changes v3 -> v4:
> >> > - Fix commit message. For some reason the update was not included in
> >> > patch v3.
> >> > Changes v2 -> v3:
> >> > - Better commit message
> >> > Changes v1 -> v2:
> >> > - Remove a not needed package description change
> >
> > You should set previous iterations as superseded in patchwork:
> > https://patchwork.ozlabs.org/project/buildroot/list/
> >
> >> > ---
> >> >  package/wolftpm/Config.in  | 12 ++++++++++++
> >> >  package/wolftpm/wolftpm.mk | 12 ++++++++++++
> >> >  2 files changed, 24 insertions(+)
> >> >
> >> > diff --git a/package/wolftpm/Config.in b/package/wolftpm/Config.in
> >> > index 0b964c3d7e..3027b7e33d 100644
> >> > --- a/package/wolftpm/Config.in
> >> > +++ b/package/wolftpm/Config.in
> >> > @@ -23,6 +23,18 @@ config BR2_PACKAGE_WOLFTPM_WOLFCRYPT
> >> >         encryption. Disabling this option is not recommended as it
> >> >         could create a security breach in most environments.
> >> >
> >> > +config BR2_PACKAGE_WOLFTPM_ST33
> >> > +     bool "st33"
> >> > +     default n
> >> > +     help
> >> > +       Enable support of TPM 2.0 extra functionality offered by the
> >> > STMicroelectronics ST33 chip.
> >
> > This line is too long (it should be wrapped to 72 characters).
> > make check-package will warn you about it
> >
> >> > +
> >> > +config BR2_PACKAGE_WOLFTPM_NUVOTON
> >> > +     bool "npct750"
> >> > +     default n
> >> > +     help
> >> > +       Enable support of TPM 2.0 extra functionality offered by the
> >> > Nuvoton NPCT750 chip.
> >
> > This line is also too long.
> >
> >> > +
> >> >  comment "wolfCrypt hooks need a toolchain w/ threads, dynamic library"
> >> >       depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
> >> >
> >> > diff --git a/package/wolftpm/wolftpm.mk b/package/wolftpm/wolftpm.mk
> >> > index a4a9edce85..d0423cd06b 100644
> >> > --- a/package/wolftpm/wolftpm.mk
> >> > +++ b/package/wolftpm/wolftpm.mk
> >> > @@ -35,4 +35,16 @@ else
> >> >  WOLFTPM_CONF_OPTS += --disable-wolfcrypt
> >> >  endif
> >> >
> >> > +ifeq ($(BR2_PACKAGE_WOLFTPM_ST33),y)
> >> > +WOLFTPM_CONF_OPTS += --enable-st33
> >> > +else
> >> > +WOLFTPM_CONF_OPTS += --disable-st33
> >> > +endif
> >> > +
> >> > +ifeq ($(BR2_PACKAGE_WOLFTPM_NPCT750),y)
> >> > +WOLFTPM_CONF_OPTS += --enable-nuvoton
> >> > +else
> >> > +WOLFTPM_CONF_OPTS += --disable-nuvoton
> >> > +endif
> >> > +
> >> >  $(eval $(autotools-package))
> >
> > Best Regards,
> >
> > Fabrice
>
> --
> Founder of TPM.dev
diff mbox series

Patch

diff --git a/package/wolftpm/Config.in b/package/wolftpm/Config.in
index 0b964c3d7e..3027b7e33d 100644
--- a/package/wolftpm/Config.in
+++ b/package/wolftpm/Config.in
@@ -23,6 +23,18 @@  config BR2_PACKAGE_WOLFTPM_WOLFCRYPT
 	  encryption. Disabling this option is not recommended as it
 	  could create a security breach in most environments.
 
+config BR2_PACKAGE_WOLFTPM_ST33
+	bool "st33"
+	default n
+	help
+	  Enable support of TPM 2.0 extra functionality offered by the STMicroelectronics ST33 chip.
+
+config BR2_PACKAGE_WOLFTPM_NUVOTON
+	bool "npct750"
+	default n
+	help
+	  Enable support of TPM 2.0 extra functionality offered by the Nuvoton NPCT750 chip.
+
 comment "wolfCrypt hooks need a toolchain w/ threads, dynamic library"
 	depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
 
diff --git a/package/wolftpm/wolftpm.mk b/package/wolftpm/wolftpm.mk
index a4a9edce85..d0423cd06b 100644
--- a/package/wolftpm/wolftpm.mk
+++ b/package/wolftpm/wolftpm.mk
@@ -35,4 +35,16 @@  else
 WOLFTPM_CONF_OPTS += --disable-wolfcrypt
 endif
 
+ifeq ($(BR2_PACKAGE_WOLFTPM_ST33),y)
+WOLFTPM_CONF_OPTS += --enable-st33
+else
+WOLFTPM_CONF_OPTS += --disable-st33
+endif
+
+ifeq ($(BR2_PACKAGE_WOLFTPM_NPCT750),y)
+WOLFTPM_CONF_OPTS += --enable-nuvoton
+else
+WOLFTPM_CONF_OPTS += --disable-nuvoton
+endif
+
 $(eval $(autotools-package))