diff mbox series

[1/3] package/apache: add brotli as optional dependency

Message ID 20220611121614.1172869-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/3] package/apache: add brotli as optional dependency | expand

Commit Message

Bernd Kuhls June 11, 2022, 12:16 p.m. UTC
Fixes:
http://autobuild.buildroot.net/results/90e/90e3a2aaf0ce0451b80c71743209797abeb83d0a/
http://autobuild.buildroot.net/results/006/006f94bb216a77f073a5670fa2f393c43f15a977/
http://autobuild.buildroot.net/results/dd6/dd69e665e51ce6b30e303a4d4670e9edbb159aea/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/apache/apache.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Arnout Vandecappelle June 14, 2022, 6:43 p.m. UTC | #1
On 11/06/2022 14:16, Bernd Kuhls wrote:
> Fixes:
> http://autobuild.buildroot.net/results/90e/90e3a2aaf0ce0451b80c71743209797abeb83d0a/
> http://autobuild.buildroot.net/results/006/006f94bb216a77f073a5670fa2f393c43f15a977/
> http://autobuild.buildroot.net/results/dd6/dd69e665e51ce6b30e303a4d4670e9edbb159aea/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

  Applied both to master, thanks.

  Regards,
  Arnout

> ---
>   package/apache/apache.mk | 7 +++++++
>   1 file changed, 7 insertions(+)
> 
> diff --git a/package/apache/apache.mk b/package/apache/apache.mk
> index b2c855aa36..a6fb59d26b 100644
> --- a/package/apache/apache.mk
> +++ b/package/apache/apache.mk
> @@ -45,6 +45,13 @@ APACHE_CONF_OPTS = \
>   	--with-mpm=$(APACHE_MPM) \
>   	--disable-luajit
>   
> +ifeq ($(BR2_PACKAGE_BROTLI),y)
> +APACHE_CONF_OPTS += --enable-brotli
> +APACHE_DEPENDENCIES += brotli
> +else
> +APACHE_CONF_OPTS += --disable-brotli
> +endif
> +
>   ifeq ($(BR2_PACKAGE_LIBXML2),y)
>   APACHE_DEPENDENCIES += libxml2
>   # Apache wants the path to the header file, where it can find
Peter Korsgaard July 13, 2022, 10:54 a.m. UTC | #2
On 11/06/2022 14.16, Bernd Kuhls wrote:
> Fixes:
> http://autobuild.buildroot.net/results/90e/90e3a2aaf0ce0451b80c71743209797abeb83d0a/
> http://autobuild.buildroot.net/results/006/006f94bb216a77f073a5670fa2f393c43f15a977/
> http://autobuild.buildroot.net/results/dd6/dd69e665e51ce6b30e303a4d4670e9edbb159aea/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Committed to 2022.02.x and 2022.05.x, thanks.
diff mbox series

Patch

diff --git a/package/apache/apache.mk b/package/apache/apache.mk
index b2c855aa36..a6fb59d26b 100644
--- a/package/apache/apache.mk
+++ b/package/apache/apache.mk
@@ -45,6 +45,13 @@  APACHE_CONF_OPTS = \
 	--with-mpm=$(APACHE_MPM) \
 	--disable-luajit
 
+ifeq ($(BR2_PACKAGE_BROTLI),y)
+APACHE_CONF_OPTS += --enable-brotli
+APACHE_DEPENDENCIES += brotli
+else
+APACHE_CONF_OPTS += --disable-brotli
+endif
+
 ifeq ($(BR2_PACKAGE_LIBXML2),y)
 APACHE_DEPENDENCIES += libxml2
 # Apache wants the path to the header file, where it can find