diff mbox series

[2/2] boot/optee-os: add support to build with python-pillow

Message ID 20220602090012.2008381-2-kory.maincent@bootlin.com
State Accepted
Headers show
Series [1/2] package/python-pillow: enable host package | expand

Commit Message

Kory Maincent June 2, 2022, 9 a.m. UTC
From: Kory Maincent <kory.maincent@bootlin.com>

SOC constructor version of optee-os may uses python-pillow to build the
Trusted User Interface feature.
Add support to build these specific versions by adding a new
BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_PILLOW option which will
select host-python-pillow dependency.

Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
---
 boot/optee-os/Config.in   | 7 +++++++
 boot/optee-os/optee-os.mk | 4 ++++
 2 files changed, 11 insertions(+)

Comments

Etienne Carriere June 3, 2022, 8 a.m. UTC | #1
Hello Kory,

On Thu, 2 Jun 2022 at 11:00, <kory.maincent@bootlin.com> wrote:
>
> From: Kory Maincent <kory.maincent@bootlin.com>
>
> SOC constructor version of optee-os may uses python-pillow to build the

s/uses/use/

> Trusted User Interface feature.
> Add support to build these specific versions by adding a new
> BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_PILLOW option which will
> select host-python-pillow dependency.
>
> Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
> ---

LGTM (Acked-by: Etienne Carriere <etienne.carriere@linaro.org>) with 2
minor spelling issues.



>  boot/optee-os/Config.in   | 7 +++++++
>  boot/optee-os/optee-os.mk | 4 ++++
>  2 files changed, 11 insertions(+)
>
> diff --git a/boot/optee-os/Config.in b/boot/optee-os/Config.in
> index fb8a189a75..b459393191 100644
> --- a/boot/optee-os/Config.in
> +++ b/boot/optee-os/Config.in
> @@ -72,6 +72,13 @@ config BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_CRYPTOGRAPHY
>           python-cryptography. Select this option if optee-os needs
>           python-cryptography to be built.
>
> +config BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_PILLOW
> +       bool "OP-TEE OS needs host-python-pillow"
> +       help
> +         OP-TEE OS version from SOC manufacturer may use python-pillow
> +         to build the Trusted User Interface feature.
> +         Select this option if optee-os need python-pillow to be built.

s/need/needs/

> +
>  config BR2_TARGET_OPTEE_OS_CORE
>         bool "Build core"
>         default y
> diff --git a/boot/optee-os/optee-os.mk b/boot/optee-os/optee-os.mk
> index 5313a1badc..88f14b48e4 100644
> --- a/boot/optee-os/optee-os.mk
> +++ b/boot/optee-os/optee-os.mk
> @@ -29,6 +29,10 @@ else
>  OPTEE_OS_DEPENDENCIES += host-python-pycryptodomex
>  endif
>
> +ifeq ($(BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_PILLOW),y)
> +OPTEE_OS_DEPENDENCIES += host-python-pillow
> +endif
> +
>  ifeq ($(BR2_TARGET_OPTEE_OS_NEEDS_DTC),y)
>  OPTEE_OS_DEPENDENCIES += host-dtc
>  endif
> --
> 2.25.1
>
diff mbox series

Patch

diff --git a/boot/optee-os/Config.in b/boot/optee-os/Config.in
index fb8a189a75..b459393191 100644
--- a/boot/optee-os/Config.in
+++ b/boot/optee-os/Config.in
@@ -72,6 +72,13 @@  config BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_CRYPTOGRAPHY
 	  python-cryptography. Select this option if optee-os needs
 	  python-cryptography to be built.
 
+config BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_PILLOW
+	bool "OP-TEE OS needs host-python-pillow"
+	help
+	  OP-TEE OS version from SOC manufacturer may use python-pillow
+	  to build the Trusted User Interface feature.
+	  Select this option if optee-os need python-pillow to be built.
+
 config BR2_TARGET_OPTEE_OS_CORE
 	bool "Build core"
 	default y
diff --git a/boot/optee-os/optee-os.mk b/boot/optee-os/optee-os.mk
index 5313a1badc..88f14b48e4 100644
--- a/boot/optee-os/optee-os.mk
+++ b/boot/optee-os/optee-os.mk
@@ -29,6 +29,10 @@  else
 OPTEE_OS_DEPENDENCIES += host-python-pycryptodomex
 endif
 
+ifeq ($(BR2_TARGET_OPTEE_OS_NEEDS_PYTHON_PILLOW),y)
+OPTEE_OS_DEPENDENCIES += host-python-pillow
+endif
+
 ifeq ($(BR2_TARGET_OPTEE_OS_NEEDS_DTC),y)
 OPTEE_OS_DEPENDENCIES += host-dtc
 endif