diff mbox series

[4/4] package/rtl8723ds: new package

Message ID 20220527103335.1968203-5-angelo@amarulasolutions.com
State Accepted
Headers show
Series Better wifi handling | expand

Commit Message

Angelo Compagnucci May 27, 2022, 10:33 a.m. UTC
This package adds a driver for Realtek RTL8723DS wifi chip.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
---
 package/Config.in              |  1 +
 package/rtl8723ds/Config.in    | 10 ++++++++++
 package/rtl8723ds/rtl8723ds.mk | 23 +++++++++++++++++++++++
 3 files changed, 34 insertions(+)
 create mode 100644 package/rtl8723ds/Config.in
 create mode 100644 package/rtl8723ds/rtl8723ds.mk

Comments

Thomas Petazzoni June 1, 2022, 7:55 p.m. UTC | #1
On Fri, 27 May 2022 12:33:35 +0200
Angelo Compagnucci <angelo@amarulasolutions.com> wrote:

> This package adds a driver for Realtek RTL8723DS wifi chip.
> 
> Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
> ---
>  package/Config.in              |  1 +
>  package/rtl8723ds/Config.in    | 10 ++++++++++
>  package/rtl8723ds/rtl8723ds.mk | 23 +++++++++++++++++++++++
>  3 files changed, 34 insertions(+)

This was missing an entry in the DEVELOPERS file.

> diff --git a/package/Config.in b/package/Config.in
> index 8892134133..52671dbf89 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -565,6 +565,7 @@ endmenu
>  	source "package/rtl8189es/Config.in"
>  	source "package/rtl8189fs/Config.in"
>  	source "package/rtl8723bs/Config.in"
> +	source "package/rtl8723ds/Config.in"
>  	source "package/rtl8723bu/Config.in"

Alphabetic ordering was not correct here (reported by check-package),
so I fixed that up.


> +RTL8723DS_VERSION = 76146e85847beb2427b1d4958fa275822f2b04ab
> +RTL8723DS_SITE = $(call github,lwfinger,rtl8723ds,$(RTL8723DS_VERSION))
> +RTL8723DS_LICENSE = GPL-2.0, proprietary (*.bin firmware blobs)

There are no firmware files in this Git repository, so it seems like
"proprietary (*.bin firmware blobs)" was copy/pasted from other rtlxxxx
packages. I dropped that, and kept only GPL-2.0.

Of course, if you have some evidence showing that there are some
proprietary firmware files in this package, let me know and we'll fix
things back.

Applied to next with those changes. Thanks!

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index 8892134133..52671dbf89 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -565,6 +565,7 @@  endmenu
 	source "package/rtl8189es/Config.in"
 	source "package/rtl8189fs/Config.in"
 	source "package/rtl8723bs/Config.in"
+	source "package/rtl8723ds/Config.in"
 	source "package/rtl8723bu/Config.in"
 	source "package/rtl8812au-aircrack-ng/Config.in"
 	source "package/rtl8821au/Config.in"
diff --git a/package/rtl8723ds/Config.in b/package/rtl8723ds/Config.in
new file mode 100644
index 0000000000..ef7dd39a68
--- /dev/null
+++ b/package/rtl8723ds/Config.in
@@ -0,0 +1,10 @@ 
+config BR2_PACKAGE_RTL8723DS
+	bool "rtl8723ds"
+	depends on BR2_LINUX_KERNEL
+	help
+	  rtl8723bs wifi driver
+
+	  https://github.com/lwfinger/rtl8723ds
+
+comment "rtl8723ds needs a Linux kernel to be built"
+	depends on !BR2_LINUX_KERNEL
diff --git a/package/rtl8723ds/rtl8723ds.mk b/package/rtl8723ds/rtl8723ds.mk
new file mode 100644
index 0000000000..dea403c8d6
--- /dev/null
+++ b/package/rtl8723ds/rtl8723ds.mk
@@ -0,0 +1,23 @@ 
+################################################################################
+#
+# rtl8723ds
+#
+################################################################################
+
+RTL8723DS_VERSION = 76146e85847beb2427b1d4958fa275822f2b04ab
+RTL8723DS_SITE = $(call github,lwfinger,rtl8723ds,$(RTL8723DS_VERSION))
+RTL8723DS_LICENSE = GPL-2.0, proprietary (*.bin firmware blobs)
+
+RTL8723DS_MODULE_MAKE_OPTS = \
+	CONFIG_RTL8723DS=m \
+	KVER=$(LINUX_VERSION_PROBED) \
+	KSRC=$(LINUX_DIR)
+
+define RTL8723DS_LINUX_CONFIG_FIXUPS
+	$(call KCONFIG_ENABLE_OPT,CONFIG_NET)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_WIRELESS)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_CFG80211)
+endef
+
+$(eval $(kernel-module))
+$(eval $(generic-package))