diff mbox series

[4/4] boot/uboot: bump to 2022.04

Message ID 20220521123838.2881-5-heiko.thiery@gmail.com
State Changes Requested
Headers show
Series U-Boot bump to 2022.04 | expand

Commit Message

Heiko Thiery May 21, 2022, 12:38 p.m. UTC
Since U-Boot 2022.04 a host dependency to gnutls is required.

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
 boot/uboot/Config.in | 4 ++--
 boot/uboot/uboot.mk  | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni May 30, 2022, 7:44 p.m. UTC | #1
Hello,

On Sat, 21 May 2022 14:38:44 +0200
Heiko Thiery <heiko.thiery@gmail.com> wrote:

> Since U-Boot 2022.04 a host dependency to gnutls is required.

Are you sure this is an unconditional dependency?

When I read tools/Makefile, I see:

HOSTLDLIBS_mkeficapsule += -lgnutls -luuid
hostprogs-$(CONFIG_TOOLS_MKEFICAPSULE) += mkeficapsule

so it's only configurations with CONFIG_TOOLS_MKEFICAPSULE=y that need
host-gnutls.

So unless I'm missing something, the host-gnutls dependency should not
be made a new mandatory dependency, and instead a "U-Boot needs
host-gnutls" option should be added, like
BR2_TARGET_UBOOT_NEEDS_OPENSSL.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 953c36135e..d525faea1c 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -41,7 +41,7 @@  choice
 	  Select the specific U-Boot version you want to use
 
 config BR2_TARGET_UBOOT_LATEST_VERSION
-	bool "2022.01"
+	bool "2022.04"
 
 config BR2_TARGET_UBOOT_CUSTOM_VERSION
 	bool "Custom version"
@@ -85,7 +85,7 @@  endif
 
 config BR2_TARGET_UBOOT_VERSION
 	string
-	default "2022.01"	if BR2_TARGET_UBOOT_LATEST_VERSION
+	default "2022.04"	if BR2_TARGET_UBOOT_LATEST_VERSION
 	default BR2_TARGET_UBOOT_CUSTOM_VERSION_VALUE \
 		if BR2_TARGET_UBOOT_CUSTOM_VERSION
 	default "custom"	if BR2_TARGET_UBOOT_CUSTOM_TARBALL
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index cb26fc8d3e..86e28004c4 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -17,7 +17,7 @@  UBOOT_CPE_ID_PRODUCT = u-boot
 UBOOT_INSTALL_IMAGES = YES
 
 # u-boot 2020.01+ needs make 4.0+
-UBOOT_DEPENDENCIES = host-pkgconf $(BR2_MAKE_HOST_DEPENDENCY)
+UBOOT_DEPENDENCIES = host-pkgconf host-gnutls $(BR2_MAKE_HOST_DEPENDENCY)
 UBOOT_MAKE = $(BR2_MAKE)
 
 ifeq ($(UBOOT_VERSION),custom)