diff mbox series

[1/1] package/bubblewrap: bump to version 0.6.2

Message ID 20220517233710.4172411-1-aperez@igalia.com
State Accepted
Headers show
Series [1/1] package/bubblewrap: bump to version 0.6.2 | expand

Commit Message

Adrian Perez de Castro May 17, 2022, 11:37 p.m. UTC
This version now allows to disable building tests, which allows dropping
the patch "0001-meson-add-tests-option.patch", and contains a few minor
fixes. Release notes can be found at:

  https://github.com/containers/bubblewrap/releases/tag/v0.6.2

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
---
 .../0001-meson-add-tests-option.patch         | 54 -------------------
 package/bubblewrap/bubblewrap.hash            |  4 +-
 package/bubblewrap/bubblewrap.mk              |  2 +-
 3 files changed, 3 insertions(+), 57 deletions(-)
 delete mode 100644 package/bubblewrap/0001-meson-add-tests-option.patch

Comments

Peter Korsgaard May 18, 2022, 7:19 a.m. UTC | #1
>>>>> "Adrian" == Adrian Perez de Castro <aperez@igalia.com> writes:

 > This version now allows to disable building tests, which allows dropping
 > the patch "0001-meson-add-tests-option.patch", and contains a few minor
 > fixes. Release notes can be found at:

 >   https://github.com/containers/bubblewrap/releases/tag/v0.6.2

 > Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/bubblewrap/0001-meson-add-tests-option.patch b/package/bubblewrap/0001-meson-add-tests-option.patch
deleted file mode 100644
index 32836f925d..0000000000
--- a/package/bubblewrap/0001-meson-add-tests-option.patch
+++ /dev/null
@@ -1,54 +0,0 @@ 
-From 34ea0ad841d6f9167db391c08e6cd51471fed6be Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sun, 3 Apr 2022 11:27:06 +0200
-Subject: [PATCH] meson: add tests option
-
-Allow the user to disable tests, for example to avoid the following
-build failure on mips32:
-
-FAILED: tests/try-syscall.p/try-syscall.c.o
-/home/autobuild/autobuild/instance-11/output-1/host/bin/mipsel-buildroot-linux-musl-gcc -Itests/try-syscall.p -Itests -I../tests -fdiagnostics-color=always -Wall -Winvalid-pch -Wextra -O3 -D_GNU_SOURCE -Werror=shadow -Werror=empty-body -Werror=strict-prototypes -Werror=missing-prototypes -Werror=implicit-function-declaration -Werror=pointer-arith -Werror=init-self -Werror=missing-declarations -Werror=return-type -Werror=overflow -Werror=int-conversion -Werror=incompatible-pointer-types -Werror=misleading-indentation -Werror=missing-include-dirs -Werror=aggregate-return -Werror=switch-default -Wswitch-enum -Wno-sign-compare -Wno-error=sign-compare -Wno-missing-field-initializers -Wno-error=missing-field-initializers -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -O1 -g0 -MD -MQ tests/try-syscall.p/try-syscall.c.o -MF tests/try-syscall.p/try-syscall.c.o.d -o tests/try-syscall.p/try-syscall.c.o -c ../tests/try-syscall.c
-../tests/try-syscall.c:34:5: error: #error "Unknown MIPS ABI"
-   34 | #   error "Unknown MIPS ABI"
-      |     ^~~~~
-
-Fixes:
- - http://autobuild.buildroot.org/results/cf0365354fc8c16e5871d561daae0fa5039d0bee
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Retrieved from:
-https://github.com/containers/bubblewrap/commit/34ea0ad841d6f9167db391c08e6cd51471fed6be]
----
- meson.build       | 4 +++-
- meson_options.txt | 6 ++++++
- 2 files changed, 9 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 5b63aa64..9277ac4e 100644
---- a/meson.build
-+++ b/meson.build
-@@ -152,4 +152,6 @@ if not meson.is_subproject()
-   subdir('completions')
- endif
- 
--subdir('tests')
-+if get_option('tests')
-+  subdir('tests')
-+endif
-diff --git a/meson_options.txt b/meson_options.txt
-index 2fa3a8c3..a136a3c3 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -38,6 +38,12 @@ option(
-   description : 'enable optional SELINUX support',
-   value : 'auto',
- )
-+option(
-+  'tests',
-+  type : 'boolean',
-+  description : 'build tests',
-+  value : 'true',
-+)
- option(
-   'zsh_completion',
-   type : 'feature',
diff --git a/package/bubblewrap/bubblewrap.hash b/package/bubblewrap/bubblewrap.hash
index c3bf4d8212..98fafc3679 100644
--- a/package/bubblewrap/bubblewrap.hash
+++ b/package/bubblewrap/bubblewrap.hash
@@ -1,5 +1,5 @@ 
-# From https://github.com/containers/bubblewrap/releases/tag/v0.6.1
-sha256  9609c7dc162bc68abc29abfab566934fdca37520a15ed01b675adcf3a4303282  bubblewrap-0.6.1.tar.xz
+# From https://github.com/containers/bubblewrap/releases/tag/v0.6.2
+sha256  8a0ec802d1b3e956c5bb0a40a81c9ce0b055a31bf30a8efa547433603b8af20b  bubblewrap-0.6.2.tar.xz
 
 # Hash for license files:
 sha256  b7993225104d90ddd8024fd838faf300bea5e83d91203eab98e29512acebd69c  COPYING
diff --git a/package/bubblewrap/bubblewrap.mk b/package/bubblewrap/bubblewrap.mk
index 81456e9e0d..91864d2b76 100644
--- a/package/bubblewrap/bubblewrap.mk
+++ b/package/bubblewrap/bubblewrap.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-BUBBLEWRAP_VERSION = 0.6.1
+BUBBLEWRAP_VERSION = 0.6.2
 BUBBLEWRAP_SITE = https://github.com/containers/bubblewrap/releases/download/v$(BUBBLEWRAP_VERSION)
 BUBBLEWRAP_SOURCE = bubblewrap-$(BUBBLEWRAP_VERSION).tar.xz
 BUBBLEWRAP_DEPENDENCIES = host-pkgconf libcap