diff mbox series

[04/19] package/x11r7/xdriver_xf86-video-amdgpu: needs libgbm

Message ID 20220514175612.2510884-4-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [01/19] package/x11r7/xserver_xorg-server: bump version to 21.1.3 | expand

Commit Message

Bernd Kuhls May 14, 2022, 5:55 p.m. UTC
The package depends on gbm:
https://gitlab.freedesktop.org/xorg/driver/xf86-video-amdgpu/-/blob/master/configure.ac#L75

For details see
http://lists.busybox.net/pipermail/buildroot/2022-April/641451.html

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/x11r7/xdriver_xf86-video-amdgpu/Config.in         | 8 +++-----
 .../xdriver_xf86-video-amdgpu.mk                          | 1 +
 2 files changed, 4 insertions(+), 5 deletions(-)

Comments

Thomas Petazzoni June 5, 2022, 10:01 p.m. UTC | #1
Hello,

On Sat, 14 May 2022 19:55:57 +0200
Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

> The package depends on gbm:
> https://gitlab.freedesktop.org/xorg/driver/xf86-video-amdgpu/-/blob/master/configure.ac#L75
> 
> For details see
> http://lists.busybox.net/pipermail/buildroot/2022-April/641451.html
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Could you clarify if this is a fix, or an improvement?

If I understand correctly the discussion at
http://lists.busybox.net/pipermail/buildroot/2022-April/641451.html,
this driver used to require mesa3d+dri+egl (which guaranteed to provide
libgbm), but now only requires libgbm. If this is correct, then this
patch is not a fix, but an improvement, because it makes this package
available in a larger set of configurations.

Could you clarify this?

> diff --git a/package/x11r7/xdriver_xf86-video-amdgpu/xdriver_xf86-video-amdgpu.mk b/package/x11r7/xdriver_xf86-video-amdgpu/xdriver_xf86-video-amdgpu.mk
> index c34af6faf1..ba4ab43db2 100644
> --- a/package/x11r7/xdriver_xf86-video-amdgpu/xdriver_xf86-video-amdgpu.mk
> +++ b/package/x11r7/xdriver_xf86-video-amdgpu/xdriver_xf86-video-amdgpu.mk
> @@ -11,6 +11,7 @@ XDRIVER_XF86_VIDEO_AMDGPU_LICENSE = MIT
>  XDRIVER_XF86_VIDEO_AMDGPU_LICENSE_FILES = COPYING
>  XDRIVER_XF86_VIDEO_AMDGPU_DEPENDENCIES = \
>  	libdrm \
> +	libgbm \
>  	xlib_libXcomposite \
>  	xorgproto \
>  	xserver_xorg-server

Interesting, we had a Config.in dependency on mesa, but it was not a
build dependency, but libgbm is?

Thomas
Bernd Kuhls June 6, 2022, 1:16 p.m. UTC | #2
Hi Thomas,

Am Mon, 6 Jun 2022 00:01:20 +0200 schrieb Thomas Petazzoni via buildroot:

> Could you clarify if this is a fix, or an improvement?

before answering your question I would like to say that the dependency 
situation in package/x11r7/ is a bit messy imho. Fixing autobuilder bugs, 
and there were lots of them in the mesa/x11 area, made sure that we have 
all necessary dependencies in place but, as in this case, we added 
sometimes too many dependencies, did not notice when bumping a package 
that its dependencies were loosened, are, as in this case, did not use 
the new libgbm virtual package in all places needed.

> If I understand correctly the discussion at
> http://lists.busybox.net/pipermail/buildroot/2022-April/641451.html,
> this driver used to require mesa3d+dri+egl (which guaranteed to provide
> libgbm), but now only requires libgbm.

Here we have such a current example for too many dependencies due to the 
addition of the virtual libgbm package which was added to buildroot long 
after this package was added.
Depending on mesa3d+dri+egl did the trick in earlier days ;) Upstream did 
not change its configure script: https://cgit.freedesktop.org/xorg/driver/
xf86-video-amdgpu/log/configure.ac

So this patch series can be considered as a follow-up to the addition of 
libgbm

>>  XDRIVER_XF86_VIDEO_AMDGPU_DEPENDENCIES = \
>>  	libdrm \
>> +	libgbm \
>>  	xlib_libXcomposite \
>>  	xorgproto \ xserver_xorg-server
> 
> Interesting, we had a Config.in dependency on mesa, but it was not a
> build dependency, but libgbm is?

Mesa3d, and therefore libgbm, is pulled in by the xserver_xorg-server 
package, but to make clear this package depends on libgbm I added that 
dependency:
https://gitlab.freedesktop.org/xorg/driver/xf86-video-amdgpu/-/blob/
master/configure.ac#L75

Regards, Bernd
diff mbox series

Patch

diff --git a/package/x11r7/xdriver_xf86-video-amdgpu/Config.in b/package/x11r7/xdriver_xf86-video-amdgpu/Config.in
index c42255f55c..fb23fc1fdf 100644
--- a/package/x11r7/xdriver_xf86-video-amdgpu/Config.in
+++ b/package/x11r7/xdriver_xf86-video-amdgpu/Config.in
@@ -1,8 +1,7 @@ 
 config BR2_PACKAGE_XDRIVER_XF86_VIDEO_AMDGPU
 	bool "xf86-video-amdgpu"
 	depends on BR2_USE_MMU # libdrm
-	depends on BR2_PACKAGE_MESA3D_DRI_DRIVER
-	depends on BR2_PACKAGE_MESA3D_OPENGL_EGL # gbm
+	depends on BR2_PACKAGE_HAS_LIBGBM
 	select BR2_PACKAGE_LIBDRM
 	select BR2_PACKAGE_LIBDRM_AMDGPU
 	select BR2_PACKAGE_LIBEPOXY
@@ -11,7 +10,6 @@  config BR2_PACKAGE_XDRIVER_XF86_VIDEO_AMDGPU
 	help
 	  AMD GPU video driver
 
-comment "xf86-video-amdgpu needs egl/opengl support from mesa3d"
+comment "xf86-video-amdgpu needs GBM"
 	depends on BR2_USE_MMU
-	depends on !BR2_PACKAGE_MESA3D_OPENGL_EGL || \
-		!BR2_PACKAGE_MESA3D_DRI_DRIVER
+	depends on !BR2_PACKAGE_HAS_LIBGBM
diff --git a/package/x11r7/xdriver_xf86-video-amdgpu/xdriver_xf86-video-amdgpu.mk b/package/x11r7/xdriver_xf86-video-amdgpu/xdriver_xf86-video-amdgpu.mk
index c34af6faf1..ba4ab43db2 100644
--- a/package/x11r7/xdriver_xf86-video-amdgpu/xdriver_xf86-video-amdgpu.mk
+++ b/package/x11r7/xdriver_xf86-video-amdgpu/xdriver_xf86-video-amdgpu.mk
@@ -11,6 +11,7 @@  XDRIVER_XF86_VIDEO_AMDGPU_LICENSE = MIT
 XDRIVER_XF86_VIDEO_AMDGPU_LICENSE_FILES = COPYING
 XDRIVER_XF86_VIDEO_AMDGPU_DEPENDENCIES = \
 	libdrm \
+	libgbm \
 	xlib_libXcomposite \
 	xorgproto \
 	xserver_xorg-server