diff mbox series

[1/1] package/alchemy: add host-pkgconf dependency

Message ID 20220513202855.752024-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/alchemy: add host-pkgconf dependency | expand

Commit Message

Fabrice Fontaine May 13, 2022, 8:28 p.m. UTC
host-pkgconf is a mandatory dependency since the addition of the package
in commit 7f1f3f87868fa333833dbba9f4f07adc338b34ed resulting in the
following ulog build failure:

/home/buildroot/autobuild/run/instance-0/output-1/per-package/ulog/host/opt/alchemy/check.mk:36: *** 'pkg-config' is required.  Stop.

An other option would be to set TARGET_OS to baremetal but it could have
unexpected side-effects such as removing -fPIC for arm targets

Fixes:
 - http://autobuild.buildroot.org/results/c731fe0e9bdbfce0823f9c48641f1ed710fa6125

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/alchemy/alchemy.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Romain Naour May 14, 2022, 3:17 p.m. UTC | #1
Hello Fabrice,

Le 13/05/2022 à 22:28, Fabrice Fontaine a écrit :
> host-pkgconf is a mandatory dependency since the addition of the package
> in commit 7f1f3f87868fa333833dbba9f4f07adc338b34ed resulting in the
> following ulog build failure:
> 
> /home/buildroot/autobuild/run/instance-0/output-1/per-package/ulog/host/opt/alchemy/check.mk:36: *** 'pkg-config' is required.  Stop.
> 
> An other option would be to set TARGET_OS to baremetal but it could have
> unexpected side-effects such as removing -fPIC for arm targets
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/c731fe0e9bdbfce0823f9c48641f1ed710fa6125

Also fixes:
https://gitlab.com/buildroot.org/buildroot/-/jobs/2429013555

> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Reviewed-by: Romain Naour <romain.naour@gmail.com>

Best regards,
Romain


> ---
>  package/alchemy/alchemy.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/alchemy/alchemy.mk b/package/alchemy/alchemy.mk
> index 18cdd0a645..10d1068ac4 100644
> --- a/package/alchemy/alchemy.mk
> +++ b/package/alchemy/alchemy.mk
> @@ -8,7 +8,7 @@ ALCHEMY_VERSION = d95b3c38cd37814a1b98d0bbf813de7adaaecfbc
>  ALCHEMY_SITE = $(call github,Parrot-Developers,alchemy,$(ALCHEMY_VERSION))
>  ALCHEMY_LICENSE = BSD-3-Clause (Alchemy), GPL-2.0 (kconfig)
>  ALCHEMY_LICENSE_FILES = COPYING README
> -HOST_ALCHEMY_DEPENDENCIES = host-python3
> +HOST_ALCHEMY_DEPENDENCIES = host-pkgconf host-python3
>  
>  ALCHEMY_HOME = $(HOST_DIR)/opt/alchemy
>  ALCHEMY_SDK_BASEDIR = $(STAGING_DIR)/usr/lib/alchemy/sdk
> @@ -35,6 +35,7 @@ ALCHEMY_TARGET_ENV = \
>  	ALCHEMY_HOME=$(ALCHEMY_HOME) \
>  	ALCHEMY_WORKSPACE_DIR="$(@D)" \
>  	ALCHEMY_TARGET_OUT=alchemy-out \
> +	PKGCONFIG_BIN=$(PKG_CONFIG_HOST_BINARY) \
>  	TARGET_OS=linux \
>  	TARGET_OS_FLAVOUR=buildroot \
>  	TARGET_CROSS="$(TARGET_CROSS)" \
Herve Codina May 16, 2022, 8:14 a.m. UTC | #2
On Sat, 14 May 2022 17:17:12 +0200
Romain Naour <romain.naour@gmail.com> wrote:

> Hello Fabrice,
> 
> Le 13/05/2022 à 22:28, Fabrice Fontaine a écrit :
> > host-pkgconf is a mandatory dependency since the addition of the package
> > in commit 7f1f3f87868fa333833dbba9f4f07adc338b34ed resulting in the
> > following ulog build failure:
> > 
> > /home/buildroot/autobuild/run/instance-0/output-1/per-package/ulog/host/opt/alchemy/check.mk:36: *** 'pkg-config' is required.  Stop.
> > 
> > An other option would be to set TARGET_OS to baremetal but it could have
> > unexpected side-effects such as removing -fPIC for arm targets
> > 
> > Fixes:
> >  - http://autobuild.buildroot.org/results/c731fe0e9bdbfce0823f9c48641f1ed710fa6125  
> 
> Also fixes:
> https://gitlab.com/buildroot.org/buildroot/-/jobs/2429013555
> 
> > 
> > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>  
> 
> Reviewed-by: Romain Naour <romain.naour@gmail.com>
> 
> Best regards,
> Romain

Reviewed-by: Herve Codina <herve.codina@bootlin.com>

Thanks,
Hervé
Yann E. MORIN May 17, 2022, 8:45 p.m. UTC | #3
Fabrice, All,

On 2022-05-13 22:28 +0200, Fabrice Fontaine spake thusly:
> host-pkgconf is a mandatory dependency since the addition of the package
> in commit 7f1f3f87868fa333833dbba9f4f07adc338b34ed resulting in the
> following ulog build failure:
> 
> /home/buildroot/autobuild/run/instance-0/output-1/per-package/ulog/host/opt/alchemy/check.mk:36: *** 'pkg-config' is required.  Stop.
> 
> An other option would be to set TARGET_OS to baremetal but it could have
> unexpected side-effects such as removing -fPIC for arm targets
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/c731fe0e9bdbfce0823f9c48641f1ed710fa6125
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/alchemy/alchemy.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/alchemy/alchemy.mk b/package/alchemy/alchemy.mk
> index 18cdd0a645..10d1068ac4 100644
> --- a/package/alchemy/alchemy.mk
> +++ b/package/alchemy/alchemy.mk
> @@ -8,7 +8,7 @@ ALCHEMY_VERSION = d95b3c38cd37814a1b98d0bbf813de7adaaecfbc
>  ALCHEMY_SITE = $(call github,Parrot-Developers,alchemy,$(ALCHEMY_VERSION))
>  ALCHEMY_LICENSE = BSD-3-Clause (Alchemy), GPL-2.0 (kconfig)
>  ALCHEMY_LICENSE_FILES = COPYING README
> -HOST_ALCHEMY_DEPENDENCIES = host-python3
> +HOST_ALCHEMY_DEPENDENCIES = host-pkgconf host-python3
>  
>  ALCHEMY_HOME = $(HOST_DIR)/opt/alchemy
>  ALCHEMY_SDK_BASEDIR = $(STAGING_DIR)/usr/lib/alchemy/sdk
> @@ -35,6 +35,7 @@ ALCHEMY_TARGET_ENV = \
>  	ALCHEMY_HOME=$(ALCHEMY_HOME) \
>  	ALCHEMY_WORKSPACE_DIR="$(@D)" \
>  	ALCHEMY_TARGET_OUT=alchemy-out \
> +	PKGCONFIG_BIN=$(PKG_CONFIG_HOST_BINARY) \
>  	TARGET_OS=linux \
>  	TARGET_OS_FLAVOUR=buildroot \
>  	TARGET_CROSS="$(TARGET_CROSS)" \
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard May 29, 2022, 8:48 a.m. UTC | #4
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > host-pkgconf is a mandatory dependency since the addition of the package
 > in commit 7f1f3f87868fa333833dbba9f4f07adc338b34ed resulting in the
 > following ulog build failure:

 > /home/buildroot/autobuild/run/instance-0/output-1/per-package/ulog/host/opt/alchemy/check.mk:36:
 > *** 'pkg-config' is required.  Stop.

 > An other option would be to set TARGET_OS to baremetal but it could have
 > unexpected side-effects such as removing -fPIC for arm targets

 > Fixes:
 >  - http://autobuild.buildroot.org/results/c731fe0e9bdbfce0823f9c48641f1ed710fa6125

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/alchemy/alchemy.mk b/package/alchemy/alchemy.mk
index 18cdd0a645..10d1068ac4 100644
--- a/package/alchemy/alchemy.mk
+++ b/package/alchemy/alchemy.mk
@@ -8,7 +8,7 @@  ALCHEMY_VERSION = d95b3c38cd37814a1b98d0bbf813de7adaaecfbc
 ALCHEMY_SITE = $(call github,Parrot-Developers,alchemy,$(ALCHEMY_VERSION))
 ALCHEMY_LICENSE = BSD-3-Clause (Alchemy), GPL-2.0 (kconfig)
 ALCHEMY_LICENSE_FILES = COPYING README
-HOST_ALCHEMY_DEPENDENCIES = host-python3
+HOST_ALCHEMY_DEPENDENCIES = host-pkgconf host-python3
 
 ALCHEMY_HOME = $(HOST_DIR)/opt/alchemy
 ALCHEMY_SDK_BASEDIR = $(STAGING_DIR)/usr/lib/alchemy/sdk
@@ -35,6 +35,7 @@  ALCHEMY_TARGET_ENV = \
 	ALCHEMY_HOME=$(ALCHEMY_HOME) \
 	ALCHEMY_WORKSPACE_DIR="$(@D)" \
 	ALCHEMY_TARGET_OUT=alchemy-out \
+	PKGCONFIG_BIN=$(PKG_CONFIG_HOST_BINARY) \
 	TARGET_OS=linux \
 	TARGET_OS_FLAVOUR=buildroot \
 	TARGET_CROSS="$(TARGET_CROSS)" \