diff mbox series

[1/3] package/rtl8189fs: enable required kernel options

Message ID 20220509060721.2726047-2-geomatsi@gmail.com
State Accepted
Headers show
Series package/rtl8189s: fixes for autobuilder failures | expand

Commit Message

Sergey Matyukevich May 9, 2022, 6:07 a.m. UTC
Enable Linux kernel configuration options required by the driver.
Those are wireless networking and sdio support.

Fixes:
- http://autobuild.buildroot.net/results/ed6e29e44333ccae2728ca3321ff876c3056eada/

Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>
---
 package/rtl8189fs/rtl8189fs.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Peter Korsgaard May 28, 2022, 7:17 p.m. UTC | #1
>>>>> "Sergey" == Sergey Matyukevich <geomatsi@gmail.com> writes:

 > Enable Linux kernel configuration options required by the driver.
 > Those are wireless networking and sdio support.

 > Fixes:
 > - http://autobuild.buildroot.net/results/ed6e29e44333ccae2728ca3321ff876c3056eada/

 > Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>

Committed to 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/rtl8189fs/rtl8189fs.mk b/package/rtl8189fs/rtl8189fs.mk
index 40b735c21b..0cca0b751d 100644
--- a/package/rtl8189fs/rtl8189fs.mk
+++ b/package/rtl8189fs/rtl8189fs.mk
@@ -13,5 +13,12 @@  RTL8189FS_MODULE_MAKE_OPTS = \
 	KVER=$(LINUX_VERSION_PROBED) \
 	KSRC=$(LINUX_DIR)
 
+define RTL8189FS_LINUX_CONFIG_FIXUPS
+	$(call KCONFIG_ENABLE_OPT,CONFIG_WIRELESS)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_CFG80211)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_MAC80211)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_MMC)
+endef
+
 $(eval $(kernel-module))
 $(eval $(generic-package))