diff mbox series

[1/1] package/dhcp: untar internal bind

Message ID 20220419161130.3431492-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/dhcp: untar internal bind | expand

Commit Message

Fabrice Fontaine April 19, 2022, 4:11 p.m. UTC
Untar internal bind so libtool patches will be applied on bind's
libtool. This will fix:
 - installation of some libraries such as libisccfg. Indeed, if libtool
   is not patched those libraries will be "relinked" and so not
   installed.
 - build failures with riscv and or1k:

  Invalid configuration `riscv64-buildroot-linux-musl': machine `riscv64-buildroot' not recognized

  Invalid configuration `or1k-buildroot-linux-uclibc': machine `or1k-buildroot' not recognized

Fixes:
 - http://autobuild.buildroot.org/results/d25b76e628ffe5293c6bc1fd467a6b8966cb1bc2
 - http://autobuild.buildroot.org/results/ba3258d8df00a7626784189125f0202fb161c40e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/dhcp/dhcp.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Jan Havran April 20, 2022, 9:13 a.m. UTC | #1
V Tue, Apr 19, 2022 at 06:11:30PM +0200, Fabrice Fontaine napsal(a):
> Untar internal bind so libtool patches will be applied on bind's
> libtool. This will fix:
>  - installation of some libraries such as libisccfg. Indeed, if libtool
>    is not patched those libraries will be "relinked" and so not
>    installed.
>  - build failures with riscv and or1k:
> 
>   Invalid configuration `riscv64-buildroot-linux-musl': machine `riscv64-buildroot' not recognized
> 
>   Invalid configuration `or1k-buildroot-linux-uclibc': machine `or1k-buildroot' not recognized
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/d25b76e628ffe5293c6bc1fd467a6b8966cb1bc2
>  - http://autobuild.buildroot.org/results/ba3258d8df00a7626784189125f0202fb161c40e
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

With this patch I no longer get following error and dhcp works for me:
dhclient: error while loading shared libraries: libisccfg.so.163: cannot open shared object file: No such file or directory

Tested on ARM/PineCube.

Tested-by: Jan Havran <havran.jan@email.cz>

> ---
>  package/dhcp/dhcp.mk | 7 +++++++
>  1 file changed, 7 insertions(+)
> 
> diff --git a/package/dhcp/dhcp.mk b/package/dhcp/dhcp.mk
> index e6f4c419f4..f815c6c802 100644
> --- a/package/dhcp/dhcp.mk
> +++ b/package/dhcp/dhcp.mk
> @@ -14,6 +14,13 @@ DHCP_CPE_ID_VENDOR = isc
>  # internal bind does not support parallel builds.
>  DHCP_MAKE = $(MAKE1)
>  
> +# untar internal bind so libtool patches will be applied on bind's libtool
> +define DHCP_UNTAR_INTERNAL_BIND
> +	$(TAR) xf $(@D)/bind/bind.tar.gz -C $(@D)/bind/
> +endef
> +
> +DHCP_POST_EXTRACT_HOOKS = DHCP_UNTAR_INTERNAL_BIND
> +
>  # use libtool-enabled configure.ac
>  define DHCP_LIBTOOL_AUTORECONF
>  	cp $(@D)/configure.ac+lt $(@D)/configure.ac
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
yegorslists--- via buildroot April 21, 2022, 9:24 a.m. UTC | #2
On 4/19/22 7:11 PM, Fabrice Fontaine wrote:
> Untar internal bind so libtool patches will be applied on bind's
> libtool. This will fix:
>   - installation of some libraries such as libisccfg. Indeed, if libtool
>     is not patched those libraries will be "relinked" and so not
>     installed.
>   - build failures with riscv and or1k:
> 
>    Invalid configuration `riscv64-buildroot-linux-musl': machine `riscv64-buildroot' not recognized
> 
>    Invalid configuration `or1k-buildroot-linux-uclibc': machine `or1k-buildroot' not recognized
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/d25b76e628ffe5293c6bc1fd467a6b8966cb1bc2
>   - http://autobuild.buildroot.org/results/ba3258d8df00a7626784189125f0202fb161c40e
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Tested-by: Eugen Hristev <eugen.hristev@microchip.com>

Tested on AT91 boards

> ---
>   package/dhcp/dhcp.mk | 7 +++++++
>   1 file changed, 7 insertions(+)
> 
> diff --git a/package/dhcp/dhcp.mk b/package/dhcp/dhcp.mk
> index e6f4c419f4..f815c6c802 100644
> --- a/package/dhcp/dhcp.mk
> +++ b/package/dhcp/dhcp.mk
> @@ -14,6 +14,13 @@ DHCP_CPE_ID_VENDOR = isc
>   # internal bind does not support parallel builds.
>   DHCP_MAKE = $(MAKE1)
> 
> +# untar internal bind so libtool patches will be applied on bind's libtool
> +define DHCP_UNTAR_INTERNAL_BIND
> +       $(TAR) xf $(@D)/bind/bind.tar.gz -C $(@D)/bind/
> +endef
> +
> +DHCP_POST_EXTRACT_HOOKS = DHCP_UNTAR_INTERNAL_BIND
> +
>   # use libtool-enabled configure.ac
>   define DHCP_LIBTOOL_AUTORECONF
>          cp $(@D)/configure.ac+lt $(@D)/configure.ac
> --
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
>
Yann E. MORIN April 21, 2022, 7:32 p.m. UTC | #3
Fabrice, All,

On 2022-04-19 18:11 +0200, Fabrice Fontaine spake thusly:
> Untar internal bind so libtool patches will be applied on bind's
> libtool. This will fix:
>  - installation of some libraries such as libisccfg. Indeed, if libtool
>    is not patched those libraries will be "relinked" and so not
>    installed.
>  - build failures with riscv and or1k:
> 
>   Invalid configuration `riscv64-buildroot-linux-musl': machine `riscv64-buildroot' not recognized
> 
>   Invalid configuration `or1k-buildroot-linux-uclibc': machine `or1k-buildroot' not recognized

dhcp, the package that keeps on giving...

Jan, Eugen, what keeps you from switching away from dhcp?

> Fixes:
>  - http://autobuild.buildroot.org/results/d25b76e628ffe5293c6bc1fd467a6b8966cb1bc2
>  - http://autobuild.buildroot.org/results/ba3258d8df00a7626784189125f0202fb161c40e
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/dhcp/dhcp.mk | 7 +++++++
>  1 file changed, 7 insertions(+)
> 
> diff --git a/package/dhcp/dhcp.mk b/package/dhcp/dhcp.mk
> index e6f4c419f4..f815c6c802 100644
> --- a/package/dhcp/dhcp.mk
> +++ b/package/dhcp/dhcp.mk
> @@ -14,6 +14,13 @@ DHCP_CPE_ID_VENDOR = isc
>  # internal bind does not support parallel builds.
>  DHCP_MAKE = $(MAKE1)
>  
> +# untar internal bind so libtool patches will be applied on bind's libtool
> +define DHCP_UNTAR_INTERNAL_BIND
> +	$(TAR) xf $(@D)/bind/bind.tar.gz -C $(@D)/bind/
> +endef
> +
> +DHCP_POST_EXTRACT_HOOKS = DHCP_UNTAR_INTERNAL_BIND
> +
>  # use libtool-enabled configure.ac
>  define DHCP_LIBTOOL_AUTORECONF
>  	cp $(@D)/configure.ac+lt $(@D)/configure.ac
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
yegorslists--- via buildroot April 21, 2022, 7:34 p.m. UTC | #4
On 4/21/22 10:32 PM, Yann E. MORIN wrote:
> Fabrice, All,
> 
> On 2022-04-19 18:11 +0200, Fabrice Fontaine spake thusly:
>> Untar internal bind so libtool patches will be applied on bind's
>> libtool. This will fix:
>>   - installation of some libraries such as libisccfg. Indeed, if libtool
>>     is not patched those libraries will be "relinked" and so not
>>     installed.
>>   - build failures with riscv and or1k:
>>
>>    Invalid configuration `riscv64-buildroot-linux-musl': machine `riscv64-buildroot' not recognized
>>
>>    Invalid configuration `or1k-buildroot-linux-uclibc': machine `or1k-buildroot' not recognized
> 
> dhcp, the package that keeps on giving...
> 
> Jan, Eugen, what keeps you from switching away from dhcp?

Actually this time it was the dhcpd that was failing .. not the client.
It looks like they share some library.

BTW, can you point some more different packets that we can use instead 
of the client and of the server that are due to be deprecated ?

Thanks

> 
>> Fixes:
>>   - http://autobuild.buildroot.org/results/d25b76e628ffe5293c6bc1fd467a6b8966cb1bc2
>>   - http://autobuild.buildroot.org/results/ba3258d8df00a7626784189125f0202fb161c40e
>>
>> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> 
> Applied to master, thanks.
> 
> Regards,
> Yann E. MORIN.
> 
>> ---
>>   package/dhcp/dhcp.mk | 7 +++++++
>>   1 file changed, 7 insertions(+)
>>
>> diff --git a/package/dhcp/dhcp.mk b/package/dhcp/dhcp.mk
>> index e6f4c419f4..f815c6c802 100644
>> --- a/package/dhcp/dhcp.mk
>> +++ b/package/dhcp/dhcp.mk
>> @@ -14,6 +14,13 @@ DHCP_CPE_ID_VENDOR = isc
>>   # internal bind does not support parallel builds.
>>   DHCP_MAKE = $(MAKE1)
>>
>> +# untar internal bind so libtool patches will be applied on bind's libtool
>> +define DHCP_UNTAR_INTERNAL_BIND
>> +     $(TAR) xf $(@D)/bind/bind.tar.gz -C $(@D)/bind/
>> +endef
>> +
>> +DHCP_POST_EXTRACT_HOOKS = DHCP_UNTAR_INTERNAL_BIND
>> +
>>   # use libtool-enabled configure.ac
>>   define DHCP_LIBTOOL_AUTORECONF
>>        cp $(@D)/configure.ac+lt $(@D)/configure.ac
>> --
>> 2.35.1
>>
>> _______________________________________________
>> buildroot mailing list
>> buildroot@buildroot.org
>> https://lists.buildroot.org/mailman/listinfo/buildroot
> 
> --
> .-----------------.--------------------.------------------.--------------------.
> |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
> | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
> | +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
> | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
> '------------------------------^-------^------------------^--------------------'
>
Peter Korsgaard May 24, 2022, 8:20 a.m. UTC | #5
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Untar internal bind so libtool patches will be applied on bind's
 > libtool. This will fix:
 >  - installation of some libraries such as libisccfg. Indeed, if libtool
 >    is not patched those libraries will be "relinked" and so not
 >    installed.
 >  - build failures with riscv and or1k:

 >   Invalid configuration `riscv64-buildroot-linux-musl': machine `riscv64-buildroot' not recognized

 >   Invalid configuration `or1k-buildroot-linux-uclibc': machine `or1k-buildroot' not recognized

 > Fixes:
 >  - http://autobuild.buildroot.org/results/d25b76e628ffe5293c6bc1fd467a6b8966cb1bc2
 >  - http://autobuild.buildroot.org/results/ba3258d8df00a7626784189125f0202fb161c40e

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/dhcp/dhcp.mk b/package/dhcp/dhcp.mk
index e6f4c419f4..f815c6c802 100644
--- a/package/dhcp/dhcp.mk
+++ b/package/dhcp/dhcp.mk
@@ -14,6 +14,13 @@  DHCP_CPE_ID_VENDOR = isc
 # internal bind does not support parallel builds.
 DHCP_MAKE = $(MAKE1)
 
+# untar internal bind so libtool patches will be applied on bind's libtool
+define DHCP_UNTAR_INTERNAL_BIND
+	$(TAR) xf $(@D)/bind/bind.tar.gz -C $(@D)/bind/
+endef
+
+DHCP_POST_EXTRACT_HOOKS = DHCP_UNTAR_INTERNAL_BIND
+
 # use libtool-enabled configure.ac
 define DHCP_LIBTOOL_AUTORECONF
 	cp $(@D)/configure.ac+lt $(@D)/configure.ac