diff mbox series

[1/1] package/dhcp: fix install of internal bind libraries

Message ID 20220414164109.1724873-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/dhcp: fix install of internal bind libraries | expand

Commit Message

Fabrice Fontaine April 14, 2022, 4:41 p.m. UTC
Internal bind libraries are not installed to target since commit
0c8dd6ebd656e06cf99a63eb93343715f4853503 resulting in the following
runtime failure:

Starting DHCP server: /usr/sbin/dhcpd: error while loading shared libraries: libirs.so.161: cannot open shared object file: No such file or directory

RANLIB must also be set to avoid the following build failure at install
step:

libtool: install: arceb-buildroot-linux-uclibc-ranlib /home/fabrice/buildroot/output/per-package/dhcp/target/usr/lib/libisccfg.a
/home/fabrice/buildroot/output/build/dhcp-4.4.3/bind/bind-9.11.36/libtool: line 1719: arceb-buildroot-linux-uclibc-ranlib: command not found

Fixes:
 - No autobuilder failures (reported by Eugen.Hristev@microchip.com)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/dhcp/dhcp.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard April 14, 2022, 8:14 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Internal bind libraries are not installed to target since commit
 > 0c8dd6ebd656e06cf99a63eb93343715f4853503 resulting in the following
 > runtime failure:

 > Starting DHCP server: /usr/sbin/dhcpd: error while loading shared
 > libraries: libirs.so.161: cannot open shared object file: No such file
 > or directory

 > RANLIB must also be set to avoid the following build failure at install
 > step:

 > libtool: install: arceb-buildroot-linux-uclibc-ranlib
 > /home/fabrice/buildroot/output/per-package/dhcp/target/usr/lib/libisccfg.a
 > /home/fabrice/buildroot/output/build/dhcp-4.4.3/bind/bind-9.11.36/libtool:
 > line 1719: arceb-buildroot-linux-uclibc-ranlib: command not found

 > Fixes:
 >  - No autobuilder failures (reported by Eugen.Hristev@microchip.com)

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard May 22, 2022, 10:03 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Internal bind libraries are not installed to target since commit
 > 0c8dd6ebd656e06cf99a63eb93343715f4853503 resulting in the following
 > runtime failure:

 > Starting DHCP server: /usr/sbin/dhcpd: error while loading shared
 > libraries: libirs.so.161: cannot open shared object file: No such file
 > or directory

 > RANLIB must also be set to avoid the following build failure at install
 > step:

 > libtool: install: arceb-buildroot-linux-uclibc-ranlib
 > /home/fabrice/buildroot/output/per-package/dhcp/target/usr/lib/libisccfg.a
 > /home/fabrice/buildroot/output/build/dhcp-4.4.3/bind/bind-9.11.36/libtool:
 > line 1719: arceb-buildroot-linux-uclibc-ranlib: command not found

 > Fixes:
 >  - No autobuilder failures (reported by Eugen.Hristev@microchip.com)

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/dhcp/dhcp.mk b/package/dhcp/dhcp.mk
index c58592cc45..6ac9ed0147 100644
--- a/package/dhcp/dhcp.mk
+++ b/package/dhcp/dhcp.mk
@@ -28,7 +28,8 @@  DHCP_BIND_EXTRA_CONFIG = \
 	BUILD_CC='$(HOSTCC)' \
 	BUILD_CFLAGS='$(HOST_CFLAGS)' \
 	BUILD_CPPFLAGS='$(HOST_CPPFLAGS)' \
-	BUILD_LDFLAGS='$(HOST_LDFLAGS)'
+	BUILD_LDFLAGS='$(HOST_LDFLAGS)' \
+	RANLIB='$(TARGET_RANLIB)'
 
 DHCP_CONF_ENV += ac_cv_prog_AWK=$(HOST_DIR)/bin/gawk
 
@@ -70,6 +71,7 @@  DHCP_CONF_OPTS += --enable-delayed-ack
 endif
 
 define DHCP_INSTALL_LIBS
+	$(MAKE) -C $(@D)/bind install-bind DESTDIR=$(TARGET_DIR)
 	$(MAKE) -C $(@D)/common install-exec DESTDIR=$(TARGET_DIR)
 	$(MAKE) -C $(@D)/omapip install-exec DESTDIR=$(TARGET_DIR)
 endef